package/procps: bump version and rename to procps-ng
procps is getting replaced by procps-ng, and there are new versions available! procps-ng is now an autotools package, so get rid of our custom build/install rules. Remove most patches, except for one that still half-applies, so update and rename it. procps is dead, long live procps-ng! Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
7de0d049b2
commit
5cd1c4feb5
@ -98,6 +98,16 @@ comment "build, or run, in unpredictable ways. "
|
||||
comment "----------------------------------------------------"
|
||||
endif
|
||||
|
||||
###############################################################################
|
||||
comment "Legacy options removed in 2014.08"
|
||||
|
||||
config BR2_PACKAGE_PROCPS
|
||||
bool "procps has been replaced by procps-ng"
|
||||
select BR2_PACKAGE_PROCPS_NG
|
||||
select BR2_LEGACY
|
||||
help
|
||||
The procps package has been replaced by the equivalent procps-ng.
|
||||
|
||||
###############################################################################
|
||||
comment "Legacy options removed in 2014.05"
|
||||
|
||||
|
@ -1106,7 +1106,7 @@ source "package/numactl/Config.in"
|
||||
source "package/nut/Config.in"
|
||||
source "package/polkit/Config.in"
|
||||
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
|
||||
source "package/procps/Config.in"
|
||||
source "package/procps-ng/Config.in"
|
||||
source "package/psmisc/Config.in"
|
||||
endif
|
||||
source "package/quota/Config.in"
|
||||
|
@ -1,8 +1,8 @@
|
||||
config BR2_PACKAGE_PROCPS
|
||||
bool "procps"
|
||||
config BR2_PACKAGE_PROCPS_NG
|
||||
bool "procps-ng"
|
||||
select BR2_PACKAGE_NCURSES
|
||||
help
|
||||
Standard informational utilities and process-handling tools.
|
||||
Provides things like kill, ps, uptime, free, top, etc...
|
||||
|
||||
http://procps.sourceforge.net/
|
||||
http://sourceforge.net/projects/procps-ng/
|
16
package/procps-ng/procps-ng-0000-remove-index.patch
Normal file
16
package/procps-ng/procps-ng-0000-remove-index.patch
Normal file
@ -0,0 +1,16 @@
|
||||
sysctl: remove use of legacy index()
|
||||
|
||||
[yann.morin.1998@free.fr: adapt to procps-ng]
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
diff -durN procps-v3.3.9.orig/sysctl.c procps-v3.3.9/sysctl.c
|
||||
--- procps-v3.3.9.orig/sysctl.c 2013-12-03 12:16:18.000000000 +0100
|
||||
+++ procps-v3.3.9/sysctl.c 2014-05-31 00:45:00.869748741 +0200
|
||||
@@ -794,7 +794,7 @@
|
||||
program_invocation_short_name);
|
||||
|
||||
for ( ; *argv; argv++) {
|
||||
- if (WriteMode || index(*argv, '='))
|
||||
+ if (WriteMode || strchr(*argv, '='))
|
||||
ReturnCode += WriteSetting(*argv);
|
||||
else
|
||||
ReturnCode += ReadSetting(*argv);
|
15
package/procps-ng/procps-ng.mk
Normal file
15
package/procps-ng/procps-ng.mk
Normal file
@ -0,0 +1,15 @@
|
||||
################################################################################
|
||||
#
|
||||
# procps
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PROCPS_NG_VERSION = 3.3.9
|
||||
PROCPS_NG_SOURCE = procps-ng-$(PROCPS_NG_VERSION).tar.xz
|
||||
PROCPS_NG_SITE = http://downloads.sourceforge.net/project/procps-ng/Production
|
||||
PROCPS_NG_LICENSE = GPLv2+, libproc and libps LGPLv2+
|
||||
PROCPS_NG_LICENSE_FILES = COPYING COPYING.LIB
|
||||
|
||||
PROCPS_NG_DEPENDENCIES = ncurses
|
||||
|
||||
$(eval $(autotools-package))
|
@ -1,23 +0,0 @@
|
||||
[PATCH] procps: fix build with make 3.82
|
||||
|
||||
Equivalent to upstream fix:
|
||||
http://procps.cvs.sourceforge.net/viewvc/procps/procps/Makefile?r1=1.70&r2=1.71
|
||||
|
||||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: procps-3.2.8/Makefile
|
||||
===================================================================
|
||||
--- procps-3.2.8.orig/Makefile
|
||||
+++ procps-3.2.8/Makefile
|
||||
@@ -174,7 +174,7 @@
|
||||
# want this rule first, use := on ALL, and ALL not filled in yet
|
||||
all: do_all
|
||||
|
||||
--include */module.mk
|
||||
+-include proc/module.mk ps/module.mk
|
||||
|
||||
do_all: $(ALL)
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -u procps-3.2.5/Makefile procps-3.2.5-patched/Makefile
|
||||
--- procps-3.2.5/Makefile 2005-01-25 22:55:26.000000000 -0600
|
||||
+++ procps-3.2.5-patched/Makefile 2007-07-05 23:09:24.251423681 -0500
|
||||
@@ -70,9 +70,7 @@
|
||||
CURSES := -lncurses
|
||||
|
||||
# Preprocessor flags.
|
||||
-PKG_CPPFLAGS := -D_GNU_SOURCE -I proc
|
||||
-CPPFLAGS := -I/usr/include/ncurses
|
||||
-ALL_CPPFLAGS := $(PKG_CPPFLAGS) $(CPPFLAGS)
|
||||
+ALL_CPPFLAGS := -D_GNU_SOURCE -I proc
|
||||
|
||||
# Left out -Wconversion due to noise in glibc headers.
|
||||
# Left out -Wunreachable-code and -Wdisabled-optimization
|
||||
@@ -91,11 +89,9 @@
|
||||
-Wstrict-prototypes -Wmissing-prototypes
|
||||
# Note that some stuff below is conditional on CFLAGS containing
|
||||
# an option that starts with "-g". (-g, -g2, -g3, -ggdb, etc.)
|
||||
-CFLAGS := -O2 -s
|
||||
ALL_CFLAGS := $(PKG_CFLAGS) $(CFLAGS)
|
||||
|
||||
PKG_LDFLAGS := -Wl,-warn-common
|
||||
-LDFLAGS :=
|
||||
ALL_LDFLAGS := $(PKG_LDFLAGS) $(LDFLAGS)
|
||||
|
||||
############ Add some extra flags if gcc allows
|
@ -1,21 +0,0 @@
|
||||
diff -ur procps-3.2.5/sysctl.c procps-3.2.5-patched/sysctl.c
|
||||
--- procps-3.2.5/sysctl.c 2005-01-05 15:00:47.000000000 -0600
|
||||
+++ procps-3.2.5-patched/sysctl.c 2006-12-04 19:51:36.272843000 -0600
|
||||
@@ -272,7 +272,7 @@
|
||||
return 0;
|
||||
} /* end if */
|
||||
|
||||
- equals = index(setting, '=');
|
||||
+ equals = strchr(setting, '=');
|
||||
|
||||
if (!equals) {
|
||||
fprintf(stderr, ERR_NO_EQUALS, setting);
|
||||
@@ -498,7 +498,7 @@
|
||||
if (NameOnly && Quiet) // nonsense
|
||||
return Usage(me);
|
||||
SwitchesAllowed = false;
|
||||
- if (WriteMode || index(*argv, '='))
|
||||
+ if (WriteMode || strchr(*argv, '='))
|
||||
ReturnCode = WriteSetting(*argv);
|
||||
else
|
||||
ReturnCode = ReadSetting(*argv);
|
@ -1,29 +0,0 @@
|
||||
--- procps-3.2.7/proc/escape.c 2005-01-06 07:50:26.000000000 +1100
|
||||
+++ procps-3.2.7.fixed/proc/escape.c 2008-09-09 11:55:57.000000000 +1000
|
||||
@@ -15,7 +15,7 @@
|
||||
#include "escape.h"
|
||||
#include "readproc.h"
|
||||
|
||||
-#if (__GNU_LIBRARY__ >= 6)
|
||||
+#if (__GNU_LIBRARY__ >= 6) && (!defined(__UCLIBC__) || defined(__UCLIBC_HAS_WCHAR__))
|
||||
# include <wchar.h>
|
||||
# include <wctype.h>
|
||||
# include <stdlib.h> /* MB_CUR_MAX */
|
||||
@@ -23,7 +23,7 @@
|
||||
# include <langinfo.h>
|
||||
#endif
|
||||
|
||||
-#if (__GNU_LIBRARY__ >= 6)
|
||||
+#if (__GNU_LIBRARY__ >= 6) && (!defined(__UCLIBC__) || defined(__UCLIBC_HAS_WCHAR__))
|
||||
static int escape_str_utf8(char *restrict dst, const char *restrict src, int bufsize, int *maxcells){
|
||||
int my_cells = 0;
|
||||
int my_bytes = 0;
|
||||
@@ -123,7 +123,7 @@
|
||||
"********************************"
|
||||
"********************************";
|
||||
|
||||
-#if (__GNU_LIBRARY__ >= 6)
|
||||
+#if (__GNU_LIBRARY__ >= 6) && (!defined(__UCLIBC__) || defined(__UCLIBC_HAS_WCHAR__))
|
||||
static int utf_init=0;
|
||||
|
||||
if(utf_init==0){
|
@ -1,25 +0,0 @@
|
||||
################################################################################
|
||||
#
|
||||
# procps
|
||||
#
|
||||
################################################################################
|
||||
|
||||
PROCPS_VERSION = 3.2.8
|
||||
PROCPS_SITE = http://procps.sourceforge.net/
|
||||
PROCPS_LICENSE = GPLv2+, libproc and libps LGPLv2+
|
||||
PROCPS_LICENSE_FILES = COPYING COPYING.LIB
|
||||
|
||||
PROCPS_DEPENDENCIES = ncurses
|
||||
|
||||
define PROCPS_BUILD_CMDS
|
||||
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
|
||||
endef
|
||||
|
||||
define PROCPS_INSTALL_TARGET_CMDS
|
||||
mkdir -p $(addprefix $(TARGET_DIR)/,usr/bin bin sbin) \
|
||||
$(addprefix $(TARGET_DIR)/usr/share/man/,man1 man5 man8)
|
||||
$(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) lib64=lib install=install \
|
||||
ldconfig=true install
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user