package/fio: bump version to 3.27
Removed patches which were applied upstream. Upstream added optional support for libnfs: https://git.kernel.dk/cgit/fio/commit/?id=9326926bef943245c244eb0e6129ae046a3719a9 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
f1775574b8
commit
5c78889210
@ -1,49 +0,0 @@
|
||||
From 5e8865c0e08861558c1253c521dc9098d0c773ee Mon Sep 17 00:00:00 2001
|
||||
From: Jens Axboe <axboe@kernel.dk>
|
||||
Date: Mon, 16 Mar 2020 08:30:36 -0600
|
||||
Subject: [PATCH] t/io_uring: don't use *rand48_r() variants
|
||||
|
||||
Not available on all platforms.
|
||||
|
||||
Signed-off-by: Jens Axboe <axboe@kernel.dk>
|
||||
|
||||
[Patch from upstream
|
||||
https://github.com/axboe/fio/commit/5e8865c0e08861558c1253c521dc9098d0c773ee]
|
||||
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
|
||||
---
|
||||
t/io_uring.c | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/t/io_uring.c b/t/io_uring.c
|
||||
index e84a2b6b..d48db1e9 100644
|
||||
--- a/t/io_uring.c
|
||||
+++ b/t/io_uring.c
|
||||
@@ -63,7 +63,6 @@ struct file {
|
||||
struct submitter {
|
||||
pthread_t thread;
|
||||
int ring_fd;
|
||||
- struct drand48_data rand;
|
||||
struct io_sq_ring sq_ring;
|
||||
struct io_uring_sqe *sqes;
|
||||
struct io_cq_ring cq_ring;
|
||||
@@ -170,7 +169,7 @@ static void init_io(struct submitter *s, unsigned index)
|
||||
}
|
||||
f->pending_ios++;
|
||||
|
||||
- lrand48_r(&s->rand, &r);
|
||||
+ r = lrand48();
|
||||
offset = (r % (f->max_blocks - 1)) * BS;
|
||||
|
||||
if (register_files) {
|
||||
@@ -286,7 +285,7 @@ static void *submitter_fn(void *data)
|
||||
|
||||
printf("submitter=%d\n", gettid());
|
||||
|
||||
- srand48_r(pthread_self(), &s->rand);
|
||||
+ srand48(pthread_self());
|
||||
|
||||
prepped = 0;
|
||||
do {
|
||||
--
|
||||
2.20.1
|
||||
|
@ -1,33 +0,0 @@
|
||||
From e1985f9097f37748efdc29239eb3fb6a00b12f27 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sat, 23 May 2020 19:07:40 +0200
|
||||
Subject: [PATCH] Makefile: fix build of io_uring on sh4
|
||||
|
||||
SuperH compile currently fails with:
|
||||
|
||||
/usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sh4-buildroot-linux-uclibc/8.3.0/../../../../sh4-buildroot-linux-uclibc/bin/ld: t/io_uring.o: in function `submitter_fn':
|
||||
/usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-0/output-1/build/fio-3.19/t/io_uring.c:131: undefined reference to `arch_flags'
|
||||
/usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sh4-buildroot-linux-uclibc/8.3.0/../../../../sh4-buildroot-linux-uclibc/bin/ld: /usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-0/output-1/build/fio-3.19/t/io_uring.c:367: undefined reference to `arch_flags'
|
||||
collect2: error: ld returned 1 exit status
|
||||
|
||||
Fix that by ensuring we have a stub arch.o with the necessary arch flags
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Retrieved from:
|
||||
https://github.com/axboe/fio/commit/e1985f9097f37748efdc29239eb3fb6a00b12f27]
|
||||
---
|
||||
Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index f1e984f5f..e39621954 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -283,6 +283,7 @@ T_PIPE_ASYNC_OBJS = t/read-to-pipe-async.o
|
||||
T_PIPE_ASYNC_PROGS = t/read-to-pipe-async
|
||||
|
||||
T_IOU_RING_OBJS = t/io_uring.o
|
||||
+T_IOU_RING_OBJS += t/arch.o
|
||||
T_IOU_RING_PROGS = t/io_uring
|
||||
|
||||
T_MEMLOCK_OBJS = t/memlock.o
|
@ -1,4 +1,4 @@
|
||||
# Locally computed
|
||||
sha256 a2f885834900f554127718716338914791f5d72800b6f9e3edf173b94b5a2e4e fio-3.19.tar.gz
|
||||
sha256 da9826f07a003656ea070d359c90f752db8c3216ced9ff865242eed1a1db93bc fio-3.27.tar.gz
|
||||
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
|
||||
sha256 8a240c1ad13d1fe3e58588643d81d0695899be4a669fe6d8fafa76ca6a89db2c MORAL-LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
FIO_VERSION = 3.19
|
||||
FIO_VERSION = 3.27
|
||||
FIO_SITE = http://brick.kernel.dk/snaps
|
||||
FIO_LICENSE = GPL-2.0
|
||||
FIO_LICENSE_FILES = COPYING MORAL-LICENSE
|
||||
@ -13,6 +13,10 @@ ifeq ($(BR2_PACKAGE_LIBAIO),y)
|
||||
FIO_DEPENDENCIES += libaio
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_LIBNFS),y)
|
||||
FIO_DEPENDENCIES += libnfs
|
||||
endif
|
||||
|
||||
ifeq ($(BR2_PACKAGE_NUMACTL),y)
|
||||
FIO_DEPENDENCIES += numactl
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user