board/kontron/pitx-imx8m: add U-Boot 2022.04 patch
The patch is required to fix an issue in U-Boot for linking the mkeficapsule tool against -luuid and -lgnutls. Fixes: https://gitlab.com/buildroot.org/buildroot/-/jobs/2720001065 Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
39a19ee2e2
commit
5bdf0799df
@ -0,0 +1,33 @@
|
||||
From f3523977e8f5f6b2173708777001332431ebc609 Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Thiery <heiko.thiery@gmail.com>
|
||||
Date: Tue, 19 Jul 2022 16:17:09 +0200
|
||||
Subject: [PATCH 1/2] tools: mkeficapsule: use pkg-config to get -luuid and -lgnutls
|
||||
|
||||
Instead of hardcoding -luuid -lgnutls as the flags needed to build
|
||||
mkeficapsule, use pkg-config when available.
|
||||
|
||||
We gracefully fallback on the previous behavior of hardcoding -luuid
|
||||
-lgnutls if pkg-config is not available or fails with an error.
|
||||
|
||||
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
|
||||
---
|
||||
tools/Makefile | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index 9f2339666a..9f6b282ad8 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -242,7 +242,8 @@ hostprogs-$(CONFIG_MIPS) += mips-relocs
|
||||
hostprogs-$(CONFIG_ASN1_COMPILER) += asn1_compiler
|
||||
HOSTCFLAGS_asn1_compiler.o = -idirafter $(srctree)/include
|
||||
|
||||
-HOSTLDLIBS_mkeficapsule += -lgnutls -luuid
|
||||
+HOSTLDLIBS_mkeficapsule += \
|
||||
+ $(shell pkg-config --libs gnutls uuid 2> /dev/null || echo "-lgnutls -luuid")
|
||||
hostprogs-$(CONFIG_TOOLS_MKEFICAPSULE) += mkeficapsule
|
||||
|
||||
# We build some files with extra pedantic flags to try to minimize things
|
||||
--
|
||||
2.30.2
|
||||
|
Loading…
Reference in New Issue
Block a user