package/harfbuzz: bump to version 2.7.4
remove merged patch Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
parent
9425ec501f
commit
5bb5f077a1
@ -26,7 +26,7 @@ diff --git a/meson.build b/meson.build
|
|||||||
index bf3925db..6d263d48 100644
|
index bf3925db..6d263d48 100644
|
||||||
--- a/meson.build
|
--- a/meson.build
|
||||||
+++ b/meson.build
|
+++ b/meson.build
|
||||||
@@ -284,13 +284,15 @@ endif
|
@@ -281,13 +281,15 @@ endif
|
||||||
# threads
|
# threads
|
||||||
thread_dep = null_dep
|
thread_dep = null_dep
|
||||||
if host_machine.system() != 'windows'
|
if host_machine.system() != 'windows'
|
@ -1,33 +0,0 @@
|
|||||||
From 432dfd0a1d8fe0a8df89e7ce828c520c7758f10c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
Date: Thu, 24 Sep 2020 21:00:34 +0200
|
|
||||||
Subject: [PATCH] src/meson.build: allow introspection when cross-compiling
|
|
||||||
|
|
||||||
introspection can be enabled when cross-compiling on certains conditions
|
|
||||||
(for example it is supported by buildroot)
|
|
||||||
|
|
||||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
||||||
[Upstream status: https://github.com/harfbuzz/harfbuzz/pull/2692]
|
|
||||||
---
|
|
||||||
src/meson.build | 5 -----
|
|
||||||
1 file changed, 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/meson.build b/src/meson.build
|
|
||||||
index 19290245..7db43508 100644
|
|
||||||
--- a/src/meson.build
|
|
||||||
+++ b/src/meson.build
|
|
||||||
@@ -637,11 +637,6 @@ if have_gobject
|
|
||||||
gir = find_program('g-ir-scanner', required: get_option('introspection'))
|
|
||||||
build_gir = gir.found()
|
|
||||||
|
|
||||||
- build_gir = build_gir and not meson.is_cross_build()
|
|
||||||
- if not build_gir and get_option('introspection').enabled()
|
|
||||||
- error('Introspection support is requested but it isn\'t available in cross builds')
|
|
||||||
- endif
|
|
||||||
-
|
|
||||||
build_gir = build_gir and get_option('default_library') != 'static'
|
|
||||||
if not build_gir and get_option('introspection').enabled()
|
|
||||||
error('Introspection support is requested but the default library option should be shared or both')
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
@ -1,3 +1,3 @@
|
|||||||
# Locally computed
|
# Locally computed
|
||||||
sha256 b8c048d7c2964a12f2c80deb6634dfc836b603dd12bf0d0a3df1627698e220ce harfbuzz-2.7.2.tar.xz
|
sha256 6ad11d653347bd25d8317589df4e431a2de372c0cf9be3543368e07ec23bb8e7 harfbuzz-2.7.4.tar.xz
|
||||||
sha256 beb3f017ceb41387667f78237a7cecf84defa0ed257c505894663d6a9f13211b COPYING
|
sha256 beb3f017ceb41387667f78237a7cecf84defa0ed257c505894663d6a9f13211b COPYING
|
||||||
|
@ -4,7 +4,7 @@
|
|||||||
#
|
#
|
||||||
################################################################################
|
################################################################################
|
||||||
|
|
||||||
HARFBUZZ_VERSION = 2.7.2
|
HARFBUZZ_VERSION = 2.7.4
|
||||||
HARFBUZZ_SITE = https://github.com/harfbuzz/harfbuzz/releases/download/$(HARFBUZZ_VERSION)
|
HARFBUZZ_SITE = https://github.com/harfbuzz/harfbuzz/releases/download/$(HARFBUZZ_VERSION)
|
||||||
HARFBUZZ_SOURCE = harfbuzz-$(HARFBUZZ_VERSION).tar.xz
|
HARFBUZZ_SOURCE = harfbuzz-$(HARFBUZZ_VERSION).tar.xz
|
||||||
HARFBUZZ_LICENSE = MIT, ISC (ucdn library)
|
HARFBUZZ_LICENSE = MIT, ISC (ucdn library)
|
||||||
|
Loading…
Reference in New Issue
Block a user