package/mpd: bump to version 0.20.3

Remove patch #2 which has been applied upstream.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Jörg Krause 2017-01-27 10:12:27 +01:00 committed by Peter Korsgaard
parent ae84d56331
commit 5a8530af9e
3 changed files with 2 additions and 43 deletions

View File

@ -1,41 +0,0 @@
From 6ef588b2c230eae15f7f2563eca9d5f40c78d1d0 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
Date: Wed, 11 Jan 2017 21:06:37 +0100
Subject: [PATCH] Makefile.am: fix linking xiph with ogg
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The internal static xiph library needs to link with libogg. Otherwise
building mpd will fail:
```
/mips-linux-gnu/bin/ld: libxiph.a(libxiph_a-OggVisitor.o): undefined
reference to symbol 'ogg_stream_packetout'
```
Upstream status: Pending
http://mailman.blarg.de/pipermail/mpd-devel/2017-January/000594.html
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
Makefile.am | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index e0202b0cc..9030e68fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -614,7 +614,8 @@ libxiph_a_SOURCES += \
src/lib/xiph/OggStreamState.hxx
endif
-XIPH_LIBS = libxiph.a
+XIPH_LIBS = libxiph.a \
+ $(OGG_LIBS)
endif
--
2.11.0

View File

@ -1,2 +1,2 @@
# Locally calculated after checking pgp signature
sha256 552a87d71c2981baeddf28c1856a7e071ea0236dd38bc75ec25d58529605ff77 mpd-0.20.2.tar.xz
sha256 2238c1233f5318800ede7c37eeaf705c04920315de572dc666aff6ca682eb0f9 mpd-0.20.3.tar.xz

View File

@ -5,7 +5,7 @@
################################################################################
MPD_VERSION_MAJOR = 0.20
MPD_VERSION = $(MPD_VERSION_MAJOR).2
MPD_VERSION = $(MPD_VERSION_MAJOR).3
MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
MPD_SITE = http://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
MPD_DEPENDENCIES = host-pkgconf boost