package/libuhttpd: disable -Werror
Disable -Werror to fix the following build failure raised at least since bump to version 3.9.0 in commite76d9868c9
and81db1fa371
: /home/autobuild/autobuild/instance-8/output-1/build/libuhttpd-3.14.1/src/file.c: In function '__serve_file': /home/autobuild/autobuild/instance-8/output-1/build/libuhttpd-3.14.1/src/file.c:322:50: error: format '%llu' expects argument of type 'long long unsigned int', but argument 4 has type '__off_t' {aka 'long int'} [-Werror=format=] 322 | conn->send_header(conn, "Content-Range", "bytes */%" PRIu64, st->st_size); | ^~~~~~~~~~~ ~~~~~~~~~~~ | | | __off_t {aka long int} In file included from /home/autobuild/autobuild/instance-8/output-1/build/libuhttpd-3.14.1/src/file.c:36: /home/autobuild/autobuild/instance-8/output-1/per-package/libuhttpd/host/mips64el-buildroot-linux-uclibc/sysroot/usr/include/inttypes.h:91:41: note: format string is defined here 91 | # define PRIu64 __PRI64_PREFIX "u" cc1: all warnings being treated as errors Fixes:e76d9868c9
- http://autobuild.buildroot.org/results/46349a1409f9cff027b462456078284459e75511 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
2e6e121496
commit
5961b21918
@ -0,0 +1,30 @@
|
||||
From c0f2260d8b7e435bce765e7ac91d51f1b349b87b Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 10 Mar 2024 13:43:12 +0100
|
||||
Subject: [PATCH] CMakeLists.txt: add BUILD_WERROR option
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Upstream: https://github.com/zhaojh329/libuhttpd/commit/c0f2260d8b7e435bce765e7ac91d51f1b349b87b
|
||||
---
|
||||
CMakeLists.txt | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6fb9651..6719e5f 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -7,7 +7,13 @@ include(CheckLibraryExists)
|
||||
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/Modules/")
|
||||
|
||||
add_definitions(-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64)
|
||||
-add_compile_options(-O -Wall -Werror --std=gnu99)
|
||||
+add_compile_options(-O -Wall --std=gnu99)
|
||||
+
|
||||
+option(BUILD_WERROR "Build with -Werror" ON)
|
||||
+
|
||||
+if(BUILD_WERROR)
|
||||
+ add_compile_options(-Werror)
|
||||
+endif()
|
||||
|
||||
option(BUILD_STATIC "Build static library" OFF)
|
||||
|
@ -10,6 +10,7 @@ LIBUHTTPD_LICENSE = MIT
|
||||
LIBUHTTPD_LICENSE_FILES = LICENSE
|
||||
LIBUHTTPD_INSTALL_STAGING = YES
|
||||
LIBUHTTPD_DEPENDENCIES = libev
|
||||
LIBUHTTPD_CONF_OPTS = -DBUILD_WERROR=OFF
|
||||
|
||||
ifeq ($(BR2_PACKAGE_OPENSSL),y)
|
||||
LIBUHTTPD_DEPENDENCIES += openssl
|
||||
|
Loading…
Reference in New Issue
Block a user