package/supertux: bump to version 0.6.2
- Drop patches (already in version)
- Update hash of data/AUTHORS and add CC-BY-SA-4.0 license:
ca4ff139ca
https://github.com/SuperTux/supertux/blob/v0.6.2/NEWS.md
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
d73401347b
commit
5951883cf9
@ -1,81 +0,0 @@
|
||||
From cfcd478fe69ca1b3923f388a349a4f67ac2c03aa Mon Sep 17 00:00:00 2001
|
||||
From: Shawn Anastasio <shawn@anastas.io>
|
||||
Date: Sun, 3 Feb 2019 13:22:57 -0600
|
||||
Subject: [PATCH] Fix build on PowerPC
|
||||
|
||||
On PowerPC-based architectures, SDL includes the altivec.h header
|
||||
for SIMD intrinsics. Unfortunately, altivec.h defines some types which
|
||||
conflict with C++ types like bool and std::vector. This commit adds
|
||||
a wrapper for altivec.h which resolves these conflicts and allows
|
||||
supertux to build and run.
|
||||
|
||||
Tested on a ppc64le workstation.
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Retrieved from:
|
||||
https://github.com/SuperTux/supertux/pull/1056/commits/cfcd478fe69ca1b3923f388a349a4f67ac2c03aa]
|
||||
---
|
||||
CMakeLists.txt | 15 ++++++++++++++-
|
||||
src/ppc/altivec.h | 6 ++++++
|
||||
2 files changed, 20 insertions(+), 1 deletion(-)
|
||||
create mode 100644 src/ppc/altivec.h
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 70b9673b50..b9b6ea3ea6 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -376,6 +376,11 @@ endif()
|
||||
|
||||
include(ConfigureChecks)
|
||||
|
||||
+# Include altivec wrapper on ppc
|
||||
+if(CMAKE_SYSTEM_PROCESSOR MATCHES "^ppc.*")
|
||||
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/src/ppc)
|
||||
+endif()
|
||||
+
|
||||
|
||||
## Also build external/squirrel
|
||||
|
||||
@@ -420,6 +425,13 @@ if(NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/external/tinygettext/CMakeLists.txt)
|
||||
message(FATAL_ERROR "tinygettext submodule is not checked out or ${CMAKE_CURRENT_SOURCE_DIR}/external/tinygettext/CMakeLists.txt is missing")
|
||||
endif()
|
||||
|
||||
+# Include altivec wrapper on ppc
|
||||
+if(CMAKE_SYSTEM_PROCESSOR MATCHES "^ppc.*")
|
||||
+ set(TINYGETTEXT_CXX_FLAGS "-isystem ${CMAKE_CURRENT_SOURCE_DIR}/src/ppc ${CMAKE_CXX_FLAGS}")
|
||||
+else()
|
||||
+ set(TINYGETTEXT_CXX_FLAGS "${CMAKE_CXX_FLAGS}")
|
||||
+endif()
|
||||
+
|
||||
set(TINYGETTEXT_PREFIX ${CMAKE_BINARY_DIR}/tinygettext/)
|
||||
ExternalProject_Add(tinygettext
|
||||
SOURCE_DIR "${CMAKE_SOURCE_DIR}/external/tinygettext/"
|
||||
@@ -428,7 +440,7 @@ ExternalProject_Add(tinygettext
|
||||
-DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
|
||||
-DCMAKE_C_FLAGS=${CMAKE_C_FLAGS}
|
||||
-DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
|
||||
- -DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS}
|
||||
+ -DCMAKE_CXX_FLAGS=${TINYGETTEXT_CXX_FLAGS}
|
||||
-DBUILD_SHARED_LIBS=OFF
|
||||
-DHAVE_SDL=ON
|
||||
-DVCPKG_BUILD=${VCPKG_BUILD}
|
||||
@@ -443,6 +455,7 @@ set_target_properties(tinygettext_lib PROPERTIES IMPORTED_LOCATION "${TINYGETTEX
|
||||
|
||||
include_directories(SYSTEM ${TINYGETTEXT_PREFIX}/include)
|
||||
|
||||
+
|
||||
## external/SDL_ttf with patches
|
||||
find_package(Freetype REQUIRED)
|
||||
find_package(RAQM)
|
||||
diff --git a/src/ppc/altivec.h b/src/ppc/altivec.h
|
||||
new file mode 100644
|
||||
index 0000000000..7ede8246ed
|
||||
--- /dev/null
|
||||
+++ b/src/ppc/altivec.h
|
||||
@@ -0,0 +1,6 @@
|
||||
+#include_next <altivec.h>
|
||||
+
|
||||
+// The altivec headers redefine vector and bool which conflict
|
||||
+// with C++'s bool type and std::vector. Undefine them here.
|
||||
+#undef vector
|
||||
+#undef bool
|
@ -1,25 +0,0 @@
|
||||
From 4221d54385b69d6c40eff2c67bc6bad7ed165a44 Mon Sep 17 00:00:00 2001
|
||||
From: Lars Wendler <polynomial-c@gentoo.org>
|
||||
Date: Sat, 9 May 2020 03:04:02 +0200
|
||||
Subject: [PATCH] Fix build with boost-1.73
|
||||
|
||||
[Retrieved from:
|
||||
https://github.com/SuperTux/supertux/commit/4221d54385b69d6c40eff2c67bc6bad7ed165a44]
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
src/editor/object_settings.hpp | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/editor/object_settings.hpp b/src/editor/object_settings.hpp
|
||||
index bc9049a94e..15b77b1e46 100644
|
||||
--- a/src/editor/object_settings.hpp
|
||||
+++ b/src/editor/object_settings.hpp
|
||||
@@ -22,6 +22,8 @@
|
||||
|
||||
#include "editor/object_option.hpp"
|
||||
|
||||
+#include <algorithm>
|
||||
+
|
||||
class Color;
|
||||
enum class Direction;
|
||||
enum class WalkMode;
|
@ -1,4 +1,4 @@
|
||||
# Locally calculated
|
||||
sha256 c4c3e5fa6f90e87b8c5ad6b22a179e9a9839bf997e7f219e22bbcd1c97223ac0 SuperTux-v0.6.0-Source.tar.gz
|
||||
sha256 26a9e56ea2d284148849f3239177d777dda5b675a10ab2d76ee65854c91ff598 SuperTux-v0.6.2-Source.tar.gz
|
||||
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.txt
|
||||
sha256 35c61f69239ff2f55fe0fa5dee5bad6bff311a07c47fa049552e0973a47c07bb data/AUTHORS
|
||||
sha256 09645215102c1013a1ef8c16a30bacdb9a78924ca064372290405fabd3e7074d data/AUTHORS
|
||||
|
@ -4,13 +4,13 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
SUPERTUX_VERSION = 0.6.0
|
||||
SUPERTUX_VERSION = 0.6.2
|
||||
SUPERTUX_SITE = https://github.com/SuperTux/supertux/releases/download/v$(SUPERTUX_VERSION)
|
||||
SUPERTUX_SOURCE = SuperTux-v$(SUPERTUX_VERSION)-Source.tar.gz
|
||||
|
||||
# Supertux itself is GPL-3.0+, but it bundles a few libraries with different
|
||||
# licenses (sexp-cpp, squirrel, tinygettext) which are linked statically.
|
||||
SUPERTUX_LICENSE = GPL-3.0+ (code), CC-BY-SA-2.0, CC-BY-SA-3.0, GPL-2.0+ (images music sounds)
|
||||
SUPERTUX_LICENSE = GPL-3.0+ (code), CC-BY-SA-2.0, CC-BY-SA-3.0, CC-BY-SA-4.0, GPL-2.0+ (images music sounds)
|
||||
SUPERTUX_LICENSE_FILES = LICENSE.txt data/AUTHORS
|
||||
|
||||
# Use bundled squirrel, tinygettext sexp-cpp packages which are hardcoded in
|
||||
|
Loading…
Reference in New Issue
Block a user