diff --git a/package/cannelloni/0001-Add-missing-cstdio-include.patch b/package/cannelloni/0001-Add-missing-cstdio-include.patch
deleted file mode 100644
index 1e4ad00396..0000000000
--- a/package/cannelloni/0001-Add-missing-cstdio-include.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From d41f5ec6bb66654558757c3ef9cd2a158ee06ccc Mon Sep 17 00:00:00 2001
-From: Yegor Yefremov <yegorslists@googlemail.com>
-Date: Wed, 15 Feb 2017 09:29:29 +0100
-Subject: [PATCH] Add missing <cstdio> include
-
-This header defines EOF macro. Some toolchains cannot
-find this macro, if <cstdio> is missing. So include it
-explicitly.
-
-Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
----
- sctpthread.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/sctpthread.cpp b/sctpthread.cpp
-index 6c83fed..d83b472 100644
---- a/sctpthread.cpp
-+++ b/sctpthread.cpp
-@@ -19,6 +19,7 @@
-  */
- 
- #include <chrono>
-+#include <cstdio>
- #include <algorithm>
- 
- #include <string.h>
--- 
-2.1.4
-
diff --git a/package/cannelloni/cannelloni.hash b/package/cannelloni/cannelloni.hash
index 41cb72816d..107415b0ac 100644
--- a/package/cannelloni/cannelloni.hash
+++ b/package/cannelloni/cannelloni.hash
@@ -1,3 +1,3 @@
 # Locally computed
-sha256  fe5abb1c9e523049c48dd906603bc762cc55ccd20c16dbec7dc64163b9eefccf  cannelloni-20160414.tar.gz
+sha256  de44b7e327fbf38883f46e51a5afd07de5144f2e44c5f42b7f2f0741165f0b13  cannelloni-1.0.0.tar.gz
 sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  gpl-2.0.txt
diff --git a/package/cannelloni/cannelloni.mk b/package/cannelloni/cannelloni.mk
index cc99c54aa1..f97a091760 100644
--- a/package/cannelloni/cannelloni.mk
+++ b/package/cannelloni/cannelloni.mk
@@ -4,10 +4,11 @@
 #
 ################################################################################
 
-CANNELLONI_VERSION = 20160414
-CANNELLONI_SITE = $(call github,mguentner,cannelloni,$(CANNELLONI_VERSION))
+CANNELLONI_VERSION = 1.0.0
+CANNELLONI_SITE = $(call github,mguentner,cannelloni,v$(CANNELLONI_VERSION))
 CANNELLONI_LICENSE = GPL-2.0
 CANNELLONI_LICENSE_FILES = gpl-2.0.txt
+CANNELLONI_CONF_OPTS = -DCMAKE_CXX_FLAGS="-std=c++11"
 
 ifeq ($(BR2_PACKAGE_LKSCTP_TOOLS),y)
 CANNELLONI_CONF_OPTS += -DSCTP_SUPPORT=ON