package/qt5/qt5webengine-chromium: new package
We need to add a separate package for the chromium submodule so that we can apply patches for python3 support to it and replace catapult with a python3 compatible version. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
dbaee8e456
commit
577d886886
@ -65,6 +65,7 @@ source "package/qt5/qt5wayland/Config.in"
|
||||
source "package/qt5/qt5webchannel/Config.in"
|
||||
source "package/qt5/qt5webkit/Config.in"
|
||||
source "package/qt5/qt5webengine/Config.in"
|
||||
source "package/qt5/qt5webengine-chromium/Config.in"
|
||||
source "package/qt5/qt5webengine-chromium-catapult/Config.in"
|
||||
source "package/qt5/qt5websockets/Config.in"
|
||||
source "package/qt5/qt5webview/Config.in"
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,32 @@
|
||||
From bfc520671693587a0b81842018326da35aa97f80 Mon Sep 17 00:00:00 2001
|
||||
From: James Hilliard <james.hilliard1@gmail.com>
|
||||
Date: Thu, 3 Feb 2022 20:41:08 -0700
|
||||
Subject: [PATCH] Don't rebase sysroot path
|
||||
|
||||
Just use the actual sysroot as rebase_path will generate an invalid
|
||||
sysroot path.
|
||||
|
||||
Fixes:
|
||||
/home/buildroot/buildroot/output/per-package/qt5webengine/host/opt/ext-toolchain/bin/../lib/gcc/aarch64-buildroot-linux-gnu/10.3.0/../../../../aarch64-buildroot-linux-gnu/bin/ld: cannot find crti.o: No such file or directory
|
||||
|
||||
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
||||
---
|
||||
chromium/build/config/posix/BUILD.gn | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chromium/build/config/posix/BUILD.gn b/chromium/build/config/posix/BUILD.gn
|
||||
index e61554c5656..dc957225869 100644
|
||||
--- a/chromium/build/config/posix/BUILD.gn
|
||||
+++ b/chromium/build/config/posix/BUILD.gn
|
||||
@@ -27,7 +27,7 @@ config("runtime_library") {
|
||||
|
||||
if (!is_apple && sysroot != "") {
|
||||
# Pass the sysroot to all C compiler variants, the assembler, and linker.
|
||||
- sysroot_flags = [ "--sysroot=" + rebase_path(sysroot, root_build_dir) ]
|
||||
+ sysroot_flags = [ "--sysroot=" + sysroot ]
|
||||
if (is_linux || is_chromeos) {
|
||||
# This is here so that all files get recompiled after a sysroot roll and
|
||||
# when turning the sysroot on or off. (defines are passed via the command
|
||||
--
|
||||
2.25.1
|
||||
|
5
package/qt5/qt5webengine-chromium/Config.in
Normal file
5
package/qt5/qt5webengine-chromium/Config.in
Normal file
@ -0,0 +1,5 @@
|
||||
# Not user-selectable, it is only needed to be copied
|
||||
# into the qt5webengine source tree.
|
||||
config BR2_PACKAGE_QT5WEBENGINE_CHROMIUM
|
||||
bool
|
||||
select BR2_PACKAGE_QT5WEBENGINE_CHROMIUM_CATAPULT
|
1257
package/qt5/qt5webengine-chromium/chromium-latest.inc
Normal file
1257
package/qt5/qt5webengine-chromium/chromium-latest.inc
Normal file
File diff suppressed because it is too large
Load Diff
1256
package/qt5/qt5webengine-chromium/qt5webengine-chromium.hash
Normal file
1256
package/qt5/qt5webengine-chromium/qt5webengine-chromium.hash
Normal file
File diff suppressed because it is too large
Load Diff
23
package/qt5/qt5webengine-chromium/qt5webengine-chromium.mk
Normal file
23
package/qt5/qt5webengine-chromium/qt5webengine-chromium.mk
Normal file
@ -0,0 +1,23 @@
|
||||
################################################################################
|
||||
#
|
||||
# qt5webengine-chromium
|
||||
#
|
||||
################################################################################
|
||||
|
||||
QT5WEBENGINE_CHROMIUM_VERSION = 0ad2814370799a2161057d92231fe3ee00e2fe98
|
||||
QT5WEBENGINE_CHROMIUM_SITE = $(QT5_SITE)/qtwebengine-chromium/-/archive/$(QT5WEBENGINE_CHROMIUM_VERSION)
|
||||
QT5WEBENGINE_CHROMIUM_SOURCE = qtwebengine-chromium-$(QT5WEBENGINE_CHROMIUM_VERSION).tar.bz2
|
||||
QT5WEBENGINE_CHROMIUM_PATCH_DEPENDENCIES = qt5webengine-chromium-catapult
|
||||
QT5WEBENGINE_CHROMIUM_INSTALL_TARGET = NO
|
||||
|
||||
include package/qt5/qt5webengine-chromium/chromium-latest.inc
|
||||
|
||||
QT5WEBENGINE_CHROMIUM_LICENSE = BSD-3-Clause, GPL-2.0 or LGPL-3.0 or GPL-3.0 or GPL-3.0 with exception
|
||||
|
||||
define QT5WEBENGINE_CHROMIUM_COPY_CATAPULT
|
||||
rm -rf $(@D)/chromium/third_party/catapult
|
||||
cp -a $(QT5WEBENGINE_CHROMIUM_CATAPULT_DIR) $(@D)/chromium/third_party/catapult
|
||||
endef
|
||||
QT5WEBENGINE_CHROMIUM_POST_PATCH_HOOKS += QT5WEBENGINE_CHROMIUM_COPY_CATAPULT
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user