proftp: bump version and fix compilation on 2.6.24+
Based on patch by Thiago A. Corra.
This commit is contained in:
parent
93c736ca95
commit
575721ee91
@ -1,22 +1,17 @@
|
||||
diff -urN proftpd-1.3.0a-0rig/ChangeLog proftpd-1.3.0a/ChangeLog
|
||||
--- proftpd-1.3.0a-0rig/ChangeLog 2006-04-16 23:39:01.000000000 +0200
|
||||
+++ proftpd-1.3.0a/ChangeLog 2007-09-24 08:18:14.000000000 +0200
|
||||
@@ -1,3 +1,11 @@
|
||||
+2007-09-24 08:00 ulfs
|
||||
+
|
||||
+ * contrib/mod_load/mod_load.c.in
|
||||
+ * include/conf.h
|
||||
+ * lib/glibc-glob.c
|
||||
+
|
||||
+ Replace bzero/bcopy with memset/memcpy
|
||||
+
|
||||
2006-04-16 14:36 castaglia
|
||||
|
||||
* contrib/dist/rpm/proftpd.spec, include/version.h, NEWS:
|
||||
diff -urN proftpd-1.3.0a-0rig/config.h.in proftpd-1.3.0a/config.h.in
|
||||
--- proftpd-1.3.0a-0rig/config.h.in 2005-10-20 01:28:30.000000000 +0200
|
||||
+++ proftpd-1.3.0a/config.h.in 2007-09-24 08:24:38.000000000 +0200
|
||||
@@ -190,7 +190,7 @@
|
||||
---
|
||||
config.h.in | 11 ++++-------
|
||||
contrib/mod_load/mod_load.c.in | 2 +-
|
||||
include/conf.h | 11 -----------
|
||||
lib/glibc-glob.c | 10 ----------
|
||||
lib/libltdl/config-h.in | 7 ++-----
|
||||
lib/libltdl/ltdl.c | 4 ----
|
||||
6 files changed, 7 insertions(+), 38 deletions(-)
|
||||
|
||||
Index: proftpd-1.3.1/config.h.in
|
||||
===================================================================
|
||||
--- proftpd-1.3.1.orig/config.h.in
|
||||
+++ proftpd-1.3.1/config.h.in
|
||||
@@ -202,7 +202,7 @@
|
||||
#undef STACK_DIRECTION
|
||||
|
||||
/* Define if you have the ANSI C header files. */
|
||||
@ -25,7 +20,7 @@ diff -urN proftpd-1.3.0a-0rig/config.h.in proftpd-1.3.0a/config.h.in
|
||||
|
||||
/* Define if you can safely include both <sys/time.h> and <time.h>. */
|
||||
#undef TIME_WITH_SYS_TIME
|
||||
@@ -202,10 +202,10 @@
|
||||
@@ -214,10 +214,10 @@
|
||||
#undef uid_t
|
||||
|
||||
/* The number of bytes in a short. */
|
||||
@ -38,7 +33,7 @@ diff -urN proftpd-1.3.0a-0rig/config.h.in proftpd-1.3.0a/config.h.in
|
||||
|
||||
/* The number of bytes in a long. */
|
||||
#undef SIZEOF_LONG
|
||||
@@ -222,9 +222,6 @@
|
||||
@@ -234,9 +234,6 @@
|
||||
/* The number of bytes in a time_t. */
|
||||
#undef SIZEOF_TIME_T
|
||||
|
||||
@ -48,7 +43,7 @@ diff -urN proftpd-1.3.0a-0rig/config.h.in proftpd-1.3.0a/config.h.in
|
||||
/* Define if you have the crypt function. */
|
||||
#undef HAVE_CRYPT
|
||||
|
||||
@@ -307,7 +304,7 @@
|
||||
@@ -319,7 +316,7 @@
|
||||
#undef HAVE_INET_PTON
|
||||
|
||||
/* Define if you have the memcpy function. */
|
||||
@ -57,9 +52,10 @@ diff -urN proftpd-1.3.0a-0rig/config.h.in proftpd-1.3.0a/config.h.in
|
||||
|
||||
/* Define if you have the mempcpy function. */
|
||||
#undef HAVE_MEMPCPY
|
||||
diff -urN proftpd-1.3.0a-0rig/contrib/mod_load/mod_load.c.in proftpd-1.3.0a/contrib/mod_load/mod_load.c.in
|
||||
--- proftpd-1.3.0a-0rig/contrib/mod_load/mod_load.c.in 2005-01-07 00:39:59.000000000 +0100
|
||||
+++ proftpd-1.3.0a/contrib/mod_load/mod_load.c.in 2007-09-24 08:02:01.000000000 +0200
|
||||
Index: proftpd-1.3.1/contrib/mod_load/mod_load.c.in
|
||||
===================================================================
|
||||
--- proftpd-1.3.1.orig/contrib/mod_load/mod_load.c.in
|
||||
+++ proftpd-1.3.1/contrib/mod_load/mod_load.c.in
|
||||
@@ -651,7 +651,7 @@
|
||||
for (i = 0; i < conf.config_maxclass; ++i)
|
||||
{
|
||||
@ -69,9 +65,10 @@ diff -urN proftpd-1.3.0a-0rig/contrib/mod_load/mod_load.c.in proftpd-1.3.0a/cont
|
||||
|
||||
desc.sd_type = CPUTYPE_CLASS;
|
||||
desc.sd_objid = i;
|
||||
diff -urN proftpd-1.3.0a-0rig/include/conf.h proftpd-1.3.0a/include/conf.h
|
||||
--- proftpd-1.3.0a-0rig/include/conf.h 2005-06-30 02:39:16.000000000 +0200
|
||||
+++ proftpd-1.3.0a/include/conf.h 2007-09-24 08:20:26.000000000 +0200
|
||||
Index: proftpd-1.3.1/include/conf.h
|
||||
===================================================================
|
||||
--- proftpd-1.3.1.orig/include/conf.h
|
||||
+++ proftpd-1.3.1/include/conf.h
|
||||
@@ -118,10 +118,6 @@
|
||||
# define strrchr rindex
|
||||
# endif
|
||||
@ -83,7 +80,7 @@ diff -urN proftpd-1.3.0a-0rig/include/conf.h proftpd-1.3.0a/include/conf.h
|
||||
#endif
|
||||
|
||||
#ifdef HAVE_BSTRING_H
|
||||
@@ -264,13 +260,6 @@
|
||||
@@ -278,13 +274,6 @@
|
||||
off_t lseek(int, off_t, int);
|
||||
#endif
|
||||
|
||||
@ -97,9 +94,10 @@ diff -urN proftpd-1.3.0a-0rig/include/conf.h proftpd-1.3.0a/include/conf.h
|
||||
/* Solaris has __vsnprintf, but no vsnprintf */
|
||||
#if ! defined(HAVE_VSNPRINTF) && defined(HAVE___VSNPRINTF)
|
||||
# undef vsnprintf
|
||||
diff -urN proftpd-1.3.0a-0rig/lib/glibc-glob.c proftpd-1.3.0a/lib/glibc-glob.c
|
||||
--- proftpd-1.3.0a-0rig/lib/glibc-glob.c 2006-03-22 23:10:34.000000000 +0100
|
||||
+++ proftpd-1.3.0a/lib/glibc-glob.c 2007-09-24 08:07:48.000000000 +0200
|
||||
Index: proftpd-1.3.1/lib/glibc-glob.c
|
||||
===================================================================
|
||||
--- proftpd-1.3.1.orig/lib/glibc-glob.c
|
||||
+++ proftpd-1.3.1/lib/glibc-glob.c
|
||||
@@ -215,18 +215,8 @@
|
||||
|
||||
#ifndef ANSI_STRING
|
||||
@ -119,9 +117,10 @@ diff -urN proftpd-1.3.0a-0rig/lib/glibc-glob.c proftpd-1.3.0a/lib/glibc-glob.c
|
||||
#endif /* Not ANSI_STRING. */
|
||||
|
||||
#if !defined HAVE_STRCOLL && !defined _LIBC
|
||||
diff -urN proftpd-1.3.0a-0rig/lib/libltdl/config-h.in proftpd-1.3.0a/lib/libltdl/config-h.in
|
||||
--- proftpd-1.3.0a-0rig/lib/libltdl/config-h.in 2004-10-29 07:17:55.000000000 +0200
|
||||
+++ proftpd-1.3.0a/lib/libltdl/config-h.in 2007-09-24 08:25:40.000000000 +0200
|
||||
Index: proftpd-1.3.1/lib/libltdl/config-h.in
|
||||
===================================================================
|
||||
--- proftpd-1.3.1.orig/lib/libltdl/config-h.in
|
||||
+++ proftpd-1.3.1/lib/libltdl/config-h.in
|
||||
@@ -21,9 +21,6 @@
|
||||
/* Define to 1 if you have the <assert.h> header file. */
|
||||
#undef HAVE_ASSERT_H
|
||||
@ -150,9 +149,10 @@ diff -urN proftpd-1.3.0a-0rig/lib/libltdl/config-h.in proftpd-1.3.0a/lib/libltdl
|
||||
|
||||
/* Define to empty if `const' does not conform to ANSI C. */
|
||||
#undef const
|
||||
diff -urN proftpd-1.3.0a-0rig/lib/libltdl/ltdl.c proftpd-1.3.0a/lib/libltdl/ltdl.c
|
||||
--- proftpd-1.3.0a-0rig/lib/libltdl/ltdl.c 2004-10-29 07:17:55.000000000 +0200
|
||||
+++ proftpd-1.3.0a/lib/libltdl/ltdl.c 2007-09-24 08:13:51.000000000 +0200
|
||||
Index: proftpd-1.3.1/lib/libltdl/ltdl.c
|
||||
===================================================================
|
||||
--- proftpd-1.3.1.orig/lib/libltdl/ltdl.c
|
||||
+++ proftpd-1.3.1/lib/libltdl/ltdl.c
|
||||
@@ -372,9 +372,6 @@
|
||||
if you need that behaviour. */
|
||||
#if ! HAVE_MEMCPY
|
@ -0,0 +1,12 @@
|
||||
--- a/lib/libcap/libcap.h 2008-04-24 19:46:29.475883739 +0200
|
||||
+++ b/lib/libcap/libcap.h 2008-04-24 19:48:31.116088563 +0200
|
||||
@@ -52,7 +52,8 @@
|
||||
*/
|
||||
|
||||
#if !defined(_LINUX_CAPABILITY_VERSION) || \
|
||||
- (_LINUX_CAPABILITY_VERSION != 0x19980330)
|
||||
+ ((_LINUX_CAPABILITY_VERSION != 0x19980330) && \
|
||||
+ (_LINUX_CAPABILITY_VERSION != 0x20071026))
|
||||
|
||||
# error "Kernel <linux/capability.h> does not match library"
|
||||
# error "file "libcap.h" --> fix and recompile libcap"
|
@ -3,7 +3,7 @@
|
||||
# proftpd
|
||||
#
|
||||
#############################################################
|
||||
PROFTPD_VERSION:=1.3.0a
|
||||
PROFTPD_VERSION:=1.3.1
|
||||
PROFTPD_SOURCE:=proftpd-$(PROFTPD_VERSION).tar.bz2
|
||||
PROFTPD_SITE:=ftp://ftp.proftpd.org/distrib/source/
|
||||
PROFTPD_DIR:=$(BUILD_DIR)/proftpd-$(PROFTPD_VERSION)
|
||||
@ -23,6 +23,7 @@ proftpd-source: $(DL_DIR)/$(PROFTPD_SOURCE)
|
||||
$(PROFTPD_DIR)/.unpacked: $(DL_DIR)/$(PROFTPD_SOURCE)
|
||||
$(PROFTPD_CAT) $(DL_DIR)/$(PROFTPD_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
|
||||
$(CONFIG_UPDATE) $(PROFTPD_DIR)
|
||||
toolchain/patch-kernel.sh $(PROFTPD_DIR) package/proftpd/ proftpd-$(PROFTPD_VERSION)\*.patch;
|
||||
touch $@
|
||||
|
||||
$(PROFTPD_DIR)/.configured: $(PROFTPD_DIR)/.unpacked
|
||||
|
Loading…
Reference in New Issue
Block a user