new package: usb_modeswitch_data
usb_modeswitch_data provides udev rules for usb VID/PID combinations to switch usb deices from their default mode into a more useable mode. The default mode usually is a cdrom with installation software that is of little use in an embedded linux situation Signed-off-by: J.C. Woltz <jwoltz@gmail.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
1fc66acff8
commit
572ba0692c
@ -239,6 +239,7 @@ source "package/uboot-tools/Config.in"
|
||||
source "package/udev/Config.in"
|
||||
source "package/unionfs/Config.in"
|
||||
source "package/usb_modeswitch/Config.in"
|
||||
source "package/usb_modeswitch_data/Config.in"
|
||||
source "package/usbmount/Config.in"
|
||||
source "package/usbutils/Config.in"
|
||||
source "package/wipe/Config.in"
|
||||
|
12
package/usb_modeswitch_data/Config.in
Normal file
12
package/usb_modeswitch_data/Config.in
Normal file
@ -0,0 +1,12 @@
|
||||
config BR2_PACKAGE_USB_MODESWITCH_DATA
|
||||
bool "usb_modeswitch_data"
|
||||
select BR2_PACKAGE_USB_MODESWITCH
|
||||
# tcl is a runtime dependency
|
||||
select BR2_PACKAGE_TCL
|
||||
select BR2_PACKAGE_TCL_TCLSH
|
||||
help
|
||||
USB mode switch data
|
||||
Contains udev rules and events to allow usb_modeswitch to
|
||||
function automatically
|
||||
|
||||
http://www.draisberghof.de/usb_modeswitch/
|
@ -0,0 +1,27 @@
|
||||
Fixed Makefile install sections to not reload udev rules. In a
|
||||
cross-compiler environment, it is not wanted to reload the host udev rules.
|
||||
|
||||
Signed-off-by: J.C. Woltz <jwoltz@gmail.com>
|
||||
--- usb_modeswitch_data-20120120.orig/Makefile 2012-01-20 17:25:32.000000000 -0500
|
||||
+++ usb_modeswitch_data-20120120/Makefile 2012-02-06 14:20:47.000000000 -0500
|
||||
@@ -12,9 +12,9 @@
|
||||
|
||||
clean:
|
||||
|
||||
-install: files-install db-install rules-reload
|
||||
+install: files-install db-install
|
||||
|
||||
-install-packed: files-install db-install-packed rules-reload
|
||||
+install-packed: files-install db-install-packed
|
||||
|
||||
files-install:
|
||||
install -d $(PREFIX)/share/usb_modeswitch
|
||||
@@ -50,7 +50,7 @@
|
||||
fi \
|
||||
fi
|
||||
|
||||
-uninstall: files-uninstall rules-reload
|
||||
+uninstall: files-uninstall
|
||||
|
||||
files-uninstall:
|
||||
$(RM) $(RULESDIR)/40-usb_modeswitch.rules
|
24
package/usb_modeswitch_data/usb_modeswitch_data.mk
Normal file
24
package/usb_modeswitch_data/usb_modeswitch_data.mk
Normal file
@ -0,0 +1,24 @@
|
||||
#############################################################
|
||||
#
|
||||
# usb_modeswitch_data
|
||||
#
|
||||
#############################################################
|
||||
|
||||
USB_MODESWITCH_DATA_VERSION = 20120812
|
||||
USB_MODESWITCH_DATA_SOURCE = usb-modeswitch-data-$(USB_MODESWITCH_DATA_VERSION).tar.bz2
|
||||
USB_MODESWITCH_DATA_SITE = http://www.draisberghof.de/usb_modeswitch
|
||||
USB_MODESWITCH_DATA_DEPENDENCIES = usb_modeswitch
|
||||
USB_MODESWITCH_DATA_LICENSE = GPLv2+
|
||||
USB_MODESWITCH_DATA_LICENSE_FILES = COPYING
|
||||
|
||||
# Nothing to build, it is a pure data package
|
||||
|
||||
define USB_MODESWITCH_DATA_INSTALL_TARGET_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
|
||||
endef
|
||||
|
||||
define USB_MODESWITCH_DATA_CLEAN_CMDS
|
||||
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) clean
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user