toolchain/binutils: add 2.18.50.0.9
Based on 713e7e46 in Bernhard's tree.
This commit is contained in:
parent
1ad0441dc8
commit
56287af5a5
24
toolchain/binutils/2.18.50.0.9/110-arm-eabi-conf.patch
Normal file
24
toolchain/binutils/2.18.50.0.9/110-arm-eabi-conf.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -rdup binutils-2.18.50.0.3.orig/configure binutils-2.18.50.0.3/configure
|
||||
--- binutils-2.18.50.0.3.orig/configure 2007-11-22 12:41:26.000000000 +0100
|
||||
+++ binutils-2.18.50.0.3/configure 2007-11-22 12:45:01.000000000 +0100
|
||||
@@ -2245,7 +2245,7 @@ case "${target}" in
|
||||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||
libgloss_dir=arm
|
||||
;;
|
||||
- arm*-*-linux-gnueabi)
|
||||
+ arm*-*-linux-*gnueabi)
|
||||
noconfigdirs="$noconfigdirs target-qthreads"
|
||||
noconfigdirs="$noconfigdirs target-libobjc"
|
||||
case ${with_newlib} in
|
||||
diff -rdup binutils-2.18.50.0.3.orig/configure.ac binutils-2.18.50.0.3/configure.ac
|
||||
--- binutils-2.18.50.0.3.orig/configure.ac 2007-11-22 12:41:26.000000000 +0100
|
||||
+++ binutils-2.18.50.0.3/configure.ac 2007-11-22 12:44:54.000000000 +0100
|
||||
@@ -522,7 +522,7 @@ case "${target}" in
|
||||
noconfigdirs="$noconfigdirs target-libffi target-qthreads"
|
||||
libgloss_dir=arm
|
||||
;;
|
||||
- arm*-*-linux-gnueabi)
|
||||
+ arm*-*-linux-*gnueabi)
|
||||
noconfigdirs="$noconfigdirs target-qthreads"
|
||||
noconfigdirs="$noconfigdirs target-libobjc"
|
||||
case ${with_newlib} in
|
@ -0,0 +1,24 @@
|
||||
diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.am binutils-2.17.50.0.17/ld/Makefile.am
|
||||
--- binutils-2.17.50.0.17.oorig/ld/Makefile.am 2007-06-18 19:29:29.000000000 +0200
|
||||
+++ binutils-2.17.50.0.17/ld/Makefile.am 2007-06-25 10:00:36.000000000 +0200
|
||||
@@ -18,7 +18,7 @@
|
||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||
# directives need to be different for native and cross linkers.
|
||||
-scriptdir = $(tooldir)/lib
|
||||
+scriptdir = $(libdir)
|
||||
|
||||
EMUL = @EMUL@
|
||||
EMULATION_OFILES = @EMULATION_OFILES@
|
||||
diff -u binutils-2.17.50.0.17.oorig/ld/Makefile.in binutils-2.17.50.0.17/ld/Makefile.in
|
||||
--- binutils-2.17.50.0.17.oorig/ld/Makefile.in 2007-06-18 19:29:29.000000000 +0200
|
||||
+++ binutils-2.17.50.0.17/ld/Makefile.in 2007-06-25 10:00:36.000000000 +0200
|
||||
@@ -287,7 +287,7 @@
|
||||
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||
# directives need to be different for native and cross linkers.
|
||||
-scriptdir = $(tooldir)/lib
|
||||
+scriptdir = $(libdir)
|
||||
BASEDIR = $(srcdir)/..
|
||||
BFDDIR = $(BASEDIR)/bfd
|
||||
INCDIR = $(BASEDIR)/include
|
@ -0,0 +1,21 @@
|
||||
diff -u binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em binutils-2.17.50.0.17/ld/emultempl/elf32.em
|
||||
--- binutils-2.17.50.0.17.oorig/ld/emultempl/elf32.em 2007-06-18 19:31:40.000000000 +0200
|
||||
+++ binutils-2.17.50.0.17/ld/emultempl/elf32.em 2007-06-25 10:01:25.000000000 +0200
|
||||
@@ -1007,6 +1007,8 @@
|
||||
&& command_line.rpath == NULL)
|
||||
{
|
||||
lib_path = (const char *) getenv ("LD_RUN_PATH");
|
||||
+ if ((lib_path) && (strlen (lib_path) == 0))
|
||||
+ lib_path = NULL;
|
||||
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
|
||||
force))
|
||||
break;
|
||||
@@ -1191,6 +1193,8 @@
|
||||
rpath = command_line.rpath;
|
||||
if (rpath == NULL)
|
||||
rpath = (const char *) getenv ("LD_RUN_PATH");
|
||||
+ if ((rpath) && (strlen (rpath) == 0))
|
||||
+ rpath = NULL;
|
||||
if (! (bfd_elf_size_dynamic_sections
|
||||
(output_bfd, command_line.soname, rpath,
|
||||
command_line.filter_shlib,
|
@ -40,7 +40,12 @@ choice
|
||||
|
||||
config BR2_BINUTILS_VERSION_2_18_50_0_8
|
||||
depends on !BR2_avr32 && !BR2_nios2
|
||||
depends on BR2_DEPRECATED
|
||||
bool "binutils 2.18.50.0.8"
|
||||
|
||||
config BR2_BINUTILS_VERSION_2_18_50_0_9
|
||||
depends on !BR2_avr32 && !BR2_nios2
|
||||
bool "binutils 2.18.50.0.9"
|
||||
endchoice
|
||||
|
||||
config BR2_BINUTILS_VERSION
|
||||
@ -53,6 +58,7 @@ config BR2_BINUTILS_VERSION
|
||||
default "2.18.50.0.3" if BR2_BINUTILS_VERSION_2_18_50_0_3
|
||||
default "2.18.50.0.6" if BR2_BINUTILS_VERSION_2_18_50_0_6
|
||||
default "2.18.50.0.8" if BR2_BINUTILS_VERSION_2_18_50_0_8
|
||||
default "2.18.50.0.9" if BR2_BINUTILS_VERSION_2_18_50_0_9
|
||||
|
||||
config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
|
||||
string "Additional binutils options"
|
||||
|
Loading…
Reference in New Issue
Block a user