From 558617ddf8cff531804d4de9e7cd1774311ce488 Mon Sep 17 00:00:00 2001
From: Ulf Samuelsson <ulf.samuelsson@atmel.com>
Date: Tue, 28 Aug 2007 18:22:38 +0000
Subject: [PATCH] This fixes make clean on pppd package (there is no rule
 uninstall in pppd's makefile) and does some small bits of cleanup.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Thiago A. CorrĂȘa <thiago.correa@gmail.com>
---
 package/pppd/pppd.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

diff --git a/package/pppd/pppd.mk b/package/pppd/pppd.mk
index c72f640c51..c0f584967e 100644
--- a/package/pppd/pppd.mk
+++ b/package/pppd/pppd.mk
@@ -26,7 +26,7 @@ $(PPPD_DIR)/.unpacked: $(DL_DIR)/$(PPPD_SOURCE)
 	$(SED) 's,(INSTALL) -s,(INSTALL),' $(PPPD_DIR)/pppd/plugins/*/Makefile.linux
 	$(SED) 's/ -o root//' $(PPPD_DIR)/*/Makefile.linux
 	$(SED) 's/ -g daemon//' $(PPPD_DIR)/*/Makefile.linux
-	touch $(PPPD_DIR)/.unpacked
+	touch $@
 
 $(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
 	(cd $(PPPD_DIR); rm -rf config.cache; \
@@ -49,7 +49,7 @@ $(PPPD_DIR)/.configured: $(PPPD_DIR)/.unpacked
 		--infodir=/usr/info \
 		$(DISABLE_NLS) \
 	)
-	touch $(PPPD_DIR)/.configured
+	touch $@
 
 $(PPPD_DIR)/$(PPPD_BINARY): $(PPPD_DIR)/.configured
 	$(MAKE) CC=$(TARGET_CC) COPTS="$(TARGET_CFLAGS)" -C $(PPPD_DIR)
@@ -65,7 +65,6 @@ pppd-clean:
 	rm -f $(TARGET_DIR)/usr/sbin/pppd
 	rm -f $(TARGET_DIR)/usr/sbin/chat
 	rm -rf $(TARGET_DIR)/etc/ppp
-	$(MAKE) DESTDIR=$(TARGET_DIR)/usr CC=$(TARGET_CC) -C $(PPPD_DIR) uninstall
 	-$(MAKE) -C $(PPPD_DIR) clean
 
 pppd-dirclean: