package/libshout: bump to version 2.4.6

- Drop patch (already in version) and so autoreconf
- libvorbis is optional since
  181ac9f3f5

https://gitlab.xiph.org/xiph/icecast-libshout/-/blob/v2.4.6/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2022-10-23 22:40:44 +02:00 committed by Thomas Petazzoni
parent 13596db789
commit 54a8261e6f
4 changed files with 11 additions and 58 deletions

View File

@ -1,51 +0,0 @@
From 148b56bf894192cef6dd133715e295260b934a71 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Fri, 5 Mar 2021 15:50:32 +0100
Subject: [PATCH] configure.ac: add an option to disable tools
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status:
https://gitlab.xiph.org/xiph/icecast-libshout/-/issues/2331]
---
Makefile.am | 5 ++++-
configure.ac | 5 +++++
2 files changed, 9 insertions(+), 1 deletion(-)
diff --git a/Makefile.am b/Makefile.am
index ea855cf..79241f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,10 +3,13 @@
AUTOMAKE_OPTIONS = 1.6 foreign
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = include src doc win32 tools
+SUBDIRS = include src doc win32
if HAVE_EXAMPLES
SUBDIRS += examples
endif
+if HAVE_TOOLS
+SUBDIRS += tools
+endif
EXTRA_DIST = INSTALL m4/shout.m4 m4/acx_pthread.m4 \
m4/ogg.m4 m4/vorbis.m4 m4/xiph_compiler.m4 m4/xiph_net.m4 \
diff --git a/configure.ac b/configure.ac
index 264b9b0..34f971c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,6 +100,11 @@ AC_ARG_ENABLE([examples],
AS_HELP_STRING([--disable-examples],[Do not build example code]))
AM_CONDITIONAL([HAVE_EXAMPLES],[test "${enable_examples}" != "no"])
+dnl Allow tools not to be build
+AC_ARG_ENABLE([tools],
+ AS_HELP_STRING([--disable-tools],[Do not build tools]))
+AM_CONDITIONAL([HAVE_TOOLS],[test "${enable_tools}" != "no"])
+
dnl Module checks
XIPH_NET
--
2.30.0

View File

@ -1,7 +1,6 @@
config BR2_PACKAGE_LIBSHOUT
bool "libshout"
select BR2_PACKAGE_LIBOGG
select BR2_PACKAGE_LIBVORBIS
help
Libshout is a library for communicating with and sending data
to an icecast server. It handles the socket connection, the

View File

@ -1,8 +1,8 @@
# From https://ftp.osuosl.org/pub/xiph/releases/libshout/SHA512SUMS
sha512 290844185da16961f03434d3e341573dd6cb0139e5fa81902903021b641382d2629302d7c356bc591b35656754e07f4e44a8d9e782e092b17a051b9ae8f54341 libshout-2.4.5.tar.gz
sha512 e8478cdbf9a27674c16a7b620d1576f2e31a47262b8e29b314d0f46d4e5be24b9a29790b7b226f48939bc34cacf5734fae0aa5686c7ed5879cdbd827ff8e0339 libshout-2.4.6.tar.gz
# From https://ftp.osuosl.org/pub/xiph/releases/libshout/SHA256SUMS
sha256 d9e568668a673994ebe3f1eb5f2bee06e3236a5db92b8d0c487e1c0f886a6890 libshout-2.4.5.tar.gz
sha256 39cbd4f0efdfddc9755d88217e47f8f2d7108fa767f9d58a2ba26a16d8f7c910 libshout-2.4.6.tar.gz
# Hash for license file
sha256 7a4436f9ec37603356791c87de3bc444989befd2682d29efb3d97604e04c1852 COPYING

View File

@ -4,14 +4,12 @@
#
################################################################################
LIBSHOUT_VERSION = 2.4.5
LIBSHOUT_VERSION = 2.4.6
LIBSHOUT_SITE = https://downloads.xiph.org/releases/libshout
LIBSHOUT_LICENSE = LGPL-2.0+
LIBSHOUT_LICENSE_FILES = COPYING
LIBSHOUT_INSTALL_STAGING = YES
LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
# We're patching configure.ac
LIBSHOUT_AUTORECONF = YES
LIBSHOUT_DEPENDENCIES = host-pkgconf libogg
LIBSHOUT_CONF_OPTS = \
--disable-examples \
--disable-tools
@ -23,6 +21,13 @@ else
LIBSHOUT_CONF_OPTS += --disable-theora
endif
ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
LIBSHOUT_CONF_OPTS += --enable-vorbis
LIBSHOUT_DEPENDENCIES += libvorbis
else
LIBSHOUT_CONF_OPTS += --disable-vorbis
endif
ifeq ($(BR2_PACKAGE_SPEEX),y)
LIBSHOUT_CONF_OPTS += --enable-speex
LIBSHOUT_DEPENDENCIES += speex