luacrypto: refactor with autotools
some CMake stuff comes from LuaDist, but CMake is not the primary build infrastructure of LuaCrypto. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
eca77d0429
commit
549c09b627
@ -1,7 +1,6 @@
|
||||
config BR2_PACKAGE_LUACRYPTO
|
||||
bool "luacrypto"
|
||||
select BR2_PACKAGE_OPENSSL
|
||||
select BR2_PACKAGE_LUASOCKET
|
||||
help
|
||||
LuaCrypto provides a Lua frontend to the OpenSSL cryptographic
|
||||
library.
|
||||
|
30
package/luacrypto/luacrypto-01-autotools.patch
Normal file
30
package/luacrypto/luacrypto-01-autotools.patch
Normal file
@ -0,0 +1,30 @@
|
||||
autotools: fix install directories
|
||||
|
||||
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
|
||||
|
||||
Index: b/Makefile.am
|
||||
===================================================================
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -3,7 +3,7 @@
|
||||
SUBDIRS = src \
|
||||
doc
|
||||
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/lib/pkgconfig
|
||||
pkgconfig_DATA = luacrypto.pc
|
||||
|
||||
test: all
|
||||
Index: b/configure.ac
|
||||
===================================================================
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -31,7 +31,7 @@
|
||||
PKG_CHECK_MODULES([LUA], [lua])
|
||||
|
||||
# lua libdir
|
||||
-LUALIBDIR="`$PKGCONFIG --variable=libdir lua`"
|
||||
+LUALIBDIR="`$PKGCONFIG --variable=INSTALL_CMOD lua`"
|
||||
|
||||
# dest of headers
|
||||
CRYPTOINC="${includedir}/${PACKAGE_NAME}"
|
@ -8,7 +8,7 @@ LUACRYPTO_VERSION = 0.3.2
|
||||
LUACRYPTO_SITE = http://github.com/mkottman/luacrypto/tarball/$(LUACRYPTO_VERSION)
|
||||
LUACRYPTO_LICENSE = MIT
|
||||
LUACRYPTO_LICENSE_FILES = COPYING
|
||||
LUACRYPTO_DEPENDENCIES = lua openssl
|
||||
LUACRYPTO_CONF_OPT = "-DLUA_LIBRARIES=\"$(STAGING_DIR)/usr/lib/liblua.so\""
|
||||
LUACRYPTO_DEPENDENCIES = lua openssl host-pkgconf
|
||||
LUACRYPTO_AUTORECONF = YES
|
||||
|
||||
$(eval $(cmake-package))
|
||||
$(eval $(autotools-package))
|
||||
|
Loading…
Reference in New Issue
Block a user