rtorrent: new package

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Gustavo Zacarias 2012-05-14 10:55:29 +00:00 committed by Peter Korsgaard
parent be26c3e760
commit 54366d812d
4 changed files with 56 additions and 0 deletions

View File

@ -564,6 +564,7 @@ source "package/radvd/Config.in"
source "package/rp-pppoe/Config.in"
source "package/rsh-redone/Config.in"
source "package/rsync/Config.in"
source "package/rtorrent/Config.in"
source "package/samba/Config.in"
source "package/ser2net/Config.in"
source "package/socat/Config.in"

View File

@ -0,0 +1,16 @@
config BR2_PACKAGE_RTORRENT
bool "rtorrent"
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR
select BR2_PACKAGE_LIBCURL
select BR2_PACKAGE_LIBSIGC
select BR2_PACKAGE_LIBTORRENT
select BR2_PACKAGE_NCURSES
select BR2_PACKAGE_OPENSSL
help
BitTorrent Client using libtorrent
http://libtorrent.rakshasa.no/
comment "rtorrent requires a toolchain with C++ and WCHAR support"
depends on !(BR2_INSTALL_LIBSTDCPP && BR2_USE_WCHAR)

View File

@ -0,0 +1,27 @@
Fix cross compilation, based on OpenWRT patch.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura rtorrent-0.9.2/configure.ac rtorrent-0.9.2-cross/configure.ac
--- rtorrent-0.9.2/configure.ac 2012-04-20 03:55:30.000000000 -0300
+++ rtorrent-0.9.2-cross/configure.ac 2012-05-09 11:06:49.436474039 -0300
@@ -4,7 +4,6 @@
AM_INIT_AUTOMAKE
AM_CONFIG_HEADER(config.h)
-AM_PATH_CPPUNIT(1.9.6)
AC_PROG_CXX
AC_PROG_LIBTOOL
diff -Nura rtorrent-0.9.2/scripts/common.m4 rtorrent-0.9.2-cross/scripts/common.m4
--- rtorrent-0.9.2/scripts/common.m4 2012-03-13 09:10:49.000000000 -0300
+++ rtorrent-0.9.2-cross/scripts/common.m4 2012-05-09 11:05:56.620102678 -0300
@@ -223,7 +223,7 @@
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
AC_MSG_CHECKING(for execinfo.h)
- AC_RUN_IFELSE([AC_LANG_SOURCE([
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
#include <execinfo.h>
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
])],

View File

@ -0,0 +1,12 @@
#############################################################
#
# rtorrent
#
#############################################################
RTORRENT_VERSION = 0.9.2
RTORRENT_SITE = http://libtorrent.rakshasa.no/downloads
RTORRENT_DEPENDENCIES = host-pkg-config libcurl libsigc libtorrent ncurses
RTORRENT_AUTORECONF = YES
$(eval $(call AUTOTARGETS))