uhttpd: add patch to remove -Werror
Fixes: http://autobuild.buildroot.net/results/febbd094090e14fe7a79e6f691c290075da4fd59/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
041c717ec8
commit
5382bac7c6
33
package/uhttpd/0001-Remove-Werror.patch
Normal file
33
package/uhttpd/0001-Remove-Werror.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From ac52380eeca27e1e2e7eb5fb9d39059dbe58b919 Mon Sep 17 00:00:00 2001
|
||||
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
Date: Wed, 7 Dec 2016 22:48:27 +0100
|
||||
Subject: [PATCH] Remove -Werror
|
||||
|
||||
-Werror might cause build failures with newer versions of gcc or C
|
||||
libraries, not tested by upstream, for example:
|
||||
|
||||
# warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
|
||||
^
|
||||
cc1: all warnings being treated as errors
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 7ae8ba4..825342f 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -5,7 +5,7 @@ PROJECT(uhttpd C)
|
||||
INCLUDE (CheckFunctionExists)
|
||||
|
||||
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
|
||||
-ADD_DEFINITIONS(-D_FILE_OFFSET_BITS=64 -Os -Wall -Werror -Wmissing-declarations --std=gnu99 -g3)
|
||||
+ADD_DEFINITIONS(-D_FILE_OFFSET_BITS=64 -Os -Wall -Wmissing-declarations --std=gnu99 -g3)
|
||||
|
||||
OPTION(TLS_SUPPORT "TLS support" ON)
|
||||
OPTION(LUA_SUPPORT "Lua support" ON)
|
||||
--
|
||||
2.7.4
|
||||
|
Loading…
Reference in New Issue
Block a user