webkit: Version bump to 1.11.5
Also apply the following patches: - upstream fix for 32-bit autotools - upstream fix for conditional gstreamer build of gtklauncher - upstream fix for detecting the latest harfbuzz - Update existing patch for disabling docs - Update existing patch for execinfo_h - upstream patch for the MIPS DFG support. This fixes compilation problems on MIPS. Signed-off-by: Markos Chandras <markos.chandras@imgtec.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
62146ea3ad
commit
52fcc6a256
@ -6,16 +6,19 @@ config BR2_PACKAGE_WEBKIT
|
||||
depends on BR2_PACKAGE_LIBGTK2
|
||||
depends on (BR2_arm || BR2_armeb || BR2_i386 || BR2_mips || BR2_mipsel || \
|
||||
BR2_powerpc || BR2_sh || BR2_sparc || BR2_x86_64)
|
||||
select BR2_PACKAGE_CAIRO_PNG
|
||||
select BR2_PACKAGE_ENCHANT
|
||||
select BR2_PACKAGE_HARFBUZZ
|
||||
select BR2_PACKAGE_ICU
|
||||
select BR2_PACKAGE_JPEG
|
||||
select BR2_PACKAGE_LIBCURL
|
||||
select BR2_PACKAGE_LIBGAIL
|
||||
select BR2_PACKAGE_LIBSECRET
|
||||
select BR2_PACKAGE_LIBSOUP
|
||||
select BR2_PACKAGE_LIBXML2
|
||||
select BR2_PACKAGE_LIBXSLT
|
||||
select BR2_PACKAGE_SQLITE
|
||||
select BR2_PACKAGE_ENCHANT
|
||||
select BR2_PACKAGE_LIBSOUP
|
||||
select BR2_PACKAGE_JPEG
|
||||
select BR2_PACKAGE_CAIRO_PNG
|
||||
select BR2_PACKAGE_LIBGAIL
|
||||
select BR2_PACKAGE_WEBP
|
||||
select BR2_PACKAGE_XLIB_LIBXT if BR2_PACKAGE_XORG7
|
||||
help
|
||||
WebKit is an open source, standards compliant web browser engine.
|
||||
|
34
package/webkit/webkit-build-fix-for-32-bit-autotools.patch
Normal file
34
package/webkit/webkit-build-fix-for-32-bit-autotools.patch
Normal file
@ -0,0 +1,34 @@
|
||||
Add missing symbol for WebCore::TextIterator::getLocationAndLengthFromRange
|
||||
|
||||
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
|
||||
|
||||
From f5bb58f9096061f00c948e668335811d364ba360 Mon Sep 17 00:00:00 2001
|
||||
From: "kov@webkit.org" <kov@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
|
||||
Date: Thu, 7 Feb 2013 13:48:46 +0000
|
||||
Subject: [PATCH] Unreviewed build fix after r141196 for 32 bits autotools.
|
||||
|
||||
* Source/autotools/symbols.filter: restore 32 bits version of the
|
||||
WebCore::TextIterator::getLocationAndLengthFromRange(WebCore::Node*,
|
||||
WebCore::Range const*, unsigned int&, unsigned int&) symbol.
|
||||
|
||||
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@142105 268f45cc-cd09-0410-ab3c-d52691b4dbfc
|
||||
---
|
||||
ChangeLog | 8 ++++++++
|
||||
Source/autotools/symbols.filter | 1 +
|
||||
2 files changed, 9 insertions(+)
|
||||
|
||||
diff --git a/Source/autotools/symbols.filter b/Source/autotools/symbols.filter
|
||||
index 9d730b3..2edefaf 100644
|
||||
--- a/Source/autotools/symbols.filter
|
||||
+++ b/Source/autotools/symbols.filter
|
||||
@@ -57,6 +57,7 @@ _ZN7WebCore11HistoryItem16setDocumentStateERKN3WTF6VectorINS1_6StringELj0EEE;
|
||||
_ZN7WebCore11HistoryItem16setDocumentStateERKN3WTF6VectorINS1_6StringELm0EEE;
|
||||
_ZN7WebCore11MemoryCache14resourceForURLERKNS_4KURLE;
|
||||
_ZN7WebCore12TextIterator26rangeFromLocationAndLengthEPNS_13ContainerNodeEiib;
|
||||
+_ZN7WebCore12TextIterator29getLocationAndLengthFromRangeEPNS_4NodeEPKNS_5RangeERjS6_;
|
||||
_ZN7WebCore12TextIterator29getLocationAndLengthFromRangeEPNS_4NodeEPKNS_5RangeERmS6_;
|
||||
_ZN7WebCore12PrintContext20pageNumberForElementEPNS_7ElementERKNS_9FloatSizeE;
|
||||
_ZN7WebCore13createWrapperEPN3JSC9ExecStateEPNS_17JSDOMGlobalObjectEPNS_4NodeE;
|
||||
--
|
||||
1.8.3.2
|
||||
|
51
package/webkit/webkit-build-fix-for-gtklauncher.patch
Normal file
51
package/webkit/webkit-build-fix-for-gtklauncher.patch
Normal file
@ -0,0 +1,51 @@
|
||||
Make gstreamer support conditional
|
||||
|
||||
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
|
||||
|
||||
From f1055f61bce46eccf8dc0aa017113a08d3d71944 Mon Sep 17 00:00:00 2001
|
||||
From: "commit-queue@webkit.org"
|
||||
<commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
|
||||
Date: Fri, 15 Mar 2013 07:13:51 +0000
|
||||
Subject: [PATCH] Build fix for Tools/GtkLauncher/Programs_GtkLauncher-main.o
|
||||
if gstreamer is not installed https://bugs.webkit.org/show_bug.cgi?id=112394
|
||||
|
||||
Patch by Tobias Mueller <tobiasmue@gnome.org> on 2013-03-15
|
||||
Reviewed by Philippe Normand.
|
||||
|
||||
* GtkLauncher/main.c:
|
||||
(main): Guard using the gstreamer function with #ifdef WTF_USE_GSTREAMER
|
||||
|
||||
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@145881 268f45cc-cd09-0410-ab3c-d52691b4dbfc
|
||||
---
|
||||
Tools/ChangeLog | 10 ++++++++++
|
||||
Tools/GtkLauncher/main.c | 5 ++++-
|
||||
2 files changed, 14 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Tools/GtkLauncher/main.c b/Tools/GtkLauncher/main.c
|
||||
index 32baf4a..84c8833 100644
|
||||
--- a/Tools/GtkLauncher/main.c
|
||||
+++ b/Tools/GtkLauncher/main.c
|
||||
@@ -28,7 +28,9 @@
|
||||
#include "autotoolsconfig.h"
|
||||
#include "LauncherInspectorWindow.h"
|
||||
#include <errno.h>
|
||||
+#ifdef WTF_USE_GSTREAMER
|
||||
#include <gst/gst.h>
|
||||
+#endif
|
||||
#include <gtk/gtk.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
@@ -489,8 +491,9 @@ int main(int argc, char* argv[])
|
||||
GOptionContext *context = g_option_context_new(0);
|
||||
g_option_context_add_main_entries(context, commandLineOptions, 0);
|
||||
g_option_context_add_group(context, gtk_get_option_group(TRUE));
|
||||
+#ifdef WTF_USE_GSTREAMER
|
||||
g_option_context_add_group(context, gst_init_get_option_group());
|
||||
-
|
||||
+#endif
|
||||
webkitSettings = webkit_web_settings_new();
|
||||
g_object_set(webkitSettings, "enable-developer-extras", TRUE, NULL);
|
||||
if (!addWebSettingsGroupToContext(context, webkitSettings)) {
|
||||
--
|
||||
1.8.3.2
|
||||
|
28
package/webkit/webkit-detect-harfbuzz-icu.patch
Normal file
28
package/webkit/webkit-detect-harfbuzz-icu.patch
Normal file
@ -0,0 +1,28 @@
|
||||
harfbuzz-icu detections based on the following upstream commits
|
||||
|
||||
- 5f3ae29ffb29c499c1825578ba7f3ffcbf1aa8b9
|
||||
- ad2a23ec44b692bde43a13b658990770caa8dfc5
|
||||
- 22b4786377142424bfb6562ff029997acd0846d1
|
||||
|
||||
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
|
||||
|
||||
Index: webkit-1.11.5/configure.ac
|
||||
===================================================================
|
||||
--- webkit-1.11.5.orig/configure.ac
|
||||
+++ webkit-1.11.5/configure.ac
|
||||
@@ -938,6 +938,15 @@ PKG_CHECK_MODULES([FREETYPE],
|
||||
freetype2 >= $FREETYPE2_REQUIRED_VERSION
|
||||
harfbuzz])
|
||||
fi
|
||||
+# HarfBuzz 0.9.18 splits harbuzz-icu into a separate library.
|
||||
+# Since we support earlier HarfBuzz versions we keep this conditional for now.
|
||||
+m4_define([harfbuzz_required_version], [0.9.7])
|
||||
+if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
|
||||
+ PKG_CHECK_MODULES([HARFBUZZ_ICU], [harfbuzz-icu >= $harfbuzz_required_version])
|
||||
+ FREETYPE_CFLAGS+=" $HARFBUZZ_ICU_CFLAGS"
|
||||
+ FREETYPE_LIBS+=" $HARFBUZZ_ICU_LIBS"
|
||||
+fi
|
||||
+
|
||||
AC_SUBST([FREETYPE_CFLAGS])
|
||||
AC_SUBST([FREETYPE_LIBS])
|
||||
|
@ -2,12 +2,13 @@ This patch prevents documentation from being rebased or installed. This
|
||||
prevents an error when gtk-doc --rebase is called.
|
||||
|
||||
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
|
||||
----
|
||||
Index: webkit-1.9.6/Tools/GNUmakefile.am
|
||||
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
|
||||
|
||||
Index: webkit-1.11.5/Tools/GNUmakefile.am
|
||||
===================================================================
|
||||
--- webkit-1.9.6.orig/Tools/GNUmakefile.am 2012-08-06 07:34:49.000000000 -0500
|
||||
+++ webkit-1.9.6/Tools/GNUmakefile.am 2013-05-28 21:29:54.135112927 -0500
|
||||
@@ -262,6 +262,8 @@
|
||||
--- webkit-1.11.5.orig/Tools/GNUmakefile.am
|
||||
+++ webkit-1.11.5/Tools/GNUmakefile.am
|
||||
@@ -308,6 +308,8 @@ EXTRA_DIST += \
|
||||
Tools/Scripts/webkit-build-directory \
|
||||
Tools/Scripts/webkitdirs.pm
|
||||
|
||||
@ -16,7 +17,7 @@ Index: webkit-1.9.6/Tools/GNUmakefile.am
|
||||
docs: docs-build.stamp
|
||||
.PHONY : docs
|
||||
DISTCLEANFILES += docs-build.stamp
|
||||
@@ -362,7 +364,6 @@
|
||||
@@ -412,7 +414,6 @@ if ENABLE_WEBKIT2
|
||||
rm -rf $${installdir}
|
||||
endif
|
||||
|
||||
|
@ -1,13 +1,14 @@
|
||||
Fixes uclibc build as uclibc does not include backtrace functionality
|
||||
|
||||
Signed-of-by: Spenser Gilliland <spenser@gillilanding.com>
|
||||
----
|
||||
Index: webkit-1.9.6/Source/WTF/wtf/Assertions.cpp
|
||||
Signed-of-by: Markos Chandras <markos.chandras@imgtec.com>
|
||||
|
||||
Index: webkit-1.11.5/Source/WTF/wtf/Assertions.cpp
|
||||
===================================================================
|
||||
--- webkit-1.9.6.orig/Source/WTF/wtf/Assertions.cpp
|
||||
+++ webkit-1.9.6/Source/WTF/wtf/Assertions.cpp
|
||||
--- webkit-1.11.5.orig/Source/WTF/wtf/Assertions.cpp
|
||||
+++ webkit-1.11.5/Source/WTF/wtf/Assertions.cpp
|
||||
@@ -61,8 +61,10 @@
|
||||
#if (OS(DARWIN) || OS(LINUX)) && !OS(ANDROID)
|
||||
#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
|
||||
#include <cxxabi.h>
|
||||
#include <dlfcn.h>
|
||||
+#if !defined(__UCLIBC__)
|
||||
@ -17,12 +18,3 @@ Index: webkit-1.9.6/Source/WTF/wtf/Assertions.cpp
|
||||
|
||||
#if OS(ANDROID)
|
||||
#include "android/log.h"
|
||||
@@ -268,7 +270,7 @@ void WTFReportArgumentAssertionFailure(c
|
||||
|
||||
void WTFGetBacktrace(void** stack, int* size)
|
||||
{
|
||||
-#if (OS(DARWIN) || OS(LINUX)) && !OS(ANDROID)
|
||||
+#if (OS(DARWIN) || OS(LINUX)) && !OS(ANDROID) && !defined(__UCLIBC__)
|
||||
*size = backtrace(stack, *size);
|
||||
#elif OS(WINDOWS) && !OS(WINCE)
|
||||
// The CaptureStackBackTrace function is available in XP, but it is not defined
|
||||
|
1490
package/webkit/webkit-mips-dfg.patch
Normal file
1490
package/webkit/webkit-mips-dfg.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -4,22 +4,32 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
WEBKIT_VERSION = 1.9.6
|
||||
WEBKIT_VERSION = 1.11.5
|
||||
WEBKIT_SITE = http://www.webkitgtk.org/releases
|
||||
WEBKIT_SOURCE = webkit-$(WEBKIT_VERSION).tar.xz
|
||||
WEBKIT_SOURCE = webkitgtk-$(WEBKIT_VERSION).tar.xz
|
||||
WEBKIT_INSTALL_STAGING = YES
|
||||
WEBKIT_DEPENDENCIES = host-ruby host-flex host-bison host-gperf icu libcurl \
|
||||
libxml2 libxslt libgtk2 sqlite enchant libsoup jpeg libgail
|
||||
WEBKIT_DEPENDENCIES = host-ruby host-flex host-bison host-gperf enchant harfbuzz \
|
||||
icu jpeg libcurl libgail libsecret libsoup libxml2 libxslt libgtk2 sqlite webp
|
||||
|
||||
# webkit-disable-tests.patch changes configure.ac therefore autoreconf required
|
||||
WEBKIT_AUTORECONF = YES
|
||||
WEBKIT_AUTORECONF_OPT = -I $(@D)/Source/autotools
|
||||
|
||||
# Does not build and it's disabled by default
|
||||
# in newer releases
|
||||
define DISABLE_INDEXED_DATABASE
|
||||
$(SED) '/ENABLE_INDEXED_DATABASE/s:1:0:' \
|
||||
$(@D)/Source/WebCore/GNUmakefile.features.am
|
||||
endef
|
||||
|
||||
WEBKIT_PRE_CONFIGURE_HOOKS += DISABLE_INDEXED_DATABASE
|
||||
|
||||
# Give explicit path to icu-config, and silence gazillions of warnings
|
||||
# with recent gcc versions.
|
||||
WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
|
||||
CFLAGS="$(TARGET_CFLAGS) -Wno-cast-align -Wno-sign-compare" \
|
||||
CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align -Wno-sign-compare"
|
||||
CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align -Wno-sign-compare" \
|
||||
AR_FLAGS="cru"
|
||||
|
||||
WEBKIT_CONF_OPT += \
|
||||
--with-gtk=2.0 \
|
||||
|
Loading…
Reference in New Issue
Block a user