package/nfs-utils: bump version to 2.6.4
Remove patches backported from this release. Backport 2 patches from upstream ML needed for uClibc-ng on mips. Require kernel 3.17 due getrandom() dependency. Add host-util-linux to HOST_NFS_UTILS_DEPENDENCIES (new uuid.h dependency). Fixes: http://autobuild.buildroot.net/results/c5fde6099a8b228a8bdc3154d1e47dfa192e94ed/ Reviewed-by: Giulio Benetti <giulio.benetti@benettiengineering.com> Signed-off-by: Petr Vorel <petr.vorel@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
f4abda15d3
commit
52d405de45
@ -1,79 +0,0 @@
|
||||
From bc4a5deef9f820c55fdac3c0070364c17cd91cca Mon Sep 17 00:00:00 2001
|
||||
From: Wiktor Jaskulski <wjaskulski@adva.com>
|
||||
Date: Thu, 11 May 2023 15:28:23 -0400
|
||||
Subject: [PATCH] configure.ac: libevent and libsqlite3 checked when nfsv4 is
|
||||
disabled
|
||||
|
||||
Upstream: https://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=bc4a5deef9f820c55fdac3c0070364c17cd91cca
|
||||
|
||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
||||
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
---
|
||||
configure.ac | 38 +++++++++++++++-----------------------
|
||||
1 file changed, 15 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 9df52e9c..6fbcb974 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -338,42 +338,34 @@ CPPFLAGS="${nfsutils_save_CPPFLAGS}"
|
||||
AC_CHECK_HEADER(uuid/uuid.h, ,
|
||||
AC_MSG_ERROR([Cannot find needed header file uuid/uuid.h. Install libuuid-devel]))
|
||||
|
||||
+dnl check for libevent libraries and headers
|
||||
+AC_LIBEVENT
|
||||
+
|
||||
+dnl Check for sqlite3
|
||||
+AC_SQLITE3_VERS
|
||||
+
|
||||
+case $libsqlite3_cv_is_recent in
|
||||
+yes) ;;
|
||||
+unknown)
|
||||
+ dnl do not fail when cross-compiling
|
||||
+ AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
|
||||
+*)
|
||||
+ AC_MSG_ERROR([nfsdcld requires sqlite-devel]) ;;
|
||||
+esac
|
||||
+
|
||||
if test "$enable_nfsv4" = yes; then
|
||||
- dnl check for libevent libraries and headers
|
||||
- AC_LIBEVENT
|
||||
|
||||
dnl check for the keyutils libraries and headers
|
||||
AC_KEYUTILS
|
||||
|
||||
- dnl Check for sqlite3
|
||||
- AC_SQLITE3_VERS
|
||||
-
|
||||
if test "$enable_nfsdcld" = "yes"; then
|
||||
AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
|
||||
AC_MSG_ERROR([Cannot find header needed for nfsdcld]))
|
||||
-
|
||||
- case $libsqlite3_cv_is_recent in
|
||||
- yes) ;;
|
||||
- unknown)
|
||||
- dnl do not fail when cross-compiling
|
||||
- AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
|
||||
- *)
|
||||
- AC_MSG_ERROR([nfsdcld requires sqlite-devel]) ;;
|
||||
- esac
|
||||
fi
|
||||
|
||||
if test "$enable_nfsdcltrack" = "yes"; then
|
||||
AC_CHECK_HEADERS([libgen.h sys/inotify.h], ,
|
||||
AC_MSG_ERROR([Cannot find header needed for nfsdcltrack]))
|
||||
-
|
||||
- case $libsqlite3_cv_is_recent in
|
||||
- yes) ;;
|
||||
- unknown)
|
||||
- dnl do not fail when cross-compiling
|
||||
- AC_MSG_WARN([assuming sqlite is at least v3.3]) ;;
|
||||
- *)
|
||||
- AC_MSG_ERROR([nfsdcltrack requires sqlite-devel]) ;;
|
||||
- esac
|
||||
fi
|
||||
|
||||
else
|
||||
--
|
||||
2.34.1
|
||||
|
@ -0,0 +1,44 @@
|
||||
From 4710e469cd0f512ac5e2c3c4335d8e21b97f21b0 Mon Sep 17 00:00:00 2001
|
||||
From: Petr Vorel <pvorel@suse.cz>
|
||||
Date: Tue, 5 Dec 2023 20:40:36 +0100
|
||||
Subject: [PATCH] reexport/{fsidd,reexport}.c: Re-add missing includes
|
||||
|
||||
Older uClibc-ng requires <unistd.h> for close(2), unlink(2) and write(2),
|
||||
<sys/un.h> for struct sockaddr_un.
|
||||
|
||||
Fixes: 1a4edb2a ("reexport/fsidd.c: Remove unused headers")
|
||||
Fixes: bdc79f02 ("support/reexport.c: Remove unused headers")
|
||||
Signed-off-by: Petr Vorel <pvorel@suse.cz>
|
||||
Upstream: https://lore.kernel.org/linux-nfs/20231205223543.31443-1-pvorel@suse.cz/
|
||||
---
|
||||
support/reexport/fsidd.c | 2 ++
|
||||
support/reexport/reexport.c | 1 +
|
||||
2 files changed, 3 insertions(+)
|
||||
|
||||
diff --git a/support/reexport/fsidd.c b/support/reexport/fsidd.c
|
||||
index 3e62b3fc..814fb48e 100644
|
||||
--- a/support/reexport/fsidd.c
|
||||
+++ b/support/reexport/fsidd.c
|
||||
@@ -7,6 +7,8 @@
|
||||
#include <dlfcn.h>
|
||||
#endif
|
||||
#include <event2/event.h>
|
||||
+#include <sys/un.h>
|
||||
+#include <unistd.h>
|
||||
|
||||
#include "conffile.h"
|
||||
#include "reexport_backend.h"
|
||||
diff --git a/support/reexport/reexport.c b/support/reexport/reexport.c
|
||||
index 78516586..1900b336 100644
|
||||
--- a/support/reexport/reexport.c
|
||||
+++ b/support/reexport/reexport.c
|
||||
@@ -7,6 +7,7 @@
|
||||
#endif
|
||||
#include <sys/types.h>
|
||||
#include <sys/vfs.h>
|
||||
+#include <unistd.h>
|
||||
#include <errno.h>
|
||||
|
||||
#include "nfsd_path.h"
|
||||
--
|
||||
2.43.0
|
@ -0,0 +1,31 @@
|
||||
From aee92881ba80cf2ae7381d19f09e7fbeda57974c Mon Sep 17 00:00:00 2001
|
||||
From: Petr Vorel <petr.vorel@gmail.com>
|
||||
Date: Tue, 5 Dec 2023 23:20:33 +0100
|
||||
Subject: [PATCH] support/backend_sqlite.c: Add missing <sys/syscall.h>
|
||||
|
||||
This fixes build on systems which actually needs getrandom()
|
||||
(to get SYS_getrandom).
|
||||
|
||||
Fixes: f92fd6ca ("support/backend_sqlite.c: Add getrandom() fallback")
|
||||
Fixes: http://autobuild.buildroot.net/results/c5fde6099a8b228a8bdc3154d1e47dfa192e94ed/
|
||||
Reported-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
|
||||
Signed-off-by: Petr Vorel <pvorel@suse.cz>
|
||||
Upstream: https://lore.kernel.org/linux-nfs/20231205223543.31443-2-pvorel@suse.cz/
|
||||
---
|
||||
support/reexport/backend_sqlite.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/support/reexport/backend_sqlite.c b/support/reexport/backend_sqlite.c
|
||||
index 0eb5ea37..54dfe447 100644
|
||||
--- a/support/reexport/backend_sqlite.c
|
||||
+++ b/support/reexport/backend_sqlite.c
|
||||
@@ -7,6 +7,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <sys/syscall.h>
|
||||
#include <unistd.h>
|
||||
|
||||
#ifdef HAVE_GETRANDOM
|
||||
--
|
||||
2.43.0
|
@ -1,44 +0,0 @@
|
||||
From 274e4d212c30183242e48b639889865819f3ac33 Mon Sep 17 00:00:00 2001
|
||||
From: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
Date: Sun, 11 Jun 2023 08:57:11 +0200
|
||||
Subject: [PATCH] support/reexport: guard dlfcn.h include with HAVE_DLFCN_H
|
||||
|
||||
Upstream: http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commitdiff;h=8125c6f4ad156a9bad0dc2cc42e0243380fc478d
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
---
|
||||
support/reexport/fsidd.c | 2 ++
|
||||
support/reexport/reexport.c | 2 ++
|
||||
2 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/support/reexport/fsidd.c b/support/reexport/fsidd.c
|
||||
index 37649d06..d4b245e8 100644
|
||||
--- a/support/reexport/fsidd.c
|
||||
+++ b/support/reexport/fsidd.c
|
||||
@@ -3,7 +3,9 @@
|
||||
#endif
|
||||
|
||||
#include <assert.h>
|
||||
+#ifdef HAVE_DLFCN_H
|
||||
#include <dlfcn.h>
|
||||
+#endif
|
||||
#include <event2/event.h>
|
||||
#include <limits.h>
|
||||
#include <stdint.h>
|
||||
diff --git a/support/reexport/reexport.c b/support/reexport/reexport.c
|
||||
index d597a2f7..d9a700af 100644
|
||||
--- a/support/reexport/reexport.c
|
||||
+++ b/support/reexport/reexport.c
|
||||
@@ -2,7 +2,9 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_DLFCN_H
|
||||
#include <dlfcn.h>
|
||||
+#endif
|
||||
#include <stdint.h>
|
||||
#include <stdio.h>
|
||||
#include <sys/random.h>
|
||||
--
|
||||
2.39.2
|
||||
|
@ -1,11 +1,12 @@
|
||||
comment "nfs-utils needs a toolchain w/ threads"
|
||||
comment "nfs-utils needs a toolchain w/ threads, headers >= 3.17"
|
||||
depends on BR2_USE_MMU
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17
|
||||
|
||||
config BR2_PACKAGE_NFS_UTILS
|
||||
bool "nfs-utils"
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS # libtirpc, rpcbind
|
||||
depends on BR2_USE_MMU # fork()
|
||||
depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17 # getrandom()
|
||||
select BR2_PACKAGE_LIBEVENT
|
||||
select BR2_PACKAGE_LIBTIRPC # IPv6 requires libtirpc
|
||||
select BR2_PACKAGE_SQLITE
|
||||
|
@ -1,4 +1,4 @@
|
||||
# From https://www.kernel.org/pub/linux/utils/nfs-utils/2.6.3/sha256sums.asc
|
||||
sha256 38d89e853a71d3c560ff026af3d969d75e24f782ff68324e76261fe0344459e1 nfs-utils-2.6.3.tar.xz
|
||||
# From https://www.kernel.org/pub/linux/utils/nfs-utils/2.6.4/sha256sums.asc
|
||||
sha256 01b3b0fb9c7d0bbabf5114c736542030748c788ec2fd9734744201e9b0a1119d nfs-utils-2.6.4.tar.xz
|
||||
# Locally computed
|
||||
sha256 576540abf5e95029ad4ad90e32071385a5e95b2c30708c706116f3eb87b9a3de COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
NFS_UTILS_VERSION = 2.6.3
|
||||
NFS_UTILS_VERSION = 2.6.4
|
||||
NFS_UTILS_SOURCE = nfs-utils-$(NFS_UTILS_VERSION).tar.xz
|
||||
NFS_UTILS_SITE = https://www.kernel.org/pub/linux/utils/nfs-utils/$(NFS_UTILS_VERSION)
|
||||
NFS_UTILS_LICENSE = GPL-2.0+
|
||||
@ -22,7 +22,7 @@ NFS_UTILS_CONF_OPTS = \
|
||||
--with-statedir=/run/nfs \
|
||||
--with-rpcgen=$(HOST_DIR)/bin/rpcgen
|
||||
|
||||
HOST_NFS_UTILS_DEPENDENCIES = host-pkgconf host-libtirpc host-libevent host-sqlite
|
||||
HOST_NFS_UTILS_DEPENDENCIES = host-pkgconf host-libtirpc host-libevent host-sqlite host-util-linux
|
||||
|
||||
HOST_NFS_UTILS_CONF_OPTS = \
|
||||
--enable-tirpc \
|
||||
|
Loading…
Reference in New Issue
Block a user