diff --git a/package/pseudo/pseudo.mk b/package/pseudo/pseudo.mk
index 92de2c6f1b..a924e10c45 100644
--- a/package/pseudo/pseudo.mk
+++ b/package/pseudo/pseudo.mk
@@ -16,7 +16,12 @@ HOST_PSEUDO_DEPENDENCIES = host-attr host-sqlite
 
 # configure script is not generated by autoconf, so passing --libdir
 # is necessary, even if the infrastructure passes --prefix already.
+# It also does not use CFLAGS from the environment, they need to be
+# specified with a custom --cflags option. Also force rpath to avoid
+# a warning at configure time.
 HOST_PSEUDO_CONF_OPTS = \
+	--cflags="$(HOSTCFLAGS)" \
+	--with-rpath=$(HOST_DIR)/usr/lib \
 	--bits=$(if $(filter %64,$(HOSTARCH)),64,32) \
 	--libdir=$(HOST_DIR)/usr/lib \
 	--with-sqlite=$(HOST_DIR)/usr