package/libcap: bump version to 2.62

Removed patch which was applied upstream:
https://git.kernel.org/pub/scm/libs/libcap/libcap.git/commit/?id=afbc554d16a32ed352191e49b3673f2f72d0002f

Release notes:
https://sites.google.com/site/fullycapable/release-notes-for-libcap

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Bernd Kuhls 2022-01-08 10:45:33 +01:00 committed by Peter Korsgaard
parent efd0435add
commit 5260f3189b
3 changed files with 2 additions and 52 deletions

View File

@ -1,50 +0,0 @@
From dc507a812d931c24f1ac98c811fdd29bffa21da9 Mon Sep 17 00:00:00 2001
From: "Arnout Vandecappelle (Essensium/Mind)" <arnout@mind.be>
Date: Tue, 24 Aug 2021 00:36:40 +0200
Subject: [PATCH] libcap/Makefile: don't overwrite 'empty' when generating
loader.txt
objcopy takes an input file and an output file as arguments. If the
output file is left out, the input file will be overwritten.
Since the objcopy command used to generate loader.txt only does a
dump-section and no filtering, in practice there is no change to empty.
However, as a side-effect, its timestamp is updated. The timestamp of
empty and of loader.txt will be more or less the same; however,
loader.txt is closed just before the output file is closed, so it's
possible that the timestamp of loader.txt is just a little bit earlier.
If this happens, it causes loader.txt to be rebuilt later, which in turn
causes a number of other object files to be rebuilt.
Usually that's harmless, but it sometimes causes the rebuild to happen
during 'make install'. This is particularly annoying if 'make install'
is done as root, since loader.txt becomes owned by root in that case.
Fix this by specifying a harmless output file: /dev/null.
While we're at it, take in an upstream change that removes the redundant
redirect.
Fixes: ee3b25c0a877fa74d1aec88f325ac45b09963c82
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
---
libcap/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libcap/Makefile b/libcap/Makefile
index 47cf8f4..18e4f4f 100644
--- a/libcap/Makefile
+++ b/libcap/Makefile
@@ -105,7 +105,7 @@ empty: empty.c
$(CC) -o $@ $<
loader.txt: empty
- $(OBJCOPY) --dump-section .interp=/dev/stdout $< > $@
+ $(OBJCOPY) --dump-section .interp=$@ $< /dev/null
cap_magic.o: execable.h execable.c loader.txt
$(CC) $(CFLAGS) $(IPATH) -DLIBRARY_VERSION=\"$(LIBTITLE)-$(VERSION).$(MINOR)\" -DSHARED_LOADER=\"$(shell cat loader.txt)\" -c execable.c -o $@
--
2.31.1

View File

@ -1,5 +1,5 @@
# https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/sha256sums.asc
sha256 a2faacd55ae5959db1b0c695f91f256ac4c5e6b10acaeaeaf508ea1ee887fa97 libcap-2.52.tar.xz
sha256 190c5baac9bee06a129eae20d3e827de62f664fe3507f0bf6c50a9a59fbd83a2 libcap-2.62.tar.xz
# Hash for license file:
sha256 f58c80bcce8c929db39a23c32e924876e3311f3ffa54f66076c38056d38fa59b License

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBCAP_VERSION = 2.52
LIBCAP_VERSION = 2.62
LIBCAP_SITE = https://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2
LIBCAP_SOURCE = libcap-$(LIBCAP_VERSION).tar.xz
LIBCAP_LICENSE = GPL-2.0 or BSD-3-Clause