Merge branch 'misc-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
This commit is contained in:
commit
51a5b44461
@ -82,7 +82,7 @@ AVAHI_CONF_OPT = --localstatedir=/var \
|
||||
--with-autoipd-user=default \
|
||||
--with-autoipd-group=default
|
||||
|
||||
AVAHI_DEPENDENCIES = $(if $(BR2_PACKAGE_GETTEXT),gettext)
|
||||
AVAHI_DEPENDENCIES = $(if $(BR2_PACKAGE_GETTEXT),gettext) host-intltool
|
||||
|
||||
ifneq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_AVAHI_AUTOIPD),)
|
||||
AVAHI_DEPENDENCIES += libdaemon
|
||||
|
13
package/busybox/busybox-1.16.0-fsync.patch
Normal file
13
package/busybox/busybox-1.16.0-fsync.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -urpN busybox-1.16.0/coreutils/fsync.c busybox-1.16.0-fsync/coreutils/fsync.c
|
||||
--- busybox-1.16.0/coreutils/fsync.c 2010-01-25 01:59:38.000000000 +0100
|
||||
+++ busybox-1.16.0-fsync/coreutils/fsync.c 2010-02-26 08:24:59.000000000 +0100
|
||||
@@ -7,6 +7,9 @@
|
||||
* Licensed under GPLv2 or later, see file LICENSE in this tarball for details.
|
||||
*/
|
||||
#include "libbb.h"
|
||||
+#ifndef O_NOATIME
|
||||
+# define O_NOATIME 0
|
||||
+#endif
|
||||
|
||||
/* This is a NOFORK applet. Be very careful! */
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -urN cgicc-3.2.7-0rig//demo/dns.cpp cgicc-3.2.7/demo/dns.cpp
|
||||
--- cgicc-3.2.7-0rig//demo/dns.cpp 2009-01-21 00:24:13.000000000 +0100
|
||||
+++ cgicc-3.2.7/demo/dns.cpp 2009-01-21 00:24:30.000000000 +0100
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <vector>
|
||||
#include <stdexcept>
|
||||
#include <iostream>
|
||||
+#include <string.h>
|
||||
|
||||
#include "cgicc/CgiDefs.h"
|
||||
#include "cgicc/Cgicc.h"
|
||||
|
@ -0,0 +1,50 @@
|
||||
Index: cgicc-3.2.9/Makefile.am
|
||||
===================================================================
|
||||
--- cgicc-3.2.9.orig/Makefile.am 2010-02-25 16:34:06.000000000 +0100
|
||||
+++ cgicc-3.2.9/Makefile.am 2010-02-25 16:34:14.000000000 +0100
|
||||
@@ -8,9 +8,15 @@
|
||||
DEMO =
|
||||
endif
|
||||
|
||||
+if DOC
|
||||
+DOCDIR = doc
|
||||
+else
|
||||
+DOC =
|
||||
+endif
|
||||
+
|
||||
ACLOCAL_AMFLAGS=
|
||||
|
||||
-SUBDIRS = cgicc doc support $(DEMO)
|
||||
+SUBDIRS = cgicc $(DOCDIR) support $(DEMO)
|
||||
|
||||
CLEANFILES = *~
|
||||
|
||||
Index: cgicc-3.2.9/configure.ac
|
||||
===================================================================
|
||||
--- cgicc-3.2.9.orig/configure.ac 2010-02-25 16:34:06.000000000 +0100
|
||||
+++ cgicc-3.2.9/configure.ac 2010-02-25 16:45:46.000000000 +0100
|
||||
@@ -17,9 +17,23 @@
|
||||
AC_PROG_CXX
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_LIBTOOL
|
||||
-AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, /bin/echo)
|
||||
|
||||
|
||||
+AC_ARG_ENABLE(doc,
|
||||
+ [ --enable-doc build doc [[default=yes]]],
|
||||
+ [case "${enableval}" in
|
||||
+ yes) cgicc_doc=yes ;;
|
||||
+ no) cgicc_doc=no ;;
|
||||
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-doc) ;;
|
||||
+ esac], cgicc_doc=yes)
|
||||
+
|
||||
+if test "$cgicc_doc" = yes; then
|
||||
+ AC_CHECK_PROG(DOXYGEN, doxygen, doxygen)
|
||||
+ if test -z "$DOXYGEN" ; then
|
||||
+ AC_MSG_ERROR([Doxygen is required to build the documentation])
|
||||
+ fi
|
||||
+fi
|
||||
+AM_CONDITIONAL(DOC, test "$cgicc_doc" = yes)
|
||||
|
||||
dnl Determine host system type
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
#############################################################
|
||||
|
||||
LIBCGICC_VERSION=3.2.7
|
||||
LIBCGICC_VERSION=3.2.9
|
||||
LIBCGICC_DIR=$(BUILD_DIR)/cgicc-$(LIBCGICC_VERSION)
|
||||
LIBCGICC_SITE=$(BR2_GNU_MIRROR)/cgicc
|
||||
LIBCGICC_SOURCE=cgicc-$(LIBCGICC_VERSION).tar.gz
|
||||
@ -22,6 +22,7 @@ $(LIBCGICC_DIR)/.unpacked: $(DL_DIR)/$(LIBCGICC_SOURCE)
|
||||
|
||||
$(LIBCGICC_DIR)/.configured: $(LIBCGICC_DIR)/.unpacked
|
||||
(cd $(LIBCGICC_DIR); rm -f config.cache; \
|
||||
$(AUTORECONF); \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
$(TARGET_CONFIGURE_ARGS) \
|
||||
./configure $(QUIET) \
|
||||
@ -33,15 +34,16 @@ $(LIBCGICC_DIR)/.configured: $(LIBCGICC_DIR)/.unpacked
|
||||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--disable-demos \
|
||||
--disable-doc \
|
||||
)
|
||||
touch $@
|
||||
|
||||
$(LIBCGICC_DIR)/.compiled: $(LIBCGICC_DIR)/.configured
|
||||
$(MAKE) -C $(LIBCGICC_DIR)
|
||||
$(TARGET_MAKE_ENV) $(MAKE) -C $(LIBCGICC_DIR)
|
||||
touch $@
|
||||
|
||||
$(STAGING_DIR)/usr/lib/libcgicc.so: $(LIBCGICC_DIR)/.compiled
|
||||
$(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBCGICC_DIR) install
|
||||
$(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBCGICC_DIR) install
|
||||
touch -c $(STAGING_DIR)/usr/lib/libcgicc.so
|
||||
|
||||
$(TARGET_DIR)/usr/lib/libcgicc.so: $(STAGING_DIR)/usr/lib/libcgicc.so
|
||||
|
@ -6,7 +6,7 @@
|
||||
|
||||
LIBRAW1394_VERSION:=1.2.1
|
||||
LIBRAW1394_SOURCE:=libraw1394-$(LIBRAW1394_VERSION).tar.gz
|
||||
LIBRAW1394_SITE:=http://www.linux1394.org/dl
|
||||
LIBRAW1394_SITE:=http://www.kernel.org/pub/linux/libs/ieee1394/
|
||||
LIBRAW1394_DIR:=$(BUILD_DIR)/libraw1394-$(LIBRAW1394_VERSION)
|
||||
|
||||
$(DL_DIR)/$(LIBRAW1394_SOURCE):
|
||||
|
@ -20,10 +20,10 @@ $(CRAMFS_DIR): $(DL_DIR)/$(CRAMFS_SOURCE)
|
||||
toolchain/patch-kernel.sh $(CRAMFS_DIR) target/cramfs/ cramfs\*.patch
|
||||
|
||||
$(CRAMFS_DIR)/mkcramfs: $(CRAMFS_DIR)
|
||||
$(MAKE) CFLAGS="-Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64" -C $(CRAMFS_DIR)
|
||||
$(MAKE) CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64" LDFLAGS="$(HOST_LDFLAGS)" -C $(CRAMFS_DIR)
|
||||
touch -c $@
|
||||
|
||||
cramfs: $(CRAMFS_DIR)/mkcramfs
|
||||
cramfs: host-zlib $(CRAMFS_DIR)/mkcramfs
|
||||
|
||||
cramfs-source: $(DL_DIR)/$(CRAMFS_SOURCE)
|
||||
|
||||
|
65
target/squashfs/squashfs-4.0-build-system-fix.patch
Normal file
65
target/squashfs/squashfs-4.0-build-system-fix.patch
Normal file
@ -0,0 +1,65 @@
|
||||
Fix the build system so that CFLAGS can be overriden on the command
|
||||
line to pass additionnal -I options.
|
||||
|
||||
Patch borrowed from OpenEmbedded.
|
||||
|
||||
Index: squashfs-4.0/squashfs-tools/Makefile
|
||||
===================================================================
|
||||
--- squashfs-4.0.orig/squashfs-tools.orig/Makefile 2009-04-19 01:47:43.000000000 +0200
|
||||
+++ squashfs-4.0/squashfs-tools/Makefile 2009-04-19 01:52:36.000000000 +0200
|
||||
@@ -1,36 +1,48 @@
|
||||
INSTALL_DIR = /usr/local/bin
|
||||
|
||||
INCLUDEDIR = .
|
||||
+CFLAGS_R = -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
|
||||
+LIBS = -lz -lpthread
|
||||
|
||||
CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
|
||||
|
||||
all: mksquashfs unsquashfs
|
||||
|
||||
mksquashfs: mksquashfs.o read_fs.o sort.o swap.o pseudo.o
|
||||
- $(CC) mksquashfs.o read_fs.o sort.o swap.o pseudo.o -lz -lpthread -lm -o $@
|
||||
+ $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o swap.o pseudo.o -lz -lpthread -lm -o $@
|
||||
|
||||
mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h squashfs_swap.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h squashfs_swap.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
sort.o: sort.c squashfs_fs.h global.h sort.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
swap.o: swap.c Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
pseudo.o: pseudo.c pseudo.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
unsquashfs: unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o
|
||||
- $(CC) unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o -lz -lpthread -lm -o $@
|
||||
+ $(CC) $(LDFLAGS) unsquashfs.o unsquash-1.o unsquash-2.o unsquash-3.o unsquash-4.o swap.o -lz -lpthread -lm -o $@
|
||||
|
||||
-unsquashfs.o: unsquashfs.h unsquashfs.c squashfs_fs.h squashfs_swap.h squashfs_compat.h global.h Makefile
|
||||
+unsquashfs.o: unsquashfs.c unsquashfs.h squashfs_fs.h squashfs_swap.h squashfs_compat.h global.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
-unsquash-1.o: unsquashfs.h unsquash-1.c squashfs_fs.h squashfs_compat.h global.h Makefile
|
||||
+unsquash-1.o: unsquash-1.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
-unsquash-2.o: unsquashfs.h unsquash-2.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
|
||||
+unsquash-2.o: unsquash-2.c unsquashfs.h unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
-unsquash-3.o: unsquashfs.h unsquash-3.c squashfs_fs.h squashfs_compat.h global.h Makefile
|
||||
+unsquash-3.o: unsquash-3.c unsquashfs.h squashfs_fs.h squashfs_compat.h global.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
-unsquash-4.o: unsquashfs.h unsquash-4.c squashfs_fs.h squashfs_swap.h global.h Makefile
|
||||
+unsquash-4.o: unsquash-4.c unsquashfs.h squashfs_fs.h squashfs_swap.h global.h Makefile
|
||||
+ $(CC) $(CFLAGS_R) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
clean:
|
||||
-rm -f *.o mksquashfs unsquashfs
|
@ -18,9 +18,9 @@ $(SQUASHFS_DIR)/.unpacked: $(DL_DIR)/$(SQUASHFS_SOURCE) #$(SQUASHFS_PATCH)
|
||||
touch $@
|
||||
|
||||
$(SQUASHFS_DIR)/squashfs-tools/mksquashfs: $(SQUASHFS_DIR)/.unpacked
|
||||
$(MAKE) -C $(SQUASHFS_DIR)/squashfs-tools
|
||||
$(MAKE) CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" -C $(SQUASHFS_DIR)/squashfs-tools
|
||||
|
||||
squashfs: $(SQUASHFS_DIR)/squashfs-tools/mksquashfs
|
||||
squashfs: host-zlib $(SQUASHFS_DIR)/squashfs-tools/mksquashfs
|
||||
|
||||
squashfs-source: $(DL_DIR)/$(SQUASHFS_SOURCE)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user