package/python3: bump version to 3.10.2
Refresh 0032-configure.ac-fixup-CC-print-multiarch-output-for-mus.patch now that the MULTIARCH logic got updated by:7e951f356e
Update license hash after a change of copyright years:35955e4ade
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
ab71ac15dd
commit
519a50decd
@ -1,4 +1,4 @@
|
||||
From edc0757c56090364e0a95aabfa9f645a16a27569 Mon Sep 17 00:00:00 2001
|
||||
From d009b0142f77881dd75ff760fec728dbc8581a03 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Korsgaard <peter@korsgaard.com>
|
||||
Date: Fri, 2 Aug 2019 15:53:16 +0200
|
||||
Subject: [PATCH] configure.ac: fixup $CC --print-multiarch output for
|
||||
@ -24,25 +24,28 @@ workaround, rewrite the --print-multiarch output to match older GCC versions
|
||||
to keep the configure script happy.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
||||
[Peter: updated for 3.10.2]
|
||||
---
|
||||
configure.ac | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
configure.ac | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 615c16aced..241298e6cf 100644
|
||||
index 913051c276..aba03f3779 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -873,7 +873,9 @@ fi
|
||||
rm -f conftest.c conftest.out
|
||||
|
||||
if test x$PLATFORM_TRIPLET != xdarwin; then
|
||||
- MULTIARCH=$($CC --print-multiarch 2>/dev/null)
|
||||
@@ -876,7 +876,11 @@ AC_MSG_CHECKING([for multiarch])
|
||||
AS_CASE([$ac_sys_system],
|
||||
[Darwin*], [MULTIARCH=""],
|
||||
[FreeBSD*], [MULTIARCH=""],
|
||||
- [MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
|
||||
+ [
|
||||
+ # GCC 8+ returns $arch-linux-{musl,uclibc} for musl/uClibc based
|
||||
+ # toolchains confusing python. Fix that up
|
||||
+ MULTIARCH=$($CC --print-multiarch 2>/dev/null | sed -E 's/-linux-(musl|uclibc)*$/-linux-gnu/')
|
||||
fi
|
||||
AC_SUBST(MULTIARCH)
|
||||
|
||||
+ ]
|
||||
)
|
||||
AC_SUBST([MULTIARCH])
|
||||
AC_MSG_RESULT([$MULTIARCH])
|
||||
--
|
||||
2.25.1
|
||||
2.20.1
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://www.python.org/downloads/release/python-3101/
|
||||
md5 789210934745a65247a3ebf5da9adb64 Python-3.10.1.tar.xz
|
||||
# From https://www.python.org/downloads/release/python-3102/
|
||||
md5 14e8c22458ed7779a1957b26cde01db9 Python-3.10.2.tar.xz
|
||||
# Locally computed
|
||||
sha256 a7f1265b6e1a5de1ec5c3ec7019ab53413469934758311e9d240c46e5ae6e177 Python-3.10.1.tar.xz
|
||||
sha256 d0285b61e1a8e420c7deb95836738a5d4a0d26463138b17601f5971212684c4b LICENSE
|
||||
sha256 17de3ac7da9f2519aa9d64378c603a73a0e9ad58dffa8812e45160c086de64c7 Python-3.10.2.tar.xz
|
||||
sha256 f03e17cd594c2085f66a454e695c7ebe5b4d3c0eff534f4f194abc2fd164621b LICENSE
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
PYTHON3_VERSION_MAJOR = 3.10
|
||||
PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).1
|
||||
PYTHON3_VERSION = $(PYTHON3_VERSION_MAJOR).2
|
||||
PYTHON3_SOURCE = Python-$(PYTHON3_VERSION).tar.xz
|
||||
PYTHON3_SITE = https://python.org/ftp/python/$(PYTHON3_VERSION)
|
||||
PYTHON3_LICENSE = Python-2.0, others
|
||||
|
Loading…
Reference in New Issue
Block a user