package/xen: bump version to 4.14.0
Bump the Xen package to the latest release. We can also remove a patch to change the CFLAGS as it is no longer required. The hash of the license file is changed, as ZPL-2.0 is no longer listed as one of the licenses of 3rd party code imported into Xen. Signed-off-by: Alistair Francis <alistair@alistair23.me> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
2c2e5355c9
commit
514bbb8520
@ -1,36 +0,0 @@
|
||||
From 8aea14bbd20b04b8fffaf35138ebdcbd39e433a3 Mon Sep 17 00:00:00 2001
|
||||
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
Date: Sat, 29 Oct 2016 16:35:26 +0200
|
||||
Subject: [PATCH] xen/Rules.mk: fix build with CFLAGS from environment
|
||||
|
||||
When CFLAGS are passed from the environment, the first-level make
|
||||
invocation will append -D__OBJECT_FILE__ to it, then call a second
|
||||
make invocation, that will have those new CFLAGS in its environment,
|
||||
but will also append -D__OBJECT_FILE__ to those.
|
||||
|
||||
Then, the compiler fails because __OBEJECT_FILE__ is defined twice.
|
||||
|
||||
Just undefine it before defining it again, as a *workaround* to this
|
||||
issue.
|
||||
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
---
|
||||
xen/Rules.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/xen/Rules.mk b/xen/Rules.mk
|
||||
index 3090ea7828..d535bf9e2f 100644
|
||||
--- a/xen/Rules.mk
|
||||
+++ b/xen/Rules.mk
|
||||
@@ -61,7 +61,7 @@ CFLAGS += -Werror -Wredundant-decls -Wno-pointer-arith
|
||||
$(call cc-option-add,CFLAGS,CC,-Wvla)
|
||||
CFLAGS += -pipe -D__XEN__ -include $(BASEDIR)/include/xen/config.h
|
||||
CFLAGS-$(CONFIG_DEBUG_INFO) += -g
|
||||
-CFLAGS += '-D__OBJECT_FILE__="$@"'
|
||||
+CFLAGS += -U__OBJECT_FILE__ '-D__OBJECT_FILE__="$@"'
|
||||
|
||||
ifneq ($(clang),y)
|
||||
# Clang doesn't understand this command line argument, and doesn't appear to
|
||||
--
|
||||
2.22.0
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 b97ce363e55b12c992063f4466c43cba0a6386ceb7a747b4dc670311f337ef01 xen-4.13.1.tar.gz
|
||||
sha256 36b91794c6d4a678137c70c41e384c03b552c7efba82c0d73e6be842e41ab3d3 COPYING
|
||||
sha256 06839f68ea7620669dbe8b67861213223cc2a7d02ced61b56e5249c50e87f035 xen-4.14.0.tar.gz
|
||||
sha256 ecca9538e9d3f7e3c2bff827502f4495e2ef9e22c451298696ea08886b176c2c COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
XEN_VERSION = 4.13.1
|
||||
XEN_VERSION = 4.14.0
|
||||
XEN_SITE = https://downloads.xenproject.org/release/xen/$(XEN_VERSION)
|
||||
XEN_LICENSE = GPL-2.0
|
||||
XEN_LICENSE_FILES = COPYING
|
||||
|
Loading…
Reference in New Issue
Block a user