package/poco: bump version to 1.12.4

For change log, see:
https://github.com/pocoproject/poco/blob/poco-1.12.4-release/CHANGELOG

This commit also drop the package patch, which was included upstream in
version 1.12.3:
3884c734c2

The file .checkpackageignore is also updated to reflect this patch
removal.

Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Julien Olivain 2023-07-24 22:48:35 +02:00 committed by Thomas Petazzoni
parent 056539bc45
commit 50ef6a6f59
4 changed files with 2 additions and 48 deletions

View File

@ -1173,7 +1173,6 @@ package/pkcs11-helper/0001-openssl-libressl-3-5-0-does-not-have-DSA_meth_set1_na
package/pkgconf/0001-Only-prefix-with-the-sysroot-a-subset-of-variables.patch Upstream
package/pkgconf/0002-Revert-main-assume-modversion-insted-of-version-if-o.patch Upstream
package/pkgconf/pkg-config.in Shellcheck
package/poco/0001-Fix-optional-JSON-support-for-MySQL-3753.patch Sob Upstream
package/poke/0001-configure.ac-HELP2MAN-replace-by-true-when-cross-com.patch Upstream
package/poke/0002-lib-getrandom.c-fix-build-with-uclibc-1.0.35.patch Upstream
package/policycoreutils/0001-Add-DESTDIR-to-all-paths-that-use-an-absolute-path.patch Upstream

View File

@ -1,45 +0,0 @@
From 3884c734c261231c34f59e56cde7ae02945b4dae Mon Sep 17 00:00:00 2001
From: Hernan Martinez <hernan.c.martinez@gmail.com>
Date: Tue, 16 Aug 2022 23:07:25 -0500
Subject: [PATCH] Fix optional JSON support for MySQL (#3753)
* Fix optional JSON support for MySQL
* Fix optional JSON support for MySQLTest
---
Data/MySQL/src/ResultMetadata.cpp | 2 ++
Data/MySQL/testsuite/src/MySQLTest.cpp | 2 ++
2 files changed, 4 insertions(+)
diff --git a/Data/MySQL/src/ResultMetadata.cpp b/Data/MySQL/src/ResultMetadata.cpp
index 61b49dd54..adb5dae84 100644
--- a/Data/MySQL/src/ResultMetadata.cpp
+++ b/Data/MySQL/src/ResultMetadata.cpp
@@ -133,8 +133,10 @@ namespace
case MYSQL_TYPE_LONG_BLOB:
case MYSQL_TYPE_BLOB:
return Poco::Data::MetaColumn::FDT_BLOB;
+#ifdef POCO_MYSQL_JSON
case MYSQL_TYPE_JSON:
return Poco::Data::MetaColumn::FDT_JSON;
+#endif
default:
return Poco::Data::MetaColumn::FDT_UNKNOWN;
}
diff --git a/Data/MySQL/testsuite/src/MySQLTest.cpp b/Data/MySQL/testsuite/src/MySQLTest.cpp
index 80a3683b1..2a286d35e 100644
--- a/Data/MySQL/testsuite/src/MySQLTest.cpp
+++ b/Data/MySQL/testsuite/src/MySQLTest.cpp
@@ -976,7 +976,9 @@ CppUnit::Test* MySQLTest::suite()
CppUnit_addTest(pSuite, MySQLTest, testBLOBStmt);
CppUnit_addTest(pSuite, MySQLTest, testLongBLOB);
CppUnit_addTest(pSuite, MySQLTest, testLongTEXT);
+#ifdef POCO_MYSQL_JSON
CppUnit_addTest(pSuite, MySQLTest, testJSON);
+#endif
CppUnit_addTest(pSuite, MySQLTest, testUnsignedInts);
CppUnit_addTest(pSuite, MySQLTest, testFloat);
CppUnit_addTest(pSuite, MySQLTest, testDouble);
--
2.37.2

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 30442ccb097a0074133f699213a59d6f8c77db5b2c98a7c1ad9c5eeb3a2b06f3 poco-1.12.2.tar.gz
sha256 71ef96c35fced367d6da74da294510ad2c912563f12cd716ab02b6ed10a733ef poco-1.12.4.tar.gz
sha256 c4b1e1e5f36d8331737231fefcc30f5714326aec7c387ad59a8115eb0ba7d6b5 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
POCO_VERSION = 1.12.2
POCO_VERSION = 1.12.4
POCO_SITE = $(call github,pocoproject,poco,poco-$(POCO_VERSION)-release)
POCO_LICENSE = BSL-1.0
POCO_LICENSE_FILES = LICENSE