package/poke: bump to version 1.4

Remove upstream patches:
0001-build-do-not-check-for-Tcl-Tk-if-disable-gui-is-spec.patch
0002-tentatively-change-cppflags-to-omit-I-prefix-on-cros.patch

See:
http://www.jemarch.net/poke-1.4-relnotes.html

Tested:
https://gitlab.com/kubu93/buildroot/-/pipelines/426866708

Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Romain Naour 2021-12-10 12:56:02 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 544839b318
commit 503eecdb87
6 changed files with 6 additions and 117 deletions

View File

@ -1,43 +0,0 @@
From cef3fc90f02ef4fc49515745194bac3d81a2265b Mon Sep 17 00:00:00 2001
From: "Jose E. Marchesi" <jose.marchesi@oracle.com>
Date: Fri, 30 Apr 2021 13:17:05 +0200
Subject: [PATCH] build: do not check for Tcl/Tk if --disable-gui is specified
2021-04-30 Jose E. Marchesi <jemarch@gnu.org>
* configure.ac: Do not check for tcl/tk if --disable-gui is
specified at configure time.
(cherry picked from commit 280a5e154287e43c0a40d9530a9cc658a7367a9c)
[Romain: remove Changelog entry]
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
configure.ac | 9 ++++++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index c7205513..c2f0760a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -214,12 +214,15 @@ fi
dnl The GUI is optional, and depends on the availability of Tcl and
dnl Tk.
-POKE_TCLTK
-
AC_ARG_ENABLE([gui],
AS_HELP_STRING([--enable-gui],
[Enable the GUI (default is YES)]),
- [gui_enabled=$enableval], [gui_enabled=$has_tcltk])
+ [gui_enabled=$enableval], [gui_enabled=yes])
+
+if test "x$gui_enabled" = "xyes"; then
+ POKE_TCLTK
+ gui_enabled=$has_tcltk
+fi
AM_CONDITIONAL([GUI], [test "x$gui_enabled" = "xyes"])
--
2.30.2

View File

@ -1,4 +1,4 @@
From 8ba76a5a7ce311f67890199c5595bc1f626495ad Mon Sep 17 00:00:00 2001 From b35dadae6371c3727cac46ae5bd348b66aa411fc Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@gmail.com> From: Romain Naour <romain.naour@gmail.com>
Date: Fri, 30 Apr 2021 15:43:59 +0200 Date: Fri, 30 Apr 2021 15:43:59 +0200
Subject: [PATCH] configure.ac: HELP2MAN replace ':' by 'true' when Subject: [PATCH] configure.ac: HELP2MAN replace ':' by 'true' when
@ -17,7 +17,7 @@ Signed-off-by: Romain Naour <romain.naour@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-) 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index c2f0760a..93769ef9 100644 index 2c6f1aef..9c4c9be2 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -74,7 +74,7 @@ gl_LIBTEXTSTYLE_OPTIONAL([0.20.5]) @@ -74,7 +74,7 @@ gl_LIBTEXTSTYLE_OPTIONAL([0.20.5])
@ -30,5 +30,5 @@ index c2f0760a..93769ef9 100644
dnl recfix is part of the GNU recutils suite, and is used in cfg.mk to dnl recfix is part of the GNU recutils suite, and is used in cfg.mk to
-- --
2.30.2 2.31.1

View File

@ -1,67 +0,0 @@
From ac9d057895f1e61f63cbecafcc3e3820fdb10f84 Mon Sep 17 00:00:00 2001
From: Luca Saiu <positron@gnu.org>
Date: Fri, 30 Apr 2021 22:42:57 +0200
Subject: [PATCH] tentatively change --cppflags to omit -I prefix on
cross-compilation
The autoconf macros defined from jitter --cppflags get automatically changed, of
course.
* configure.ac (JITTER_CROSS_COMPILING): New substitution.
* bin/jitter-config.in.m4sh (main loop) <--cppflags>: Introduce conditional on
the new substitution.
Suggested by Romain Naour, after his difficulties with building GNU poke with
buildroot.
(cherry picked from commit 428406c7b8d4c20f3472d41ed57c12c1a88ad37e)
[Romain:
patch jitter-config.in instead of jitter-config.in.m4sh since
there is an issue while converting the M4sh m4sh script ( .in.m4sh )
into a portable shell script ( .in ) ready to be processed by aclocal
for @-substitutions.]
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
jitter/bin/jitter-config.in | 10 +++++++---
jitter/configure.ac | 1 +
2 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/jitter/bin/jitter-config.in b/jitter/bin/jitter-config.in
index 5e124f0..4bc508d 100644
--- a/jitter/bin/jitter-config.in
+++ b/jitter/bin/jitter-config.in
@@ -999,10 +999,14 @@ while test "$#" != "0"; do
--cppflags)
no_option_argument
append_to_output cppflags
- # Append a -I argument. This is defined separately from the rest,
- # as the installation prefix can be decided very late, at Jitter
+ # Unless cross-compiling, append a -I argument referring the
+ # installation path. This is defined separately from the rest, as
+ # the installation prefix can be decided very late, at Jitter
# installation time.
- output="$output -I $includedir";;
+ # (When cross-compiling this would be difficult to do correctly.)
+ if test "x@JITTER_CROSS_COMPILING@" != 'xyes'; then
+ output="$output -I $includedir"
+ fi;;
--ldadd)
no_option_argument
append_to_output ldadd;;
diff --git a/jitter/configure.ac b/jitter/configure.ac
index 21d6937..fb12349 100644
--- a/jitter/configure.ac
+++ b/jitter/configure.ac
@@ -308,6 +308,7 @@ else
AC_MSG_RESULT([yes, cross-compiling from $build to $host .])
jitter_cross_compiling=yes
fi
+AC_SUBST([JITTER_CROSS_COMPILING], [$jitter_cross_compiling])
# I never test on weird systems not supporting shebangs.
AC_SYS_INTERPRETER
--
2.31.1

View File

@ -1,4 +1,4 @@
# Locally calculated # Locally calculated
sha256 f61cf8da5b64c01a1359373725aad1ca257f35c1c9269e4d50dd0664183ddf62 poke-1.2.tar.gz sha256 ce054df29560c921230132703ee449fe130b6e25ab03aa6cc796bb401506aa24 poke-1.4.tar.gz
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 jitter/COPYING sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 jitter/COPYING

View File

@ -4,14 +4,13 @@
# #
################################################################################ ################################################################################
POKE_VERSION = 1.2 POKE_VERSION = 1.4
POKE_SITE = $(BR2_GNU_MIRROR)/poke POKE_SITE = $(BR2_GNU_MIRROR)/poke
# gnulib license is a mix/mess of public-domain and various GPL and LGPL versions. # gnulib license is a mix/mess of public-domain and various GPL and LGPL versions.
POKE_LICENSE = GPL-3.0+, GPL-3.0+ (jitter), gnulib license (gnulib) POKE_LICENSE = GPL-3.0+, GPL-3.0+ (jitter), gnulib license (gnulib)
POKE_LICENSE_FILES = COPYING jitter/COPYING POKE_LICENSE_FILES = COPYING jitter/COPYING
# 0001-build-do-not-check-for-Tcl-Tk-if-disable-gui-is-spec.patch # 0001-configure.ac-HELP2MAN-replace-by-false-when-cross-co.patch
# 0003-configure.ac-HELP2MAN-replace-by-false-when-cross-co.patch
POKE_AUTORECONF = YES POKE_AUTORECONF = YES
POKE_DEPENDENCIES = host-flex host-bison host-pkgconf bdwgc readline POKE_DEPENDENCIES = host-flex host-bison host-pkgconf bdwgc readline