package/tmux: remove unsafe headers path

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Romain Naour 2014-12-27 21:34:27 +01:00 committed by Thomas Petazzoni
parent 110605f2c8
commit 501d8d5da8
2 changed files with 38 additions and 0 deletions

View File

@ -0,0 +1,35 @@
From 4095ee95141063ff3f91153e84bd029b019b8dad Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@openwide.fr>
Date: Fri, 26 Dec 2014 17:44:15 +0100
Subject: [PATCH] Makefile.am: remove unsafe headers path
/usr/local/include is probably not needed and it's unsafe for
cross-compilation.
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
Makefile.am | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index a9ad5b9..0109e5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,12 +38,12 @@ else
CFLAGS += -O2
endif
if IS_GCC4
-CPPFLAGS += -iquote. -I/usr/local/include
+CPPFLAGS += -iquote.
if IS_DEBUG
CFLAGS += -Wno-pointer-sign
endif
else
-CPPFLAGS += -I. -I- -I/usr/local/include
+CPPFLAGS += -I. -I-
endif
endif
--
1.9.3

View File

@ -10,4 +10,7 @@ TMUX_LICENSE = ISC
TMUX_LICENSE_FILES = README
TMUX_DEPENDENCIES = libevent ncurses host-pkgconf
# we patch Makefile.am
TMUX_AUTORECONF = YES
$(eval $(autotools-package))