package/libcdaudio: fix build with toolchains lacking C++ support

When the target toolchain does not support C++, the provided
libcdaudio configure script tries to run a check with the C++
pre-processor provided by the host (/lib/cpp) which may not exist on
some systems.

This issue is fixed by autoreconfiguring the package, as newly
generated configure scripts do not have this issue.

Fixes:

  http://autobuild.buildroot.net/results/f725a41ef992c42ceef7514d1a8dcac99e6b9114/

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
(cherry picked from commit 8307fd0132)
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Peter Seiderer 2019-01-13 22:47:22 +01:00 committed by Peter Korsgaard
parent 6c0b001891
commit 4fe00cba02
2 changed files with 46 additions and 0 deletions

View File

@ -0,0 +1,43 @@
From 9c2873b1d9292bcf43c862b6777d41c40521424c Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 13 Jan 2019 22:27:42 +0100
Subject: [PATCH] libcdaudio: enable autoreconf
Fixes the following two autoreconf errors (by simple removing of the
two offending lines):
configure.ac:20: error: automatic de-ANSI-fication support has been removed
Makefile.am:2: error: automatic de-ANSI-fication support has been removed
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Makefile.am | 1 -
configure.ac | 1 -
2 files changed, 2 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index f639dd8..a32cfe6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,4 @@
## Process this file with automake to produce Makefile.in
-AUTOMAKE_OPTIONS = ansi2knr
SUBDIRS = src
bin_SCRIPTS = libcdaudio-config
diff --git a/configure.ac b/configure.ac
index bbdd42d..6699ceb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,7 +17,6 @@ AM_CONFIG_HEADER(config.h)
AC_PROG_AWK
AC_PROG_CC
AC_PROG_CPP
-AM_C_PROTOTYPES
AM_PROG_CC_STDC
AC_PROG_INSTALL
AC_PROG_LN_S
--
2.20.1

View File

@ -11,4 +11,7 @@ LIBCDAUDIO_CONFIG_SCRIPTS = libcdaudio-config
LIBCDAUDIO_LICENSE = GPL-2.0+
LIBCDAUDIO_LICENSE_FILES = COPYING
# fix configure failure when the toolchain doesn't have C++ support
LIBCDAUDIO_AUTORECONF = YES
$(eval $(autotools-package))