package/{avro-c, python-avro}: bump to version 1.11.0
- Drop avro-c patch (already in version) - Drop python-avro patch (not needed anymore) https://github.com/apache/avro/releases/tag/release-1.11.0 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
parent
4a23f6b7b0
commit
4f617bbbf9
@ -1,34 +0,0 @@
|
||||
From 8f5633a29b083a84876c00b88fba6d3e8dbbf1a8 Mon Sep 17 00:00:00 2001
|
||||
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
Date: Sun, 19 Jul 2020 09:35:09 +0200
|
||||
Subject: [PATCH] cmake: Build failure without a C++ compiler (again)
|
||||
|
||||
avro-c fails to build (again) without a C++ compiler because commit
|
||||
664c2fc7fba19709c1f974055f9cf4c8a799e108 reverted the change made by
|
||||
commit 414a51fdc1856083bb16851f09a4c61a48796132
|
||||
|
||||
Fixes:
|
||||
- http://autobuild.buildroot.org/results/cfa91db53cf5502cbb6f902d1e7ad6397c8d70fd
|
||||
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
[Upstream status: https://issues.apache.org/jira/browse/AVRO-2898]
|
||||
---
|
||||
CMakeLists.txt | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 6c8d7aaf..aa923e18 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -17,7 +17,7 @@
|
||||
# under the License.
|
||||
#
|
||||
cmake_minimum_required(VERSION 3.1)
|
||||
-project(AvroC)
|
||||
+project(AvroC C)
|
||||
enable_testing()
|
||||
|
||||
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR})
|
||||
--
|
||||
2.27.0
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://downloads.apache.org/avro/avro-1.10.0/c/avro-c-1.10.0.tar.gz.sha512
|
||||
sha512 2e64926b214fd996abf0553572ec6f46b312cf84df17149d1a7e89f4033b63cc34fabef62b98d727799a8a5d452ac9254e275bdea4bf894e9e1e4588bc5dfc9b avro-c-1.10.0.tar.gz
|
||||
# From https://downloads.apache.org/avro/avro-1.11.0/c/avro-c-1.11.0.tar.gz.sha512
|
||||
sha512 5369ec11832e0ce1aa0181d594f657bae82ab5fb317ec1bee5ba190de9ed42956b425a5bf7e423940e8f871a54ae1246b92db2ce8562f270b4a05523ec4b60ae avro-c-1.11.0.tar.gz
|
||||
|
||||
# License files
|
||||
sha256 d62488d6ba17132e92c23c03c80bfedc848267f96ab36489fec860f76cf6819a LICENSE
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
AVRO_C_VERSION = 1.10.0
|
||||
AVRO_C_VERSION = 1.11.0
|
||||
AVRO_C_SITE = https://www-eu.apache.org/dist/avro/avro-$(AVRO_C_VERSION)/c
|
||||
AVRO_C_LICENSE = Apache-2.0
|
||||
AVRO_C_LICENSE_FILES = LICENSE
|
||||
|
@ -1,46 +0,0 @@
|
||||
From 3446a4af8474cd863efddeae7f3e5dd3f9b8e25e Mon Sep 17 00:00:00 2001
|
||||
From: Titouan Christophe <titouan.christophe@railnova.eu>
|
||||
Date: Mon, 17 Feb 2020 15:12:13 +0100
|
||||
Subject: [PATCH] drop install time linting and imports sorting
|
||||
|
||||
Since the 1.9.2 release, the setup script is also performing code linting
|
||||
tasks, which require additional python libraries.
|
||||
|
||||
These linting tasks are not needed anyway, since they are intended to prepare
|
||||
the code for distribution, but the Buildroot package is already using a
|
||||
distributed version. We therefore simply remove them.
|
||||
|
||||
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
|
||||
---
|
||||
setup.cfg | 2 --
|
||||
setup.py | 1 -
|
||||
2 files changed, 3 deletions(-)
|
||||
|
||||
diff --git a/setup.cfg b/setup.cfg
|
||||
index 7b5de18..d46a36e 100644
|
||||
--- a/setup.cfg
|
||||
+++ b/setup.cfg
|
||||
@@ -25,8 +25,6 @@ package_dir =
|
||||
include_package_data = true
|
||||
packages = avro
|
||||
setup_requires =
|
||||
- isort
|
||||
- pycodestyle
|
||||
install_requires =
|
||||
zip_safe = true
|
||||
scripts =
|
||||
diff --git a/setup.py b/setup.py
|
||||
index f6297bb..91d3287 100755
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -164,7 +164,6 @@ def main():
|
||||
setuptools.setup(cmdclass={
|
||||
"clean": CleanCommand,
|
||||
"generate_interop_data": GenerateInteropDataCommand,
|
||||
- "lint": LintCommand,
|
||||
})
|
||||
|
||||
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,5 +1,5 @@
|
||||
# From https://downloads.apache.org/avro/avro-1.10.0/py3/avro-python3-1.10.0.tar.gz.sha512
|
||||
sha512 fb41f9227d2410c29cde10d7573aebbc142c2bf3f5945a1aaffdeac8b4b5ec690b0befdfc813a8762289dbbb7fc4e1be1564ba0c69d03092b84d8e938d6156f6 avro-python3-1.10.0.tar.gz
|
||||
# From https://downloads.apache.org/avro/avro-1.11.0/py/avro-1.11.0.tar.gz.sha512
|
||||
sha512 8af67deb33b9990b74ffd7ab5c3c55e13a649070b4623c7bbe2b278287fd0929e57ed6d0344f9e93f3eb79663b43f75891d0810812349dfaecce65fdd9b44e93 avro-1.11.0.tar.gz
|
||||
|
||||
# License files
|
||||
sha256 c79a7fea0e3cac04cd43f20e7b648e5a0ff8fa5344e644b0ee09ca1162b62747 avro/LICENSE
|
||||
|
@ -5,8 +5,9 @@
|
||||
################################################################################
|
||||
|
||||
PYTHON_AVRO_VERSION = $(AVRO_C_VERSION)
|
||||
PYTHON_AVRO_SITE = https://www-eu.apache.org/dist/avro/avro-$(PYTHON_AVRO_VERSION)/py3
|
||||
PYTHON_AVRO_SOURCE = avro-python3-$(PYTHON_AVRO_VERSION).tar.gz
|
||||
PYTHON_AVRO_SITE = \
|
||||
https://www-eu.apache.org/dist/avro/avro-$(PYTHON_AVRO_VERSION)/py
|
||||
PYTHON_AVRO_SOURCE = avro-$(PYTHON_AVRO_VERSION).tar.gz
|
||||
PYTHON_AVRO_LICENSE = Apache-2.0
|
||||
PYTHON_AVRO_LICENSE_FILES = avro/LICENSE
|
||||
PYTHON_AVRO_SETUP_TYPE = setuptools
|
||||
|
Loading…
Reference in New Issue
Block a user