more updates for python

This commit is contained in:
Mike Frysinger 2004-10-12 00:06:48 +00:00
parent 663a55ca28
commit 4e809df67f
4 changed files with 60 additions and 3 deletions

View File

@ -97,9 +97,9 @@
# Ensure that /usr/local is always used
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+ add_dir_to_list(self.compiler.library_dirs, os.getenv('DESTDIR') + '/lib')
+ add_dir_to_list(self.compiler.library_dirs, os.getenv('DESTDIR') + '/usr/lib')
+ add_dir_to_list(self.compiler.include_dirs, os.getenv('DESTDIR') + '/usr/include')
+ #add_dir_to_list(self.compiler.library_dirs, os.getenv('DESTDIR') + '/lib')
+ #add_dir_to_list(self.compiler.library_dirs, os.getenv('DESTDIR') + '/usr/lib')
+ #add_dir_to_list(self.compiler.include_dirs, os.getenv('DESTDIR') + '/usr/include')
# fink installs lots of goodies in /sw/... - make sure we
# check there

View File

@ -0,0 +1,36 @@
--- python.old/setup.py 2003-11-01 19:23:48.495647848 +0000
+++ python/setup.py 2003-11-01 19:24:16.044459792 +0000
@@ -15,7 +15,14 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+try:
+ disabled_module_list = os.environ["PYTHON_DISABLE_MODULES"].split()
+except KeyError:
+ disabled_module_list = []
+try:
+ disable_ssl = os.environ["PYTHON_DISABLE_SSL"]
+except KeyError:
+ disable_ssl = 0
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -240,6 +247,7 @@
return sys.platform
def detect_modules(self):
+ global disable_ssl
# Ensure that /usr/local is always used
add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
@@ -451,7 +459,8 @@
] )
if (ssl_incs is not None and
- ssl_libs is not None):
+ ssl_libs is not None and
+ not disable_ssl):
exts.append( Extension('_ssl', ['_ssl.c'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,

View File

@ -0,0 +1,17 @@
--- Python-2.3.2/Python/import.c 2003-10-08 12:29:03.166032656 +0100
+++ import.c 2003-10-08 12:32:57.423420120 +0100
@@ -808,8 +808,12 @@
write_compiled_module(PyCodeObject *co, char *cpathname, long mtime)
{
FILE *fp;
-
- fp = open_exclusive(cpathname);
+ char *py_dontcompile = getenv("PYTHON_DONTCOMPILE");
+
+ if (!py_dontcompile)
+ fp = open_exclusive(cpathname);
+ else
+ fp = NULL;
if (fp == NULL) {
if (Py_VerboseFlag)
PySys_WriteStderr(

View File

@ -53,13 +53,17 @@ $(PYTHON_DIR)/.configured: $(PYTHON_DIR)/.hostpython
touch $(PYTHON_DIR)/.configured
$(PYTHON_DIR)/$(PYTHON_BINARY): $(PYTHON_DIR)/.configured
export PYTHON_DISABLE_SSL=1
$(MAKE) CC=$(TARGET_CC) -C $(PYTHON_DIR) DESTDIR=$(TARGET_DIR) \
PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter" \
HOSTPYTHON=./hostpython HOSTPGEN=./Parser/hostpgen
$(TARGET_DIR)/$(PYTHON_TARGET_BINARY): $(PYTHON_DIR)/$(PYTHON_BINARY)
export PYTHON_DISABLE_SSL=1
LD_LIBRARY_PATH=$(STAGING_DIR)/lib
$(MAKE) CC=$(TARGET_CC) -C $(PYTHON_DIR) install \
DESTDIR=$(TARGET_DIR) CROSS_COMPILE=yes \
PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter" \
HOSTPYTHON=./hostpython HOSTPGEN=./Parser/hostpgen
rm $(TARGET_DIR)/usr/bin/python?.?
rm $(TARGET_DIR)/usr/bin/idle