package/bdwgc: bump to version 8.0.0
- Remove first patch (already in version):7c13fb8fcc
- Remove second patch (already in version) - Update license hash: Update header copyright (add Ivan Maidanski), see3bd265a64b
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
a6479d6058
commit
4e1dbd063d
@ -1,28 +0,0 @@
|
||||
configure.ac: add check for NO_GETCONTEXT definition
|
||||
|
||||
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
||||
[yann.morin.1998@free.fr: add a comment, change variable name, use
|
||||
AS_IF, remove debug traces, use AC_CHECK_FUNCS (as suggested by
|
||||
Thomas)]
|
||||
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
||||
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
---
|
||||
configure.ac | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
--- bdwgc-7.2f.orig/configure.ac 2014-06-01 19:00:47.000000000 +0200
|
||||
+++ bdwgc-7.2f/configure.ac 2014-12-23 14:13:11.585716713 +0100
|
||||
@@ -365,6 +365,12 @@
|
||||
AC_MSG_RESULT($ac_cv_fno_strict_aliasing)
|
||||
fi
|
||||
|
||||
+# Check for getcontext (uClibc can be configured without it, for example)
|
||||
+AC_CHECK_FUNCS([getcontext])
|
||||
+AS_IF([test "$ac_cv_func_getcontext" = "no"],
|
||||
+ [CFLAGS="$CFLAGS -DNO_GETCONTEXT"
|
||||
+ CPPFLAGS="$CPPFLAGS -DNO_GETCONTEXT"])
|
||||
+
|
||||
case "$host" in
|
||||
# While IRIX 6 has libdl for the O32 and N32 ABIs, it's missing for N64
|
||||
# and unnecessary everywhere.
|
@ -1,35 +0,0 @@
|
||||
From 31eef02317d59b4d204624efbddaea641e861390 Mon Sep 17 00:00:00 2001
|
||||
From: Mikael Djurfeldt <mikael@djurfeldt.com>
|
||||
Date: Sun, 26 Feb 2017 20:09:56 +0100
|
||||
Subject: [PATCH] Fix 'size of tv is unknown' error in
|
||||
brief_async_signal_safe_sleep (musl) (fix commits 62097c3, 9f48082)
|
||||
|
||||
Include <sys/time.h> to get struct timeval defined and select() declared.
|
||||
|
||||
* pthread_stop_world.c [GC_ENABLE_SUSPEND_THREAD]: Include sys/time.h
|
||||
before GC_brief_async_signal_safe_sleep definition.
|
||||
|
||||
Upstream status: upstream
|
||||
commit ffad61d3bbe86c09ffe062dab393fcb0e4940580
|
||||
|
||||
[Romain: backported to 7.6.0]
|
||||
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
||||
---
|
||||
pthread_stop_world.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/pthread_stop_world.c b/pthread_stop_world.c
|
||||
index dad1fdc..8c76944 100644
|
||||
--- a/pthread_stop_world.c
|
||||
+++ b/pthread_stop_world.c
|
||||
@@ -391,6 +391,7 @@ STATIC void GC_restart_handler(int sig)
|
||||
# ifndef GC_TIME_LIMIT
|
||||
# define GC_TIME_LIMIT 50
|
||||
# endif
|
||||
+# include <sys/time.h>
|
||||
|
||||
STATIC void GC_brief_async_signal_safe_sleep(void)
|
||||
{
|
||||
--
|
||||
2.9.4
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 bd112005563d787675163b5afff02c364fc8deb13a99c03f4e80fdf6608ad41e gc-7.6.2.tar.gz
|
||||
sha256 9944acfcee6cca308d974933977c1608804f5ad4345aac7cb8608137104e3742 README.QUICK
|
||||
sha256 8f23f9a20883d00af2bff122249807e645bdf386de0de8cbd6cce3e0c6968f04 gc-8.0.0.tar.gz
|
||||
sha256 aeeaabbf44e67d413e18719f0c6ac9c23387ab0b33e7a15ee46cf59ddef12cc7 README.QUICK
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
BDWGC_VERSION = 7.6.2
|
||||
BDWGC_VERSION = 8.0.0
|
||||
BDWGC_SOURCE = gc-$(BDWGC_VERSION).tar.gz
|
||||
BDWGC_SITE = http://www.hboehm.info/gc/gc_source
|
||||
BDWGC_INSTALL_STAGING = YES
|
||||
|
Loading…
Reference in New Issue
Block a user