evemu: disable tests via evemu configure option
Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
ddcaa1c2ef
commit
4d96a06164
@ -0,0 +1,44 @@
|
||||
From 077722193e4e59e76591abbaddac9d22068be4e6 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Sun, 27 Apr 2014 13:14:51 +0200
|
||||
Subject: [PATCH] configure.ac: add '--disable-tests' option
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
configure.ac | 9 +++++++++
|
||||
2 files changed, 10 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 7b68f3d..a83b35f 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = src tools python test
|
||||
+SUBDIRS = src tools python $(SUBDIR_TESTS)
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = evemu.pc
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ec21a6e..4e0c3b8 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -43,6 +43,15 @@ if test "x$XMLTO" = "x" || test "x$ASCIIDOC" = "x"; then
|
||||
AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
|
||||
fi
|
||||
|
||||
+AC_ARG_ENABLE([tests],
|
||||
+ AS_HELP_STRING([--disable-tests], [Disable running tests]))
|
||||
+
|
||||
+AS_IF([test "x$enable_tests" != "xno"], [
|
||||
+ SUBDIR_TESTS=test
|
||||
+])
|
||||
+
|
||||
+AC_SUBST([SUBDIR_TESTS])
|
||||
+
|
||||
AC_SUBST(AM_CFLAGS,
|
||||
"-Wall -Wextra -pedantic")
|
||||
|
||||
--
|
||||
1.8.1.4
|
||||
|
@ -1,19 +0,0 @@
|
||||
[PATCH] disable tests
|
||||
|
||||
The tests need C++ support and add to build time, so disable them for BR.
|
||||
|
||||
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
|
||||
---
|
||||
Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
Index: evemu-1.2.0/Makefile.am
|
||||
===================================================================
|
||||
--- evemu-1.2.0.orig/Makefile.am
|
||||
+++ evemu-1.2.0/Makefile.am
|
||||
@@ -1,4 +1,4 @@
|
||||
-SUBDIRS = src tools python test
|
||||
+SUBDIRS = src tools python
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = evemu.pc
|
@ -18,6 +18,9 @@ EVEMU_CONF_ENV = ac_cv_path_ASCIIDOC=""
|
||||
# of host system version)
|
||||
EVEMU_MAKE_ENV = SYSROOT=$(STAGING_DIR)
|
||||
|
||||
# disable tests generation because of C++ dependency
|
||||
EVEMU_CONF_OPT += --disable-tests
|
||||
|
||||
# Uses PKG_CHECK_MODULES() in configure.ac
|
||||
EVEMU_DEPENDENCIES = host-pkgconf libevdev
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user