package/libhdhomerun: new package
Needed for new kodi-pvr-hdhomerun package. [Thomas: use TARGET_MAKE_ENV, other minor tweaks.] Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
067a65755b
commit
4cb010a5f1
@ -983,6 +983,7 @@ menu "Multimedia"
|
||||
source "package/libfslcodec/Config.in"
|
||||
source "package/libfslparser/Config.in"
|
||||
source "package/libfslvpuwrap/Config.in"
|
||||
source "package/libhdhomerun/Config.in"
|
||||
source "package/libmatroska/Config.in"
|
||||
source "package/libmms/Config.in"
|
||||
source "package/libmpeg2/Config.in"
|
||||
|
18
package/libhdhomerun/0001-dont-strip.patch
Normal file
18
package/libhdhomerun/0001-dont-strip.patch
Normal file
@ -0,0 +1,18 @@
|
||||
Disable strip in Makefile.
|
||||
|
||||
Patch downloaded from Gentoo:
|
||||
https://gitweb.gentoo.org/repo/gentoo.git/tree/media-libs/libhdhomerun/files/dont-strip.patch
|
||||
|
||||
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
||||
|
||||
diff -Nur libhdhomerun/Makefile libhdhomerun.fix/Makefile
|
||||
--- libhdhomerun/Makefile 2012-08-30 15:46:27.000000000 -0500
|
||||
+++ libhdhomerun.fix/Makefile 2013-03-24 14:47:08.740937164 -0500
|
||||
@@ -42,7 +42,6 @@
|
||||
|
||||
hdhomerun_config$(BINEXT) : hdhomerun_config.c $(LIBSRCS)
|
||||
$(CC) $(CFLAGS) $+ $(LDFLAGS) -o $@
|
||||
- $(STRIP) $@
|
||||
|
||||
libhdhomerun$(LIBEXT) : $(LIBSRCS)
|
||||
$(CC) $(CFLAGS) -fPIC -DDLL_EXPORT $(SHARED) $+ $(LDFLAGS) -o $@
|
12
package/libhdhomerun/Config.in
Normal file
12
package/libhdhomerun/Config.in
Normal file
@ -0,0 +1,12 @@
|
||||
config BR2_PACKAGE_LIBHDHOMERUN
|
||||
bool "libhdhomerun"
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||
depends on !BR2_STATIC_LIBS
|
||||
help
|
||||
HDHomeRun is a network-attached digital television tuner
|
||||
box, produced by the company SiliconDust USA, Inc.
|
||||
|
||||
http://www.silicondust.com
|
||||
|
||||
comment "libhdhomerun needs a toolchain w/ threads, dynamic library"
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_STATIC_LIBS
|
2
package/libhdhomerun/libhdhomerun.hash
Normal file
2
package/libhdhomerun/libhdhomerun.hash
Normal file
@ -0,0 +1,2 @@
|
||||
# Locally computed
|
||||
sha256 907dfbd1eb82aebd8b09e7c00c21a02433e6baaacf4a4f99aa2511b1d5244baf libhdhomerun_20150826.tgz
|
31
package/libhdhomerun/libhdhomerun.mk
Normal file
31
package/libhdhomerun/libhdhomerun.mk
Normal file
@ -0,0 +1,31 @@
|
||||
################################################################################
|
||||
#
|
||||
# libhdhomerun
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBHDHOMERUN_VERSION = 20150826
|
||||
LIBHDHOMERUN_SOURCE = libhdhomerun_$(LIBHDHOMERUN_VERSION).tgz
|
||||
LIBHDHOMERUN_SITE = http://download.silicondust.com/hdhomerun
|
||||
LIBHDHOMERUN_LICENSE = LGPLv2.1+
|
||||
LIBHDHOMERUN_LICENSE_FILES = lgpl.txt
|
||||
LIBHDHOMERUN_INSTALL_STAGING = YES
|
||||
|
||||
define LIBHDHOMERUN_BUILD_CMDS
|
||||
$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D)
|
||||
endef
|
||||
|
||||
define LIBHDHOMERUN_INSTALL_STAGING_CMDS
|
||||
$(INSTALL) -D -m 0755 $(@D)/libhdhomerun.so \
|
||||
$(STAGING_DIR)/usr/lib/libhdhomerun.so
|
||||
$(INSTALL) -m 0644 $(@D)/*.h \
|
||||
$(STAGING_DIR)/usr/include/
|
||||
endef
|
||||
|
||||
define LIBHDHOMERUN_INSTALL_TARGET_CMDS
|
||||
$(INSTALL) -D -m 0755 $(@D)/libhdhomerun.so \
|
||||
$(TARGET_DIR)/usr/lib/libhdhomerun.so
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user