package/libpciaccess: bump version to 0.18.1
Removed patch which is included in upstream release. Release notes: https://lists.x.org/archives/xorg-announce/2024-March/003483.html Signed-off-by: Bernd Kuhls <bernd@kuhls.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
6d5ce8609f
commit
4c4bb101ba
@ -1,48 +0,0 @@
|
||||
From ad7e9cb4b291a46812eea321f0634cfc46fb94e2 Mon Sep 17 00:00:00 2001
|
||||
From: Alan Coopersmith <alan.coopersmith@oracle.com>
|
||||
Date: Thu, 14 Mar 2024 13:55:55 -0700
|
||||
Subject: [PATCH] meson: allow building static library, not just shared
|
||||
|
||||
Lets builders specify -Ddefault_library={shared,static,both}
|
||||
to control which types of libpciaccess library are built
|
||||
|
||||
Closes: #20
|
||||
Reported-by: Maxime Gauduin (@alucryd)
|
||||
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
|
||||
|
||||
Upstream: https://gitlab.freedesktop.org/xorg/lib/libpciaccess/-/commit/ad7e9cb4b291a46812eea321f0634cfc46fb94e2
|
||||
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
||||
---
|
||||
.gitlab-ci.yml | 2 +-
|
||||
src/meson.build | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
|
||||
index bcb75cf..185edc2 100644
|
||||
--- a/.gitlab-ci.yml
|
||||
+++ b/.gitlab-ci.yml
|
||||
@@ -91,7 +91,7 @@ meson:
|
||||
- MESON_OPTIONS: ['-Dzlib=disabled', '-Dzlib=enabled']
|
||||
script:
|
||||
- mkdir -p ../_inst
|
||||
- - meson setup builddir --prefix="$PWD/../_inst" -Dwarning_level=3 $MESON_OPTIONS
|
||||
+ - meson setup builddir --prefix="$PWD/../_inst" -Dwarning_level=3 -Ddefault_library=both $MESON_OPTIONS
|
||||
- meson configure builddir
|
||||
- ninja -C builddir test
|
||||
- ninja -C builddir install
|
||||
diff --git a/src/meson.build b/src/meson.build
|
||||
index 24eee04..e319688 100644
|
||||
--- a/src/meson.build
|
||||
+++ b/src/meson.build
|
||||
@@ -38,7 +38,7 @@ endif
|
||||
|
||||
inc_src = include_directories('.')
|
||||
|
||||
-libpciaccess = shared_library(
|
||||
+libpciaccess = library(
|
||||
'pciaccess',
|
||||
[
|
||||
'common_bridge.c',
|
||||
--
|
||||
GitLab
|
||||
|
@ -1,4 +1,4 @@
|
||||
# From https://lists.x.org/archives/xorg-announce/2024-February/003453.html
|
||||
sha512 54dff9a493344586d072edf8c8eb8f7960c7dfd64aa5c51a8ec8d4e341f703fd39eb606ee41c4fdd9d5aad3372b7efe6e0fe96eadc575ea91de276320ebc3fbd libpciaccess-0.18.tar.xz
|
||||
# From https://lists.x.org/archives/xorg-announce/2024-March/003483.html
|
||||
sha512 ef27999446e735df2331e94219ee3dafe9198a2472bb452f63ef9c9c446d5431f9e231e224cfabdeba1402974a5a0064546f9abced4d1770f994f5fc0c2b3310 libpciaccess-0.18.1.tar.xz
|
||||
# Hash for license file:
|
||||
sha256 f33f360f8905940dac01aa21597fe8a6727ca6f4ffa43b380e2116fd0666aa8a COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
LIBPCIACCESS_VERSION = 0.18
|
||||
LIBPCIACCESS_VERSION = 0.18.1
|
||||
LIBPCIACCESS_SOURCE = libpciaccess-$(LIBPCIACCESS_VERSION).tar.xz
|
||||
LIBPCIACCESS_SITE = http://xorg.freedesktop.org/releases/individual/lib
|
||||
LIBPCIACCESS_LICENSE = MIT
|
||||
|
Loading…
Reference in New Issue
Block a user