package/mpd: update to version 0.23.7
Minor bug fixes, including upstream fix for meson iconv handling, which makes
0002-src-lib-icu-fix-iconv-detection-when-libiconv-is-ins.patch redundant.
Introduces version dependencies for libshout and libupnp, which are met since
01/2021 (commit 118648d161
).
Full change log:
https://raw.githubusercontent.com/MusicPlayerDaemon/MPD/v0.23.7/NEWS
Signed-off-by: Andreas Ziegler <br015@umbiko.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
parent
8866d747cd
commit
4c22b1650d
@ -1,53 +0,0 @@
|
||||
From 3882a5a263caa681778a21b1f5f13a1b64536796 Mon Sep 17 00:00:00 2001
|
||||
From: aeolio <git@aeolio.de>
|
||||
Date: Wed, 20 Apr 2022 16:10:39 +0200
|
||||
Subject: [PATCH] src/lib/icu: fix iconv() detection when libiconv is installed
|
||||
|
||||
Signed-off-by: aeolio <git@aeolio.de>
|
||||
Upstream: https://github.com/MusicPlayerDaemon/MPD/pull/1515
|
||||
Signed-off-by: Andreas Ziegler <br015@umbiko.net>
|
||||
---
|
||||
src/lib/icu/meson.build | 11 +++++++++--
|
||||
1 file changed, 9 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/lib/icu/meson.build b/src/lib/icu/meson.build
|
||||
index 59215e704..972c1fda3 100644
|
||||
--- a/src/lib/icu/meson.build
|
||||
+++ b/src/lib/icu/meson.build
|
||||
@@ -12,17 +12,23 @@ if is_windows
|
||||
icu_sources += 'Win32.cxx'
|
||||
endif
|
||||
|
||||
+iconv_dep = []
|
||||
if icu_dep.found()
|
||||
icu_sources += [
|
||||
'Util.cxx',
|
||||
'Init.cxx',
|
||||
]
|
||||
elif not get_option('iconv').disabled()
|
||||
- have_iconv = compiler.has_function('iconv', prefix : '#include <iconv.h>')
|
||||
- conf.set('HAVE_ICONV', have_iconv)
|
||||
+ # an installed iconv library will make the builtin iconv() unavailable,
|
||||
+ # so search for the library first and pass it as (possible) dependency
|
||||
+ iconv_dep = compiler.find_library('libiconv', required: false)
|
||||
+ have_iconv = compiler.has_function('iconv',
|
||||
+ dependencies: iconv_dep,
|
||||
+ prefix : '#include <iconv.h>')
|
||||
if not have_iconv and get_option('iconv').enabled()
|
||||
error('iconv() not available')
|
||||
endif
|
||||
+ conf.set('HAVE_ICONV', have_iconv)
|
||||
endif
|
||||
|
||||
icu = static_library(
|
||||
@@ -31,6 +37,7 @@ icu = static_library(
|
||||
include_directories: inc,
|
||||
dependencies: [
|
||||
icu_dep,
|
||||
+ iconv_dep,
|
||||
fmt_dep,
|
||||
],
|
||||
)
|
||||
--
|
||||
2.34.1
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Locally calculated after checking pgp signature
|
||||
sha256 cbc5928ee3ee1ef7ff6a58f6ba4afaee16c07e9eb42d0107bcc098010f4f26ed mpd-0.23.6.tar.xz
|
||||
sha256 960dcbac717c388f5dcc4fd945e3af19a476f2b15f367e9653d4c7a948768211 mpd-0.23.7.tar.xz
|
||||
sha256 ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6 COPYING
|
||||
|
@ -5,7 +5,7 @@
|
||||
################################################################################
|
||||
|
||||
MPD_VERSION_MAJOR = 0.23
|
||||
MPD_VERSION = $(MPD_VERSION_MAJOR).6
|
||||
MPD_VERSION = $(MPD_VERSION_MAJOR).7
|
||||
MPD_SOURCE = mpd-$(MPD_VERSION).tar.xz
|
||||
MPD_SITE = https://www.musicpd.org/download/mpd/$(MPD_VERSION_MAJOR)
|
||||
MPD_DEPENDENCIES = host-pkgconf boost fmt
|
||||
|
Loading…
Reference in New Issue
Block a user