package/libqmi: bump version to 1.30.4

Remove 0001-build-add-an-option-to-not-build-man-pages.patch
as release contains very similar commit which does autodetection:
1a474db ("build: add an option to not build man pages")

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Petr Vorel 2022-02-21 20:21:26 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 27cd0b5033
commit 4c17e3e4b9
3 changed files with 2 additions and 67 deletions

View File

@ -1,65 +0,0 @@
From 295b75e9c8dc895e281e36b1e8121d09fd556af0 Mon Sep 17 00:00:00 2001
From: Aleksander Morgado <aleksander@aleksander.es>
Date: Wed, 3 Nov 2021 10:57:51 +0100
Subject: [PATCH] build: add an option to not build man pages
When cross-compiling, the compiled binaries cannot be run on the build
machine, unless one defines a helper (e.g. qemu) in the meson
configuration, which is most of the time undesirable.
If help2man is installed on the build machine, then the build would fail
because of this, so add an option to disable generating the man pages.
With later versions of meson, it will be possible to automatically
detect this condition.
Based on the same fix done in libmbim by Nicolas Cavallari, see
https://gitlab.freedesktop.org/mobile-broadband/libmbim/-/commit/792af73ea90e9689703ab526dd444fdb1c2f8e40
Fixes https://gitlab.freedesktop.org/mobile-broadband/libqmi/-/issues/75
[Retrieved (and backported) from:
https://gitlab.freedesktop.org/mobile-broadband/libqmi/-/commit/295b75e9c8dc895e281e36b1e8121d09fd556af0]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
meson.build | 8 +++++++-
meson_options.txt | 1 +
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index e88b43a1..c7312146 100644
--- a/meson.build
+++ b/meson.build
@@ -223,8 +223,8 @@ if enable_gtk_doc
subdir('docs/reference/libqmi-glib')
endif
-help2man = find_program('help2man', required: false)
-if help2man.found()
+enable_man = get_option('man')
+if enable_man
subdir('docs/man')
endif
@@ -237,6 +242,7 @@ summary({
output += ' Documentation: ' + enable_gtk_doc.to_string() + '\n'
output += ' bash completion: ' + enable_bash_completion.to_string() + '\n'
output += ' gobject introspection: ' + enable_gir.to_string() + '\n\n'
+output += ' man pages: ' + enable_man.to_string() + '\n\n'
output += ' System paths\n'
output += ' prefix: ' + qmi_prefix + '\n'
output += ' udev base directory: ' + qmi_username + '\n\n'
diff --git a/meson_options.txt b/meson_options.txt
index 4d4f913d..bee5daac 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -16,5 +16,6 @@ option('udevdir', type: 'string', value: '', description: 'where udev base direc
option('introspection', type: 'boolean', value: 'auto', description: 'build introspection support')
option('gtk_doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
+option('man', type: 'boolean', value: 'true', description: 'build man pages using help2man')
option('bash_completion', type: 'boolean', value: true, description: 'install bash completion files')
--
GitLab

View File

@ -1,4 +1,4 @@
# Locally computed:
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING.LIB
sha256 2eb7c7971b91a64ad830643b0170cff692a69bf0f093ca61d72d3f466a0272d4 libqmi-1.30.2.tar.gz
sha256 82ddd3f77c602b1e0c11d3e41d0563ede11f95036ebfcf929bc89157b13928e6 libqmi-1.30.4.tar.gz

View File

@ -4,7 +4,7 @@
#
################################################################################
LIBQMI_VERSION = 1.30.2
LIBQMI_VERSION = 1.30.4
LIBQMI_SITE = https://gitlab.freedesktop.org/mobile-broadband/libqmi/-/archive/$(LIBQMI_VERSION)
LIBQMI_LICENSE = LGPL-2.0+ (library), GPL-2.0+ (programs)
LIBQMI_LICENSE_FILES = COPYING COPYING.LIB