package/socat: bump to version 1.7.4.3

Update README hash for version number change.

Add a patch fixing build with musl.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Baruch Siach 2022-01-13 18:36:58 +02:00 committed by Yann E. MORIN
parent 7996a1a18b
commit 4b7ea7a67a
3 changed files with 47 additions and 4 deletions

View File

@ -0,0 +1,43 @@
From d56a11beb9b181fd91a70a6d703dfbdfe887122a Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Thu, 13 Jan 2022 17:56:10 +0200
Subject: [PATCH] configure.ac: correct the getprotobynumber_r test
The AC_TRY_COMPILE test succeeds even when libc does not provide the
tested symbol. The compiler produces a warning, but exits successfully.
Use AC_TRY_LINK that will only succeeds if libc provides the symbol.
This fixes build with musl libc that does not support
getprotobynumber_r().
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
Upstream status: sent to socat@dest-unreach.org
configure.ac | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index d4acc9e7e6f5..973a7f2218c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,13 +137,13 @@ AC_MSG_RESULT($sc_cv_have_prototype_hstrerror)
# getprotobynumber_r() is not standardized
AC_MSG_CHECKING(for getprotobynumber_r() variant)
AC_CACHE_VAL(sc_cv_getprotobynumber_r,
-[AC_TRY_COMPILE([#include <stddef.h>
+[AC_TRY_LINK([#include <stddef.h>
#include <netdb.h>],[getprotobynumber_r(1,NULL,NULL,1024,NULL);],
[sc_cv_getprotobynumber_r=1; tmp_bynum_variant=Linux],
- [AC_TRY_COMPILE([#include <stddef.h>
+ [AC_TRY_LINK([#include <stddef.h>
#include <netdb.h>],[getprotobynumber_r(1,NULL,NULL,1024);],
[sc_cv_getprotobynumber_r=2; tmp_bynum_variant=Solaris],
- [AC_TRY_COMPILE([#include <stddef.h>
+ [AC_TRY_LINK([#include <stddef.h>
#include <netdb.h>],[getprotobynumber_r(1,NULL,NULL);],
[sc_cv_getprotobynumber_r=3; tmp_bynum_variant=AIX],
--
2.34.1

View File

@ -1,8 +1,8 @@
# From http://www.dest-unreach.org/socat/download.md5sum
md5 003686f80d820072649660b85f80c58f socat-1.7.4.2.tar.bz2
md5 5c28dd258ba928326d0716fcb4895cc2 socat-1.7.4.3.tar.bz2
# From http://www.dest-unreach.org/socat/download.sha256sum
sha256 6690a9f9990457b505097a272bbf2cbf4cc35576176f76646e3524b0e91c1763 socat-1.7.4.2.tar.bz2
sha256 d47318104415077635119dfee44bcfb41de3497374a9a001b1aff6e2f0858007 socat-1.7.4.3.tar.bz2
# Locally calculated
sha256 062e425b43da6b3df6d8657639b5e2c781781572b5d8867444fd6d2487ac7644 README
sha256 432aebfec164bedcaada7cdf2849e1f003fa00a91a0a1ed34d7cf4abe980f5fb README
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 fd9e48ca316a5032069b9521f4f4b4d9b1c60365012bae1e62286bcd5bd2e761 COPYING.OpenSSL

View File

@ -4,7 +4,7 @@
#
################################################################################
SOCAT_VERSION = 1.7.4.2
SOCAT_VERSION = 1.7.4.3
SOCAT_SOURCE = socat-$(SOCAT_VERSION).tar.bz2
SOCAT_SITE = http://www.dest-unreach.org/socat/download
SOCAT_LICENSE = GPL-2.0 with OpenSSL exception