package/attr: fix build failure on Microblaze architecture

On Microblaze architecture __has_attribute(__symver__) support is broken
and always return true even if symver is not supported so let's add an
upstream patch to detect if symver is supported during autoreconf. Let's
also add ATTR_AUTORECONF = YES to let patch to affect building.

Fixes:
http://autobuild.buildroot.org/results/29c76e02becedf922bd7dc0533338c078bf77d2a

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Giulio Benetti 2024-02-18 09:20:12 +01:00 committed by Yann E. MORIN
parent 2c6dc1fed3
commit 4b34b8ccfa
2 changed files with 78 additions and 0 deletions

View File

@ -0,0 +1,75 @@
From 365426c28f8bf73d34d77cc06b7d5ffeae17f13a Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Date: Tue, 6 Feb 2024 15:33:15 +0100
Subject: [PATCH] configure.ac: add detection of symver gcc attribute
On non-ELF platforms, such as microblaze, builds will fail when trying
to add symver information because __attribute__((symver ..)) is not
supported even though __has_attribute(__symver__) returns true.
Support for symver needs to be detected via a compile test since
__has_attribute can report false positives [0].
Add a configure compile check for __attribute__((symver ..)) to ensure
it is supported and define a variable to advertise support.
[0] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101766#c1
Upstream: https://git.savannah.nongnu.org/cgit/attr.git/commit/?id=943c776089dbb24ebbfb7432ba9841f1845bf95a
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[Giulio: rework local patch for #if nesting]
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
configure.ac | 15 +++++++++++++++
libattr/syscalls.c | 8 ++++----
2 files changed, 19 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index 7e362e9..98477b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,21 @@ AS_CASE([$host_os],
[linux*], [os_linux=yes])
AM_CONDITIONAL([OS_LINUX], [test "x$os_linux" = "xyes"])
+AC_CACHE_CHECK(whether __attribute__((__symver__())) is supported,
+ gcc_cv_symver_attribute,
+ [cat > conftest.c <<EOF
+void foo (void) {}
+__typeof(foo) foo __attribute__ ((__symver__("foo@foo")));
+EOF
+ gcc_cv_symver_attribute=no
+ if ${CC-cc} -Werror -S conftest.c -o conftest.s >/dev/null 2>&1; then \
+ gcc_cv_symver_attribute=yes
+ fi
+ rm -f conftest.[cs]
+])
+AS_IF([test $gcc_cv_symver_attribute = yes],
+ [AC_DEFINE(HAVE_SYMVER_ATTRIBUTE, [], [GCC supports symver attribute])])
+
AC_CONFIG_COMMANDS([include/attr],
[dnl
rm -rf include/attr
diff --git a/libattr/syscalls.c b/libattr/syscalls.c
index 907560a..7ee6d39 100644
--- a/libattr/syscalls.c
+++ b/libattr/syscalls.c
@@ -31,10 +31,10 @@
* prefer symver attribute if available (since gcc 10),
* fall back to traditional .symver asm directive otherwise.
*/
-#ifdef __has_attribute
-# if __has_attribute(__symver__)
-# define SYMVER(cn, vn) __typeof(cn) cn __attribute__((__symver__(vn)))
-# elif __has_attribute(__no_reorder__)
+#if defined(HAVE_SYMVER_ATTRIBUTE)
+# define SYMVER(cn, vn) __typeof(cn) cn __attribute__((__symver__(vn)))
+#elif defined(__has_attribute)
+# if __has_attribute(__no_reorder__)
/*
* Avoid wrong partitioning with older gcc and LTO. May not work reliably
* with all versions; use -flto-partition=none if you encounter problems.
--
2.34.1

View File

@ -11,6 +11,9 @@ ATTR_LICENSE = GPL-2.0+ (programs), LGPL-2.1+ (libraries)
ATTR_LICENSE_FILES = doc/COPYING doc/COPYING.LGPL
ATTR_CPE_ID_VALID = YES
# Flag added for patch dealing with symver in configure.ac
ATTR_AUTORECONF = YES
ATTR_INSTALL_STAGING = YES
ATTR_CONF_OPTS = --disable-nls