zlog: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
cec43a8f25
commit
4a9e8a8db1
@ -800,6 +800,7 @@ source "package/protobuf-c/Config.in"
|
||||
source "package/schifra/Config.in"
|
||||
source "package/startup-notification/Config.in"
|
||||
source "package/tzdata/Config.in"
|
||||
source "package/zlog/Config.in"
|
||||
endmenu
|
||||
|
||||
menu "Security"
|
||||
|
13
package/zlog/Config.in
Normal file
13
package/zlog/Config.in
Normal file
@ -0,0 +1,13 @@
|
||||
config BR2_PACKAGE_ZLOG
|
||||
bool "zlog"
|
||||
depends on BR2_LARGEFILE
|
||||
depends on BR2_TOOLCHAIN_HAS_THREADS
|
||||
depends on !BR2_PREFER_STATIC_LIB
|
||||
help
|
||||
zlog is a reliable, high-performance, thread safe, flexible,
|
||||
clear-model, pure C logging library.
|
||||
|
||||
https://github.com/HardySimpson/zlog
|
||||
|
||||
comment "zlog needs a toolchain w/ threads, largefile, dynamic library"
|
||||
depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_LARGEFILE || BR2_PREFER_STATIC_LIB
|
32
package/zlog/zlog-01-fix-compiling-on-Buildroot.patch
Normal file
32
package/zlog/zlog-01-fix-compiling-on-Buildroot.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From a9f6a55bdb29a2bebc96a68ab53077906c25a9df Mon Sep 17 00:00:00 2001
|
||||
From: Yegor Yefremov <yegorslists@googlemail.com>
|
||||
Date: Wed, 22 Jan 2014 15:04:42 +0100
|
||||
Subject: [PATCH] Fix compiling on Buildroot
|
||||
|
||||
Buildroot always specifies -D_LARGEFILE_SOURCE, -D_LARGEFILE64_SOURCE,
|
||||
-D_FILE_OFFSET_BITS=64, so define them only if they are not already
|
||||
defined.
|
||||
|
||||
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
|
||||
---
|
||||
src/fmacros.h | 4 ++++
|
||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/src/fmacros.h b/src/fmacros.h
|
||||
index fa37948..059dfeb 100644
|
||||
--- a/src/fmacros.h
|
||||
+++ b/src/fmacros.h
|
||||
@@ -14,7 +14,11 @@
|
||||
#define _XOPEN_SOURCE
|
||||
#endif
|
||||
|
||||
+#ifndef _LARGEFILE_SOURCE
|
||||
#define _LARGEFILE_SOURCE
|
||||
+#endif
|
||||
+#ifndef _FILE_OFFSET_BITS
|
||||
#define _FILE_OFFSET_BITS 64
|
||||
+#endif
|
||||
|
||||
#endif
|
||||
--
|
||||
1.7.7
|
26
package/zlog/zlog.mk
Normal file
26
package/zlog/zlog.mk
Normal file
@ -0,0 +1,26 @@
|
||||
################################################################################
|
||||
#
|
||||
# zlog
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ZLOG_VERSION = ca6162be1608839e99c6388c28488c51ccf98e4a
|
||||
ZLOG_SITE = $(call github,HardySimpson,zlog,$(ZLOG_VERSION))
|
||||
ZLOG_LICENSE = LGPLv2.1
|
||||
ZLOG_LICENSE_FILES = COPYING
|
||||
ZLOG_INSTALL_STAGING = YES
|
||||
|
||||
define ZLOG_BUILD_CMDS
|
||||
$(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
|
||||
-C $(@D) all
|
||||
endef
|
||||
|
||||
define ZLOG_INSTALL_STAGING_CMDS
|
||||
$(MAKE) PREFIX=$(STAGING_DIR)/usr -C $(@D) install
|
||||
endef
|
||||
|
||||
define ZLOG_INSTALL_TARGET_CMDS
|
||||
$(MAKE) PREFIX=$(TARGET_DIR)/usr -C $(@D) install
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
Loading…
Reference in New Issue
Block a user