package/gupnp: bump to version 1.3.0

- Drop patch (already in version)
- Update license to LGPL-2.1+:
  37b22d0a05

https://gitlab.gnome.org/GNOME/gupnp/-/blob/gupnp-1.3.0/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2021-07-27 14:05:36 +02:00 committed by Thomas Petazzoni
parent 42b46562a2
commit 4a1cd7581a
3 changed files with 6 additions and 79 deletions

View File

@ -1,73 +0,0 @@
From 7ce37c94596029358a67d732a82e4313f7b89135 Mon Sep 17 00:00:00 2001
From: Jens Georg <mail@jensge.org>
Date: Sun, 30 May 2021 13:13:00 +0200
Subject: [PATCH] doc: Check for stylesheet existence on doc build
Checking for xsltproc is not enough
Fixes #17
[Retrieved from:
https://gitlab.gnome.org/GNOME/gupnp/-/commit/7ce37c94596029358a67d732a82e4313f7b89135]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
doc/meson.build | 34 +++++++++++++++++++++++++---------
1 file changed, 25 insertions(+), 9 deletions(-)
diff --git a/doc/meson.build b/doc/meson.build
index 26c32c9..eb69d07 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -30,6 +30,8 @@ endif
xsltproc = find_program('xsltproc', required: false)
if xsltproc.found()
+ stylesheet = 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl'
+
xlstproc_flags = [
'--nonet',
'--xinclude',
@@ -45,17 +47,31 @@ if xsltproc.found()
xsltproc,
xlstproc_flags,
'-o', '@OUTPUT@',
- 'http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl',
+ stylesheet,
'@INPUT@'
]
- custom_target(
- 'man 1 pages',
- input: 'gupnp-binding-tool.xml',
- output: 'gupnp-binding-tool-1.2.1',
- command: xsltproc_args,
- depend_files : version_xml,
- install: true,
- install_dir: join_paths(get_option('mandir'), 'man1')
+ stylesheet_check = run_command(
+ [
+ xsltproc,
+ xlstproc_flags,
+ '--noout',
+ stylesheet,
+ 'gupnp-binding-tool.xml'
+ ]
)
+ if (stylesheet_check.returncode() == 0)
+ message('Stylesheet ' + stylesheet + ' available')
+ custom_target(
+ 'man 1 pages',
+ input: 'gupnp-binding-tool.xml',
+ output: 'gupnp-binding-tool-1.2.1',
+ command: xsltproc_args,
+ depend_files : version_xml,
+ install: true,
+ install_dir: join_paths(get_option('mandir'), 'man1')
+ )
+ else
+ message('Stylesheet ' + stylesheet + ' not found, not building man page')
+ endif
endif
--
GitLab

View File

@ -1,5 +1,5 @@
# Hash from: http://ftp.gnome.org/pub/gnome/sources/gupnp/1.2/gupnp-1.2.6.sha256sum:
sha256 00b20f1e478a72deac92c34723693a2ac55789ed1e4bb4eed99eb4d62092aafd gupnp-1.2.6.tar.xz
# Hash from: http://ftp.gnome.org/pub/gnome/sources/gupnp/1.3/gupnp-1.3.0.sha256sum:
sha256 df8279293aae45ea6bb6de1b13bf1988285c8f2f4f25569fb0d79325a8471666 gupnp-1.3.0.tar.xz
# Hash for license file:
sha256 d245807f90032872d1438d741ed21e2490e1175dc8aa3afa5ddb6c8e529b58e5 COPYING
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 COPYING

View File

@ -4,11 +4,11 @@
#
################################################################################
GUPNP_VERSION_MAJOR = 1.2
GUPNP_VERSION = $(GUPNP_VERSION_MAJOR).6
GUPNP_VERSION_MAJOR = 1.3
GUPNP_VERSION = $(GUPNP_VERSION_MAJOR).0
GUPNP_SOURCE = gupnp-$(GUPNP_VERSION).tar.xz
GUPNP_SITE = http://ftp.gnome.org/pub/gnome/sources/gupnp/$(GUPNP_VERSION_MAJOR)
GUPNP_LICENSE = LGPL-2.0+
GUPNP_LICENSE = LGPL-2.1+
GUPNP_LICENSE_FILES = COPYING
GUPNP_INSTALL_STAGING = YES
GUPNP_DEPENDENCIES = host-pkgconf libglib2 libxml2 gssdp util-linux