package/python-pyzmq: bump to version 24.0.1

Migrate to setuptools infrastructure.

Add new host-python-packaging dependency.

Refresh zmq version override patch.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
James Hilliard 2022-10-25 21:11:57 -06:00 committed by Thomas Petazzoni
parent 32d8e23b97
commit 488055eb58
3 changed files with 31 additions and 18 deletions

View File

@ -1,4 +1,8 @@
detect.py: fix the ZMQ version check to the ZMQ version of the buildroot
From 8eae1193457f72899f9cc2254ae1489026df9bb6 Mon Sep 17 00:00:00 2001
From: Michael Rommel <rommel@layer-7.net>
Date: Sat, 10 Aug 2013 00:44:35 +0200
Subject: [PATCH] detect.py: fix the ZMQ version check to the ZMQ version of
the buildroot
The setup.py script tries to compile a test C program and runs it, to
retrieve a version string for the installed ZMQ library, but if the cross
@ -17,38 +21,47 @@ Flandrin.
Modified for version 18.0.2 by Asaf Kahlon
Modified for version 24.0.1 by James Hilliard
Signed-off-by: Michael Rommel <rommel@layer-7.net>
Signed-off-by: Lionel Flandrin <lionel@svkt.org>
Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
buildutils/detect.py | 14 ++++++++------
1 file changed, 8 insertions(+), 6 deletions(-)
diff --git a/buildutils/detect.py b/buildutils/detect.py
index d1380fe..4a91351 100644
index 842e3b14..e2eca744 100644
--- a/buildutils/detect.py
+++ b/buildutils/detect.py
@@ -120,13 +120,15 @@ def detect_zmq(basedir, compiler=None, **compiler_attrs):
@@ -120,18 +120,20 @@ def detect_zmq(basedir, compiler, **compiler_attrs):
cc = get_compiler(compiler=compiler, **compiler_attrs)
efile = test_compilation(cfile, compiler=cc, **compiler_attrs)
- patch_lib_paths(efile, cc.library_dirs)
+ #patch_lib_paths(efile, cc.library_dirs)
- rc, so, se = get_output_error([efile])
# add library dirs to %PATH% for windows
env = os.environ.copy()
if sys.platform.startswith("win"):
env["PATH"] = os.pathsep.join([env["PATH"]] + cc.library_dirs)
- rc, so, se = get_output_error([efile], env=env)
- if rc:
- msg = "Error running version detection script:\n%s\n%s" % (so,se)
- msg = f"Error running version detection script:\n{so}\n{se}"
- logging.error(msg)
- raise IOError(msg)
+ #rc, so, se = get_output_error([efile])
+ # if rc:
+ # msg = "Error running version detection script:\n%s\n%s" % (so,se)
- raise OSError(msg)
+ #rc, so, se = get_output_error([efile], env=env)
+ #if rc:
+ # msg = f"Error running version detection script:\n{so}\n{se}"
+ # logging.error(msg)
+ # raise IOError(msg)
+ # raise OSError(msg)
+
+ so = "vers: ##ZEROMQ_VERSION##"
handlers = {'vers': lambda val: tuple(int(v) for v in val.split('.'))}
handlers = {'vers': lambda val: tuple(int(v) for v in val.split('.'))}
--
2.20.1
2.34.1

View File

@ -1,6 +1,6 @@
# md5, sha256 from https://pypi.org/pypi/pyzmq/json
md5 200abc1a75bdcfff7adf61304f46f55e pyzmq-19.0.2.tar.gz
sha256 296540a065c8c21b26d63e3cea2d1d57902373b16e4256afe46422691903a438 pyzmq-19.0.2.tar.gz
md5 f10b7c3dee2c03557e2c5d00b73dfc7f pyzmq-24.0.1.tar.gz
sha256 216f5d7dbb67166759e59b0479bca82b8acf9bed6015b526b8eb10143fb08e77 pyzmq-24.0.1.tar.gz
# Locally computed sha256 checksums
sha256 aef3b80570351d44e29c22d080d4e9e106b34f3fdbc5cdf9636994474c72b1a2 COPYING.BSD
sha256 44b23767df3c0fe27f88981f09bc7f50a1695cec4b24252fa5f55f03e76bcd6d COPYING.LESSER

View File

@ -4,14 +4,14 @@
#
################################################################################
PYTHON_PYZMQ_VERSION = 19.0.2
PYTHON_PYZMQ_VERSION = 24.0.1
PYTHON_PYZMQ_SOURCE = pyzmq-$(PYTHON_PYZMQ_VERSION).tar.gz
PYTHON_PYZMQ_SITE = https://files.pythonhosted.org/packages/05/77/7483975d84fe1fd24cc67881ba7810e0e7b3ee6c2a0e002a5d6703cca49b
PYTHON_PYZMQ_SITE = https://files.pythonhosted.org/packages/46/0d/b06cf99a64d4187632f4ac9ddf6be99cd35de06fe72d75140496a8e0eef5
PYTHON_PYZMQ_LICENSE = LGPL-3.0+, BSD-3-Clause, Apache-2.0
# Apache license only online: http://www.apache.org/licenses/LICENSE-2.0
PYTHON_PYZMQ_LICENSE_FILES = COPYING.LESSER COPYING.BSD
PYTHON_PYZMQ_DEPENDENCIES = zeromq
PYTHON_PYZMQ_SETUP_TYPE = distutils
PYTHON_PYZMQ_DEPENDENCIES = host-python-packaging zeromq
PYTHON_PYZMQ_SETUP_TYPE = setuptools
PYTHON_PYZMQ_BUILD_OPTS = --zmq=$(STAGING_DIR)/usr
# Due to issues with cross-compiling, hardcode to the zeromq in BR