boot/syslinux: renumber patches
Also the last two are regenerated, their context has changed due to the patches that have been removed earlier. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
95e8c5eb6f
commit
4867d07d35
@ -1,4 +1,4 @@
|
|||||||
From db49dbac8a0c563fb6d07c348873e8ae50fee2a6 Mon Sep 17 00:00:00 2001
|
From 3bd5c2d951421a89f76b2423e5810862f53486c1 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
|
From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
|
||||||
Date: Fri, 9 Jun 2017 11:59:43 +0200
|
Date: Fri, 9 Jun 2017 11:59:43 +0200
|
||||||
Subject: [PATCH] Update the longjump calls to fit the new declaration
|
Subject: [PATCH] Update the longjump calls to fit the new declaration
|
||||||
@ -12,7 +12,7 @@ Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
|
|||||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||||
|
|
||||||
diff --git a/efi/main.c b/efi/main.c
|
diff --git a/efi/main.c b/efi/main.c
|
||||||
index fd95f5c..b5383cd 100644
|
index 208fee4f..71d31a5c 100644
|
||||||
--- a/efi/main.c
|
--- a/efi/main.c
|
||||||
+++ b/efi/main.c
|
+++ b/efi/main.c
|
||||||
@@ -10,7 +10,6 @@
|
@@ -10,7 +10,6 @@
|
||||||
@ -23,15 +23,15 @@ index fd95f5c..b5383cd 100644
|
|||||||
|
|
||||||
#include "efi.h"
|
#include "efi.h"
|
||||||
#include "fio.h"
|
#include "fio.h"
|
||||||
@@ -31,7 +30,7 @@ uint32_t timer_irq;
|
@@ -30,7 +29,7 @@ uint32_t timer_irq;
|
||||||
__export uint8_t KbdMap[256];
|
__export uint8_t KbdMap[256];
|
||||||
char aux_seg[256];
|
char aux_seg[256];
|
||||||
|
|
||||||
-static jmp_buf load_error_buf;
|
-static jmp_buf load_error_buf;
|
||||||
+static jmp_buf *load_error_buf;
|
+static jmp_buf *load_error_buf;
|
||||||
|
|
||||||
EFI_HANDLE image_handle, image_device_handle, mnpsb_handle;
|
static inline EFI_STATUS
|
||||||
|
efi_close_protocol(EFI_HANDLE handle, EFI_GUID *guid, EFI_HANDLE agent,
|
||||||
--
|
--
|
||||||
2.1.4
|
2.13.3
|
||||||
|
|
@ -1,4 +1,4 @@
|
|||||||
From 755c947e9166366bd1a78efb1e0c7d6e6e2daa07 Mon Sep 17 00:00:00 2001
|
From ca8aaded0c7c3900397029bd9520132b62629308 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
|
From: =?UTF-8?q?Beno=C3=AEt=20Allard?= <benoit.allard@greenbone.net>
|
||||||
Date: Mon, 12 Jun 2017 14:59:16 +0200
|
Date: Mon, 12 Jun 2017 14:59:16 +0200
|
||||||
Subject: [PATCH] efi/wrapper: build it with the host toolchain.
|
Subject: [PATCH] efi/wrapper: build it with the host toolchain.
|
||||||
@ -15,10 +15,10 @@ Signed-off-by: Benoît Allard <benoit.allard@greenbone.net>
|
|||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
diff --git a/efi/Makefile b/efi/Makefile
|
diff --git a/efi/Makefile b/efi/Makefile
|
||||||
index d3788d9..a17258a 100644
|
index d5443bd5..d24d16db 100644
|
||||||
--- a/efi/Makefile
|
--- a/efi/Makefile
|
||||||
+++ b/efi/Makefile
|
+++ b/efi/Makefile
|
||||||
@@ -78,7 +78,7 @@ syslinux.so: $(OBJS) $(CORE_OBJS) $(LIB_OBJS)
|
@@ -79,7 +79,7 @@ syslinux.so: $(OBJS) $(CORE_OBJS) $(LIB_OBJS)
|
||||||
# cp $^ $@
|
# cp $^ $@
|
||||||
|
|
||||||
wrapper: wrapper.c
|
wrapper: wrapper.c
|
||||||
@ -28,5 +28,5 @@ index d3788d9..a17258a 100644
|
|||||||
#
|
#
|
||||||
# Build the wrapper app and wrap our .so to produce a .efi
|
# Build the wrapper app and wrap our .so to produce a .efi
|
||||||
--
|
--
|
||||||
2.1.4
|
2.13.3
|
||||||
|
|
Loading…
Reference in New Issue
Block a user