package/ejabberd: bump version to 21.12
And update the patches accordingly. Also add a patch to adjust the includes to find the corresponding libraries. Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
21273da96e
commit
483b1105fd
@ -1,6 +1,6 @@
|
||||
From cb583beba1acba55112fbb4636c1c73d9ae691a0 Mon Sep 17 00:00:00 2001
|
||||
From bf3571da4a68a6a857ab7ad8256f8276b3687a38 Mon Sep 17 00:00:00 2001
|
||||
From: Johan Oudinet <johan.oudinet@gmail.com>
|
||||
Date: Fri, 20 Nov 2020 00:33:30 +0100
|
||||
Date: Fri, 13 May 2022 14:22:37 +0200
|
||||
Subject: [PATCH] Makefile.in: do not download or compile dependencies
|
||||
|
||||
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
|
||||
@ -9,27 +9,27 @@ Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile.in b/Makefile.in
|
||||
index abd64835..06f876bb 100644
|
||||
index ab0e9d967..6e54168a7 100644
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -97,7 +97,7 @@ ifneq ($(INSTALLGROUP),)
|
||||
G_USER=-g $(INSTALLGROUP)
|
||||
@@ -139,7 +139,7 @@ else
|
||||
endif
|
||||
endif
|
||||
|
||||
-all: deps src
|
||||
+all: src
|
||||
|
||||
deps: deps/.got
|
||||
deps: $(DEPSDIR)/.got
|
||||
|
||||
@@ -111,7 +111,7 @@ deps/.built: deps/.got
|
||||
$(REBAR) configure-deps
|
||||
$(REBAR) compile && :> deps/.built
|
||||
@@ -153,7 +153,7 @@ $(DEPSDIR)/.built: $(DEPSDIR)/.got
|
||||
$(CONFIGURE_DEPS)
|
||||
$(REBAR) compile && :> $(DEPSDIR)/.built
|
||||
|
||||
-src: deps/.built
|
||||
-src: $(DEPSDIR)/.built
|
||||
+src:
|
||||
$(REBAR) skip_deps=true compile
|
||||
$(REBAR) $(SKIPDEPS) compile
|
||||
|
||||
update:
|
||||
--
|
||||
2.29.2
|
||||
2.34.1
|
||||
|
||||
|
1749
package/ejabberd/0003-correct-includes.patch
Normal file
1749
package/ejabberd/0003-correct-includes.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -1,3 +1,3 @@
|
||||
# Locally computed
|
||||
sha256 9e922b938458ae9d72d4e5fdd2d08a1fbad651aae47c9a9d15b79d0bbd1e11f8 ejabberd-20.07.tgz
|
||||
sha256 b6e6739947d3678525b14ee280cedb1a04280c83ea17a4741795aac99fbdad47 ejabberd-21.12.tgz
|
||||
sha256 469bb8cfa3ef22c102875ff31932450c075e6908ff3f7d36893485c0c30898eb COPYING
|
||||
|
@ -4,7 +4,7 @@
|
||||
#
|
||||
################################################################################
|
||||
|
||||
EJABBERD_VERSION = 20.07
|
||||
EJABBERD_VERSION = 21.12
|
||||
EJABBERD_SOURCE = ejabberd-$(EJABBERD_VERSION).tgz
|
||||
EJABBERD_SITE = https://static.process-one.net/ejabberd/downloads/$(EJABBERD_VERSION)
|
||||
EJABBERD_LICENSE = GPL-2.0+ with OpenSSL exception
|
||||
@ -16,7 +16,8 @@ EJABBERD_DEPENDENCIES = getent openssl erlang-eimp host-erlang-lager \
|
||||
erlang-p1-utils erlang-p1-xml erlang-p1-xmpp erlang-p1-yaml \
|
||||
erlang-p1-zlib host-erlang-p1-utils host-erlang-p1-xmpp
|
||||
|
||||
# 0001-remove-make-targets-for-deps.patch updates Makefile.in
|
||||
# 0001-Makefile.in-do-not-download-or-compile-dependencies.patch
|
||||
# updates Makefile.in
|
||||
EJABBERD_USE_AUTOCONF = YES
|
||||
EJABBERD_AUTORECONF = YES
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user