package/mpd: fix static build issue with alsa
mpd forgets to link the archive libmixer_plugins.a against libasound leading to undefined references in a static context. Add a patch sent upstream to fix: http://autobuild.buildroot.net/results/f10/f10c6ea2d29bbcef8f33fc9ba1430e99edca895d/ http://autobuild.buildroot.net/results/312/31212c484f452fe4ea6ae084d3edefc4580830d8/ Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
31a0e3fa62
commit
47cab068fb
32
package/mpd/0003-fix-static-build-with-alsa.patch
Normal file
32
package/mpd/0003-fix-static-build-with-alsa.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From bba7b8e5fed79a7fecacf5468ade35a3ae0a0f8e Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
|
||||
Date: Sat, 21 Nov 2015 23:51:43 +0100
|
||||
Subject: [PATCH 1/1] Makefile.am: fix static build with alsa
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Add ALSA_LIBS to MIXER_LIBS, otherwise building mpd in a static context fails
|
||||
with lot of undefined references to alsa-lib (libasound) required by
|
||||
src/mixer/plugins/AlsaMixerPlugin.cxx.
|
||||
|
||||
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
|
||||
---
|
||||
Makefile.am | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 89819de..307fcba 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -1219,6 +1219,7 @@ liboutput_plugins_a_SOURCES = \
|
||||
|
||||
MIXER_LIBS = \
|
||||
libmixer_plugins.a \
|
||||
+ $(ALSA_LIBS) \
|
||||
$(PULSE_LIBS)
|
||||
|
||||
MIXER_API_SRC = \
|
||||
--
|
||||
2.6.2
|
||||
|
Loading…
Reference in New Issue
Block a user