cloop: bump and fix package
On a machine without zlib-dev installed, cloop must rely on the host-zlib compiled by Buildroot, but due to the horrible cloop build system, this didn't happen and the build was failing. Therefore, we now pass all the $(HOST_CONFIGURE_OPTS) when building cloop, and we fix the Makefile so that it takes into account CFLAGS/LDFLAGS passed in the environment or command-line and do not override them. [Peter: fix typos, remove HOST_MAKE_ENV] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
parent
6527001c9d
commit
467f221d20
30
package/cloop/cloop-2.634-1-cflags.patch
Normal file
30
package/cloop/cloop-2.634-1-cflags.patch
Normal file
@ -0,0 +1,30 @@
|
||||
Take into account the CFLAGS/LDFLAGS passed in the environment.
|
||||
|
||||
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
||||
|
||||
Index: host-cloop-2.634-1/Makefile
|
||||
===================================================================
|
||||
--- host-cloop-2.634-1.orig/Makefile 2010-12-16 09:17:52.826555645 +0100
|
||||
+++ host-cloop-2.634-1/Makefile 2010-12-16 09:18:57.208713338 +0100
|
||||
@@ -15,7 +15,7 @@
|
||||
endif
|
||||
|
||||
ifdef APPSONLY
|
||||
-CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
|
||||
+CLOOP_CFLAGS:=-Wall -Wstrict-prototypes -Wno-trigraphs -O2 -s -I. -fno-strict-aliasing -fno-common -fomit-frame-pointer
|
||||
endif
|
||||
|
||||
KERNOBJ:=compressed_loop.o
|
||||
@@ -53,10 +53,10 @@
|
||||
( cd advancecomp-1.15 ; ./configure && $(MAKE) advfs )
|
||||
|
||||
extract_compressed_fs: extract_compressed_fs.c
|
||||
- $(CC) -Wall -O2 -s -o $@ $< -lz
|
||||
+ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -Wall -O2 -s -o $@ $< -lz
|
||||
|
||||
cloop_suspend: cloop_suspend.o
|
||||
- $(CC) -o $@ $<
|
||||
+ $(CC) $(CFLAGS) $(CLOOP_CFLAGS) $(LDFLAGS) -o $@ $<
|
||||
|
||||
clean:
|
||||
rm -rf create_compressed_fs extract_compressed_fs zoom *.o *.ko Module.symvers .cloop* .compressed_loop.* .tmp*
|
@ -1,12 +1,11 @@
|
||||
CLOOP_VERSION=2.631-1
|
||||
CLOOP_VERSION=2.634-1
|
||||
CLOOP_SOURCE=cloop_$(CLOOP_VERSION).tar.gz
|
||||
CLOOP_SITE=http://debian-knoppix.alioth.debian.org/packages/sources/cloop
|
||||
|
||||
HOST_CLOOP_DEPENDENCIES = host-zlib
|
||||
|
||||
define HOST_CLOOP_BUILD_CMDS
|
||||
$(HOST_MAKE_ENV) $(MAKE1) \
|
||||
CFLAGS="$(HOST_CFLAGS) -Wall -O2 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DUSE_ERROR_SILENT" -C $(@D) APPSONLY=yes
|
||||
$(HOST_CONFIGURE_OPTS) $(MAKE1) -C $(@D) APPSONLY=yes
|
||||
endef
|
||||
|
||||
define HOST_CLOOP_INSTALL_CMDS
|
||||
|
Loading…
Reference in New Issue
Block a user