package/wine: bump to version 8.0

Multiple library checks are obsolete, either due to removal or due to built-in solutions.

License file changed due to update of copyright year.

Signed-off-by: André Zwing <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
André Zwing 2023-02-01 20:21:57 +01:00 committed by Thomas Petazzoni
parent f78c5cb5ca
commit 463d0dd494
4 changed files with 5 additions and 76 deletions

View File

@ -1,21 +0,0 @@
commit 75b70efdaa2d4baa064271098878b79f66df155f
Author: André Zwing <nerv@dawncrow.de>
Date: Sat May 21 17:53:07 2022 +0200
l3codeca.acm: Avoid mpg123 functions with suffix.
[Upstream commit: https://source.winehq.org/git/wine.git/commit/75b70efdaa2d4baa064271098878b79f66df155f]
Signed-off-by: André Zwing <nerv@dawncrow.de>
diff --git a/dlls/l3codeca.acm/Makefile.in b/dlls/l3codeca.acm/Makefile.in
index 451794b2624..31765766d4e 100644
--- a/dlls/l3codeca.acm/Makefile.in
+++ b/dlls/l3codeca.acm/Makefile.in
@@ -1,6 +1,7 @@
MODULE = l3codeca.acm
IMPORTS = $(MPG123_PE_LIBS) winmm user32 kernelbase
EXTRAINCL = $(MPG123_PE_CFLAGS)
+EXTRADEFS = -DMPG123_NO_LARGENAME
C_SRCS = \
mpegl3.c

View File

@ -1,21 +0,0 @@
commit 8d441659f7c7ae359e06a99e7abaae57792356a0
Author: André Zwing <nerv@dawncrow.de>
Date: Sat May 21 17:53:07 2022 +0200
mp3dmod: Avoid mpg123 functions with suffix.
[Upstream commit: https://source.winehq.org/git/wine.git/commit/8d441659f7c7ae359e06a99e7abaae57792356a0]
Signed-off-by: André Zwing <nerv@dawncrow.de>
diff --git a/dlls/mp3dmod/Makefile.in b/dlls/mp3dmod/Makefile.in
index dabbb1dfeae..3ba343a4d34 100644
--- a/dlls/mp3dmod/Makefile.in
+++ b/dlls/mp3dmod/Makefile.in
@@ -1,6 +1,7 @@
MODULE = mp3dmod.dll
IMPORTS = $(MPG123_PE_LIBS) dmoguids msdmo ole32 uuid wmcodecdspuuid kernelbase
EXTRAINCL = $(MPG123_PE_CFLAGS)
+EXTRADEFS = -DMPG123_NO_LARGENAME
C_SRCS = \
mp3dmod.c

View File

@ -1,5 +1,5 @@
# Locally calculated after checking pgp signature
sha256 5b43e27d5c085cb18f97394e46180310d5eef7c1d91c6895432a3889b2de086b wine-7.0.tar.xz
sha256 0272c20938f8721ae4510afaa8b36037457dd57661e4d664231079b9e91c792e wine-8.0.tar.xz
# Locally calculated
sha256 e237fa56668030e928551ddd60f05df5fe957f75eab874bbd017e085ed722e7c COPYING.LIB
sha256 7c360930e51d56c8fa12fe1df8ed348ac77a9ad73f9582a303919469399b3ce4 LICENSE
sha256 793d045546467c8f49e35fbd6e02859e57e78f8bb53571e8200bffd0e966dfa8 LICENSE

View File

@ -4,9 +4,9 @@
#
################################################################################
WINE_VERSION = 7.0
WINE_VERSION = 8.0
WINE_SOURCE = wine-$(WINE_VERSION).tar.xz
WINE_SITE = https://dl.winehq.org/wine/source/7.0
WINE_SITE = https://dl.winehq.org/wine/source/8.0
WINE_LICENSE = LGPL-2.1+
WINE_LICENSE_FILES = COPYING.LIB LICENSE
WINE_CPE_ID_VENDOR = winehq
@ -27,7 +27,6 @@ WINE_CONF_OPTS = \
--without-mingw \
--without-opencl \
--without-oss \
--without-vkd3d \
--without-vulkan
# Wine uses a wrapper around gcc, and uses the value of --host to
@ -131,20 +130,6 @@ else
WINE_CONF_OPTS += --without-v4l2
endif
ifeq ($(BR2_PACKAGE_OPENAL),y)
WINE_CONF_OPTS += --with-openal
WINE_DEPENDENCIES += openal
else
WINE_CONF_OPTS += --without-openal
endif
ifeq ($(BR2_PACKAGE_OPENLDAP),y)
WINE_CONF_OPTS += --with-ldap
WINE_DEPENDENCIES += openldap
else
WINE_CONF_OPTS += --without-ldap
endif
ifeq ($(BR2_PACKAGE_MESA3D_OSMESA_GALLIUM),y)
WINE_CONF_OPTS += --with-osmesa
WINE_DEPENDENCIES += mesa3d
@ -266,19 +251,8 @@ endif
# Wine only needs the host tools to be built, so cut-down the
# build time by building just what we need.
HOST_WINE_TOOLS = \
tools \
tools/sfnt2fon \
tools/widl \
tools/winebuild \
tools/winegcc \
tools/wmc \
tools/wrc
define HOST_WINE_BUILD_CMDS
$(foreach t, $(HOST_WINE_TOOLS),
$(HOST_MAKE_ENV) $(MAKE) -C $(@D)/$(t)
)
$(HOST_MAKE_ENV) $(MAKE) -C $(@D) __tooldeps__
endef
# Wine only needs its host variant to be built, not that it is
@ -304,10 +278,8 @@ HOST_WINE_CONF_OPTS += \
--without-gssapi \
--without-gstreamer \
--without-krb5 \
--without-ldap \
--without-mingw \
--without-netapi \
--without-openal \
--without-opencl \
--without-opengl \
--without-osmesa \
@ -318,7 +290,6 @@ HOST_WINE_CONF_OPTS += \
--without-sdl \
--without-usb \
--without-v4l2 \
--without-vkd3d \
--without-vulkan \
--without-x \
--without-xcomposite \