irrlicht: fix patches to have DOS line endings
Fixes: http://autobuild.buildroot.net/results/6260307da8acd45eb7611b08e2527a20ee5b357e/ Thanks to Romain Naour for providing the proper patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
parent
d561a02dba
commit
45bdad14e6
@ -20,25 +20,25 @@ index 0712b07..b334e9c 100644
|
||||
--- a/source/Irrlicht/Makefile
|
||||
+++ b/source/Irrlicht/Makefile
|
||||
@@ -62,7 +62,7 @@ LINKOBJ = $(IRRMESHOBJ) $(IRROBJ) $(IRRPARTICLEOBJ) $(IRRANIMOBJ) \
|
||||
###############
|
||||
#Compiler flags
|
||||
CXXINCS = -I../../include -Izlib -Ijpeglib -Ilibpng
|
||||
-CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1
|
||||
+override CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1
|
||||
CXXFLAGS += -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing
|
||||
ifndef NDEBUG
|
||||
CXXFLAGS += -g -D_DEBUG
|
||||
###############
|
||||
#Compiler flags
|
||||
CXXINCS = -I../../include -Izlib -Ijpeglib -Ilibpng
|
||||
-CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1
|
||||
+override CPPFLAGS += $(CXXINCS) -DIRRLICHT_EXPORTS=1
|
||||
CXXFLAGS += -Wall -pipe -fno-exceptions -fno-rtti -fstrict-aliasing
|
||||
ifndef NDEBUG
|
||||
CXXFLAGS += -g -D_DEBUG
|
||||
@@ -74,8 +74,8 @@ CXXFLAGS += -pg
|
||||
endif
|
||||
CFLAGS := -O3 -fexpensive-optimizations -DPNG_THREAD_UNSAFE_OK -DPNG_NO_MMX_CODE -DPNG_NO_MNG_FEATURES
|
||||
|
||||
-sharedlib sharedlib_osx: CXXFLAGS += -fPIC
|
||||
-sharedlib sharedlib_osx: CFLAGS += -fPIC
|
||||
+sharedlib sharedlib_osx: override CXXFLAGS += -fPIC
|
||||
+sharedlib sharedlib_osx: override CFLAGS += -fPIC
|
||||
|
||||
#multilib handling
|
||||
ifeq ($(HOSTTYPE), x86_64)
|
||||
endif
|
||||
CFLAGS := -O3 -fexpensive-optimizations -DPNG_THREAD_UNSAFE_OK -DPNG_NO_MMX_CODE -DPNG_NO_MNG_FEATURES
|
||||
|
||||
-sharedlib sharedlib_osx: CXXFLAGS += -fPIC
|
||||
-sharedlib sharedlib_osx: CFLAGS += -fPIC
|
||||
+sharedlib sharedlib_osx: override CXXFLAGS += -fPIC
|
||||
+sharedlib sharedlib_osx: override CFLAGS += -fPIC
|
||||
|
||||
#multilib handling
|
||||
ifeq ($(HOSTTYPE), x86_64)
|
||||
--
|
||||
2.9.3
|
||||
|
||||
|
@ -26,13 +26,13 @@ index 0899d1d..ccf5ef5 100644
|
||||
--- a/source/Irrlicht/COSOperator.cpp
|
||||
+++ b/source/Irrlicht/COSOperator.cpp
|
||||
@@ -13,7 +13,6 @@
|
||||
#include <unistd.h>
|
||||
#ifndef _IRR_SOLARIS_PLATFORM_
|
||||
#include <sys/types.h>
|
||||
-#include <sys/sysctl.h>
|
||||
#endif
|
||||
#endif
|
||||
|
||||
#include <unistd.h>
|
||||
#ifndef _IRR_SOLARIS_PLATFORM_
|
||||
#include <sys/types.h>
|
||||
-#include <sys/sysctl.h>
|
||||
#endif
|
||||
#endif
|
||||
|
||||
--
|
||||
2.9.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user