quotatool: new package
Signed-off-by: Peter Seiderer <ps.report@gmx.net> [Thomas: as suggested by Romain Naour, use QUOTATOOL_INSTALL_TARGET_OPTS to avoid installing man pages, as it fails due to a bug in the upstream package Makefile] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
parent
83d2644b11
commit
4553fea647
@ -1459,6 +1459,7 @@ F: package/libevdev/
|
||||
F: package/log4cplus/
|
||||
F: package/postgresql/
|
||||
F: package/qt5/
|
||||
F: package/quotatool/
|
||||
F: package/racehound/
|
||||
F: package/wiringpi/
|
||||
|
||||
|
@ -1997,6 +1997,7 @@ menu "System tools"
|
||||
source "package/psmisc/Config.in"
|
||||
source "package/pwgen/Config.in"
|
||||
source "package/quota/Config.in"
|
||||
source "package/quotatool/Config.in"
|
||||
source "package/rauc/Config.in"
|
||||
source "package/rsyslog/Config.in"
|
||||
source "package/runc/Config.in"
|
||||
|
@ -0,0 +1,36 @@
|
||||
From 0e096badc901f755f3bcefabdc57091725a5a0c5 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Seiderer <ps.report@gmx.net>
|
||||
Date: Thu, 1 Feb 2018 23:50:43 +0100
|
||||
Subject: [PATCH] fix missing __P definition for musl compile
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fixes:
|
||||
|
||||
In file included from src/quota.h:40:0,
|
||||
from src/parse.c:26:
|
||||
src/linux/linux_quota.h:120:15: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘__P’
|
||||
long quotactl __P((int, const char *, qid_t, caddr_t));
|
||||
^~~
|
||||
|
||||
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
|
||||
---
|
||||
src/linux/linux_quota.h | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/linux/linux_quota.h b/src/linux/linux_quota.h
|
||||
index 11f9871..2b29a89 100644
|
||||
--- a/src/linux/linux_quota.h
|
||||
+++ b/src/linux/linux_quota.h
|
||||
@@ -14,6 +14,7 @@
|
||||
#ifndef LINUX_QUOTA_H
|
||||
#define LINUX_QUOTA_H
|
||||
|
||||
+#include <sys/cdefs.h>
|
||||
#include <sys/types.h>
|
||||
#include "system.h"
|
||||
|
||||
--
|
||||
2.16.1
|
||||
|
7
package/quotatool/Config.in
Normal file
7
package/quotatool/Config.in
Normal file
@ -0,0 +1,7 @@
|
||||
config BR2_PACKAGE_QUOTATOOL
|
||||
bool "quotatool"
|
||||
help
|
||||
Quotatool is a utility to manipulate filesystem quotas from
|
||||
the commandline.
|
||||
|
||||
http://quotatool.ekenberg.se/
|
5
package/quotatool/quotatool.hash
Normal file
5
package/quotatool/quotatool.hash
Normal file
@ -0,0 +1,5 @@
|
||||
# Locally computed
|
||||
sha256 e53adc480d54ae873d160dc0e88d78095f95d9131e528749fd982245513ea090 quotatool-1.6.2.tar.gz
|
||||
|
||||
# Hash for license files:
|
||||
sha256 94686eeb98a40edc64106c6f8644068d8a08816a510a3cde75e50f1bf470564d COPYING
|
17
package/quotatool/quotatool.mk
Normal file
17
package/quotatool/quotatool.mk
Normal file
@ -0,0 +1,17 @@
|
||||
################################################################################
|
||||
#
|
||||
# quotatool
|
||||
#
|
||||
################################################################################
|
||||
|
||||
QUOTATOOL_VERSION = 1.6.2
|
||||
QUOTATOOL_SITE = http://quotatool.ekenberg.se
|
||||
QUOTATOOL_LICENSE = GPL-2.0
|
||||
QUOTATOOL_LICENSE_FILES = COPYING
|
||||
|
||||
# men="" allows to disable installing the man pages, which fails
|
||||
# because the package Makefile doesn't create the appropriate
|
||||
# directory.
|
||||
QUOTATOOL_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install men=""
|
||||
|
||||
$(eval $(autotools-package))
|
Loading…
Reference in New Issue
Block a user