package/libscrypt: bump to version 1.22

- Drop patch and use {C,LD}FLAGS_EXTRA which are available since
  bdfec26744
- While at it, also move PREFIX to LIBSCRYPT_MAKE_OPTS as advocated by
  Arnout in
  https://patchwork.ozlabs.org/project/buildroot/patch/20220221172900.1937856-1-fontaine.fabrice@gmail.com/
- Update indentation in hash file (two spaces)

https://github.com/technion/libscrypt/compare/v1.21...v1.22

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2022-03-02 00:21:11 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 6e0bf309a4
commit 4542c6714d
3 changed files with 12 additions and 40 deletions

View File

@ -1,34 +0,0 @@
From 097c5d9248f4afd34c73de5aba01a143ef784257 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Stefan=20S=C3=B8rensen?= <stefan.sorensen@spectralink.com>
Date: Tue, 14 Mar 2017 09:23:51 +0100
Subject: [PATCH] Allow adding options to CFLAGS and LDFLAGS variables
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
This also removes a number of hard-coded CFLAGS, leaving it up to the
user to pass appropriate optimization/hardening flags.
Signed-off-by: Stefan Sørensen <stefan.sorensen@spectralink.com>
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 7022a4a..3098a9a 100644
--- a/Makefile
+++ b/Makefile
@@ -5,8 +5,8 @@ MAKE_DIR ?= install -d
INSTALL_DATA ?= install
CC?=gcc
-CFLAGS?=-O2 -Wall -g -D_FORTIFY_SOURCE=2 -fstack-protector -fPIC
-LDFLAGS?=-Wl,-z,now -Wl,-z,relro -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
+override CFLAGS+=-fPIC
+override LDFLAGS+=-Wl,-z,now -Wl,-z,relro -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version
CFLAGS_EXTRA?=-Wl,-rpath=.
all: reference
--
2.7.4

View File

@ -1,3 +1,3 @@
# Locally calculated
sha256 68e377e79745c10d489b759b970e52d819dbb80dd8ca61f8c975185df3f457d3 libscrypt-1.21.tar.gz
sha256 aacbfd9e19e5b38ea09616cebf0751ef0cc7b6a19ea0fd78f4b0598b2c503394 LICENSE
sha256 a2d30ea16e6d288772791de68be56153965fe4fd4bcd787777618b8048708936 libscrypt-1.22.tar.gz
sha256 aacbfd9e19e5b38ea09616cebf0751ef0cc7b6a19ea0fd78f4b0598b2c503394 LICENSE

View File

@ -4,23 +4,29 @@
#
################################################################################
LIBSCRYPT_VERSION = 1.21
LIBSCRYPT_VERSION = 1.22
LIBSCRYPT_SITE = $(call github,technion,libscrypt,v$(LIBSCRYPT_VERSION))
LIBSCRYPT_LICENSE = BSD-2-Clause
LIBSCRYPT_LICENSE_FILES = LICENSE
LIBSCRYPT_INSTALL_STAGING = YES
LIBSCRYPT_MAKE_OPTS = \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS_EXTRA="$(TARGET_CFLAGS)" \
LDFLAGS_EXTRA="$(TARGET_LDFLAGS)" \
PREFIX=/usr
define LIBSCRYPT_BUILD_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(LIBSCRYPT_MAKE_OPTS)
endef
define LIBSCRYPT_INSTALL_STAGING_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) PREFIX=/usr \
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(LIBSCRYPT_MAKE_OPTS) \
DESTDIR=$(STAGING_DIR) install
endef
define LIBSCRYPT_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) PREFIX=/usr \
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(LIBSCRYPT_MAKE_OPTS) \
DESTDIR=$(TARGET_DIR) install
endef