Update for the latest uClibc

This commit is contained in:
Eric Andersen 2003-12-30 11:25:21 +00:00
parent df169b191c
commit 449168b8d0
2 changed files with 16 additions and 12 deletions

View File

@ -9,17 +9,20 @@
all: $(TARGETS)
--- ltp-full-20031002/testcases/kernel/syscalls/mallopt/Makefile.orig 2003-10-02 19:20:52.000000000 -0600
+++ ltp-full-20031002/testcases/kernel/syscalls/mallopt/Makefile 2003-10-02 19:21:07.000000000 -0600
@@ -23,7 +23,7 @@
LOADLIBES+= -L../../../../lib -lltp
SRCS=$(wildcard *.c)
-TARGETS=$(patsubst %.c,%,$(SRCS))
+TARGETS=#$(patsubst %.c,%,$(SRCS))
all: $(TARGETS)
--- ltp-full-20031204/testcases/kernel/syscalls/mallopt/mallopt01.orig.c
+++ ltp-full-20031204/testcases/kernel/syscalls/mallopt/mallopt01.c
@@ -85,11 +85,6 @@
flag = 1;
local_flag = FAILED;
};
- if (info.usmblks != 0) {
- fprintf(temp, "mallinfo failed: usmblks != 0\n");
- flag = 1;
- local_flag = FAILED;
- }
if (info.smblks != 0) {
fprintf(temp, "mallinfo failed: smblks != 0\n");
flag = 1;
--- ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile.orig 2003-10-02 19:27:53.000000000 -0600
+++ ltp-full-20031002/testcases/kernel/syscalls/profil/Makefile 2003-10-02 19:28:02.000000000 -0600
@@ -23,7 +23,7 @@

View File

@ -45,7 +45,8 @@ UCLIBC_HAS_THREADS=y
PTHREADS_DEBUG_SUPPORT=y
UCLIBC_HAS_LFS=y
# MALLOC is not set
MALLOC_930716=y
# MALLOC_SIMPLE is not set
MALLOC_STANDARD=y
MALLOC_GLIBC_COMPAT=y
UCLIBC_DYNAMIC_ATEXIT=y
HAS_SHADOW=y